How Do I Set Hyperfocal in Powershot S2? - General Help and Assistance on using CHDK stable releases - CHDK Forum

How Do I Set Hyperfocal in Powershot S2?

  • 10 Replies
  • 4899 Views
How Do I Set Hyperfocal in Powershot S2?
« on: 21 / May / 2008, 22:15:33 »
Advertisements
One can set hyperfocal quickly by using the arrow key (up for infinity and down for hyperfocal) while in "MF and Alt mode"

Sorry, I could not figure it out with a Powershot S2.  Anyone can help me?

Thanks
« Last Edit: 04 / June / 2008, 21:00:23 by maccow »

Re: Hyperfocal in Powershot S2
« Reply #1 on: 27 / May / 2008, 00:21:40 »
bump

and still waiting for answers

Re: How Do I Set Hyperfocal in Powershot S2?
« Reply #2 on: 04 / June / 2008, 21:00:45 »
Bump one more time

Re: How Do I Set Hyperfocal in Powershot S2?
« Reply #3 on: 11 / June / 2008, 11:09:24 »
Hi,

I checked this on my A720IS (Allbest 51) and it works great.  Thanks to you I now know about a great feature.  Sorry about your problem with the S2.

Jon


Re: How Do I Set Hyperfocal in Powershot S2?
« Reply #4 on: 12 / June / 2008, 12:03:48 »
Glad to know it works for you.

For my S2, after turning on Alt(Press the shortcut key on S2) and MF (the mannual focus button), whenever I press the UP or DOWN key, the camera is shutting off.  I tried P, Av, Tv, M and C mode, they all behave the same.

I am afraid that I did something stupid here but can not figure it out myself.

Re: How Do I Set Hyperfocal in Powershot S2?
« Reply #5 on: 12 / June / 2008, 12:16:59 »
One more observation, when I press the Down Key, the camera retracts to a position that probably is for hyperfocal (not all the way back).  Unfortunately, the camera is shut off as well. No LCD or view finder display, the power on button indictes the camera is off as well.

Is there a bug here in S2?  Maybe GRAND can help?
« Last Edit: 12 / June / 2008, 12:18:35 by maccow »

Re: How Do I Set Hyperfocal in Powershot S2?
« Reply #6 on: 01 / July / 2008, 20:07:27 »
I'm using Allbest build 50 on my S2. There is something weird going on with the hyperfocal distance calculations & settings. I haven't suffered the shutdown problems mentioned above, but have some serious issues with the hyperfocal functions of the software. Also I think you need to select MF before pressing ALT. Pressing MF whilst in ALT mode did nothing on my S2.

I don't have the full list to hand at the present time - I'll post it when I get back to the PC I stored it all on.

The hyperfocal distance is reported as infinity on many occasions. This doesn't appear to be due to the hyperfocal distance being greater than any particular value (I have calculated what the hyperfocal distance should be from the aperture & focal length & CoC=0.005). e.g. a hyperfocal distance of say 46m might be reported for a particular setting (f/8 43mm focal length), but then 'inf' might be reported for another f-stop / focal length setting combination when the hyperfocal distance is the same or less than this value (46m). [these are just indicative numbers to illustrate the point - not actual results - I'll post the true results I have later]

When the hyperfocal distance is selected to be shown in the misc values table on the display the true hyperfocal distance is only shown when shoot is half or fully pressed. This would appear to be due to the aperture being used in the calculation being the actual aperture rather than the set aperture. As the set aperture is only used when shoot is at least half depressed (i.e. the aperture on the camera is fully open when shoot is not being pressed) the true hyperfocal distance is not shown on the display, along with the the other misc values until shoot is pressed. It appear that the down key thus doesn't set the hyperfocal distance correctly.

I'm also wanting to use the hyperfocal setting for IR photography. With this in mind it would be good to be able to set an offset to the hyperfocal distance for use when shooting IR, once the focussing offset between visible & IR has been worked out for the camera.
« Last Edit: 01 / July / 2008, 20:45:09 by andrewb »

Re: How Do I Set Hyperfocal in Powershot S2?
« Reply #7 on: 04 / July / 2008, 01:00:33 »
Hi Andrewb,

What is the firmware version of your S2? (mine 1.00f).  Even I turn MF first and then Alt, it is the same story for my camera.

Thanks for your input here.


Re: How Do I Set Hyperfocal in Powershot S2?
« Reply #8 on: 04 / July / 2008, 02:16:03 »
I have the 'g' firmware

Re: How Do I Set Hyperfocal in Powershot S2?
« Reply #9 on: 04 / July / 2008, 11:21:20 »
thanks

 

Related Topics