supplierdeeply

Sporadic RAW images

  • 31 Replies
  • 9921 Views
*

Offline dzsemx

  • ****
  • 302
  • [SX40HS][A650][A630]
  • Publish
    Re: Sporadic RAW images
    « Reply #10 on: 12 / July / 2008, 18:44:17 »
    Advertisements
    @Hacki: you're genious :lol

    *

    Offline true

    • *
    • 35
    • SX230, SX260, 5DmkII, and more :)
  • Publish
    Re: Sporadic RAW images
    « Reply #11 on: 12 / July / 2008, 23:43:02 »
    Yeah, I was confused too... had to put it together.

    There really should be a proper icon for +/- in the wiki, or it should be called Exposure or Exposure Compensation button (I think that's what the Canon manual calls it...right?)
    Canon P&S: 110HS, SX260HS, SX230HS, 2x A720 IS, 2x A590 IS
    Canon DSLR: 5D Mark II, 300D IR-converted, 8x glass
    MFT: DMC-GF1, DMC-G3, 7x glass

    *

    Offline LjL

    • ****
    • 266
    • A720IS
  • Publish
    Re: Sporadic RAW images
    « Reply #12 on: 13 / July / 2008, 07:51:53 »
    Except my camera didn't even COME with a manual, so who cares what they call it! :D

    I'd call it the "Whatever-is-relevant-key", since it does just about anything depending on the context...

  • Publish
    Re: Sporadic RAW images
    « Reply #13 on: 20 / July / 2008, 20:19:11 »
    I have noticed exactly the same behavior on my A650IS.  It seems to be related to how quickly the shutter release button is depressed. Hit it quickly and no raw file is written.  Push slowly - so the green focus box and data appears - and the raw file gets written.

    Feature or bug?


  • Publish
    Re: Sporadic RAW images
    « Reply #14 on: 21 / July / 2008, 00:25:05 »
    I took about 40 photo's this weekend.  All except 5 had RAW pairs.  I did not hit the +/- button at all.  So yes, there is something weird going on.  Is it the A650 IS only?
    A650 IS w/waterproof housing, SanDisk Extreme III 2GB card

    *

    Offline ewavr

    • ****
    • 1057
    • A710IS
  • Publish
    Re: Sporadic RAW images
    « Reply #15 on: 21 / July / 2008, 09:54:22 »
    I have noticed exactly the same behavior on my A650IS.  It seems to be related to how quickly the shutter release button is depressed. Hit it quickly and no raw file is written.  Push slowly - so the green focus box and data appears - and the raw file gets written.

    Feature or bug?

    The same behavior of A630  has noted Allbest in russian forum. This is generic bug.
    Unfortunately,  ;)  on A710 no such bug - even if shutter button pressed quickly, camera is focused and RAW is saved.

    *

    Offline LjL

    • ****
    • 266
    • A720IS
  • Publish
    Re: Sporadic RAW images
    « Reply #16 on: 22 / July / 2008, 13:43:42 »
    My A720IS doesn't seem to have this problem, and there are no "is the shutter button pressed?" checks in the raw saving code; shooting_in_progress() is checked, although even this only kicks in if "Save only first RAW in series" is selected (see raw.c:47 and main.c:120) and I have strangely similar problems in the BSS code.

    See this other thread, I think it might be the same problem, consider merging.

    *

    Offline fe50

    • ******
    • 3033
    • IXUS50 & 860, SX10 Star WARs-Star RAWs
      • fe50
  • Publish
    Re: Sporadic RAW images
    « Reply #17 on: 22 / July / 2008, 15:29:23 »
    Could there be a Canon background task running which blocks the access to the files on some situations, perhaps something like an indexing mechansim or a communication with the card controller ?


    *

    Offline ewavr

    • ****
    • 1057
    • A710IS
  • Publish
    Re: Sporadic RAW images
    « Reply #18 on: 22 / July / 2008, 16:00:36 »
    Could there be a Canon background task running which blocks the access to the files on some situations, perhaps something like an indexing mechansim or a communication with the card controller ?

    Hmm... Allbest wrote in russian forum that capt_seq_hook_raw_here() not called in all in this case.

    *

    Offline DougC

    • *
    • 11
  • Publish
    Re: Sporadic RAW images
    « Reply #19 on: 22 / July / 2008, 20:40:52 »
    I just saw this thread and I've been experiencing the same problem with my G7.  I went to a car show over the weekend and took about 40 pictures but only got about 30 CRW files.  I'm pretty sure I didn't accidentally disable RAW mode with the shortcut.

    Incidentally, I discovered a bug in the Allbest firmware, at least for the G7.  No CRW files are generated if the flash is set to OFF.  AUTO or ON are okay, though.

    Doug
    Canon G7

     

    Related Topics