A550 Porting...

  • 95 Replies
  • 17366 Views
*

Offline muttley

  • **
  • 51
  • + pilu x tutti!
    • A550 Porting
  • Publish
    !!Release Date!!
    « Reply #30 on: 28 / January / 2008, 10:12:50 »
    Advertisements
    The time is come!!  :D

    Some changes from my last update:

    1- The CHDK Porting now run!  :)
    2- Modified capt_seq.c with correct fuction take by IDA.
    3. The same with movie_rec.c, now work video recording with quality or bitrate variable (i think).
    4- Property case are equal to a560/a570...I'll verify several.
    5- Keymap it's ok...based on a540.
    6- Modemap is 'working in progress', now it's copied form a560. Modified mode_get() in main.c...
    8- Others don't remember.
    7- Fixed some small bugs.

    IT'S VERY IMPORTANT YOUR UTILIZATION REPORT FOR FIND BUGS, PROBLEM AND STRANGE BEHAVIORS!
    POST HERE ALL YOUR COMMENT, THANK!

    ...now enjoy with your new chdk features: CHDK for a550.rar - 0.19MB

    « Last Edit: 28 / January / 2008, 10:14:42 by muttley »

  • Publish
    Re: A550 Porting...need help
    « Reply #31 on: 28 / January / 2008, 10:29:15 »
    Sweet, I'm still waitin for my cam to get back, but I'll start testing as soon as it does.

    Thanks a ton, Maybe now its possible to see everything that needs to be changed for CHDK to run, so maybe the wiki can get a proper porting guide that is complete.

    Tom

  • Publish
    Re: A550 Porting...need help
    « Reply #32 on: 28 / January / 2008, 11:02:41 »
    Great job! Too bad it's around midnight in my country. I was able to save it and take a few shots. I'll do a lot more testing tomorrow. Thanks a lot!

  • Publish
    Re: A550 Porting...need help
    « Reply #33 on: 28 / January / 2008, 11:54:52 »
    Still fiddling around with the camera. Has anyone tried getting scripts to work? I get this red error on top that says "uBasic:1 Unk stmt" whenever I try some of the bracketing scripts on the wiki.

    edit: Some of the bracketing scripts work but they don't change the exposure at all.
    « Last Edit: 28 / January / 2008, 12:02:09 by synthesilica »


    *

    Offline muttley

    • **
    • 51
    • + pilu x tutti!
      • A550 Porting
  • Publish
    Re: A550 Porting...need help
    « Reply #34 on: 28 / January / 2008, 16:26:10 »
    Quote
    Thanks a ton, Maybe now its possible to see everything that needs to be changed for CHDK to run, so maybe the wiki can get a proper porting guide that is complete.

    Thank, thank JTLG  8) ...but test my realease before express gratitude :P

    I hope finish soon my wiki/porting page...but I'm very busy at the moment...and I also would study some guide "photography for dummies" because i'm a classical user that set his cam in AUTO mode   :lol

    synthesilica is it no too late for try chdk?!  :haha
    sorry, but in italy (my country) was 4:00 PM...

    mhhh... thank for error reporting!

    I tried some script and many worked fine. For bracketing i see also focus don't work...I'm sure that work ISO bracketing at the moment!

    one hit:
    try bracketing in Extra Photo Operations > Bracketing in Continuous Mode (firmware is Allbest)

    a last thing:
    I have created a section named 'Bugs Report' in a550 wiki page and add your report.
    For next one everyone can add it to wiki and then explain in detail on this forum
     

  • Publish
    Re: A550 Porting...need help
    « Reply #35 on: 28 / January / 2008, 18:17:57 »
    Got it up and running about 1/2 hour ago, looks good sofar, I'm working on any bugs, haven't found any yet though.

    NICE!!!

    I was playing the games a minute ago, it seems kind of funny, playing games on a camera.  :D

    Great job Muttley!!!

    Tom

  • Publish
    Re: A550 Porting...need help
    « Reply #36 on: 29 / January / 2008, 05:59:08 »
    found another bug. The zebra stripes are shifted off to the side. They're not aligned properly with the image. Just put it on the wiki.

    *

    Offline ynaig

    • *
    • 11
    • Canon Powershot A550
  • Publish
    Re: A550 Porting...need help
    « Reply #37 on: 29 / January / 2008, 15:26:45 »
    Another bug, I don't know if that can be classified as a bug.

    When enabling the macro mode, and trying to run the interval or interval-video scripts, it won't run correctly, meaning it won't take shots.

    Ynaig


  • Publish
    Re: A550 Porting...need help
    « Reply #38 on: 30 / January / 2008, 07:11:37 »
    THANKS muttley!!!
    it works :)

    If possible post your modified capt_seq.c :)

    *

    Offline muttley

    • **
    • 51
    • + pilu x tutti!
      • A550 Porting
  • Publish
    Re: A550 Porting...need help
    « Reply #39 on: 30 / January / 2008, 09:55:58 »
    Good works!

    Give me some times for solve bugs!

    I had posted on ZShare and add in Wiki page, archive with Source of my porting...if someone would help the comunity...

    Always report all progress!

    APPEAL: If there is anyone that have good know of CHDK and He can suggest WHERE (point of source, function or any idea) the bug creep inside!  :'(

     

    Related Topics