supplierdeeply

IXUS55 (SD450) scripts freezing.

  • 8 Replies
  • 3403 Views
*

Offline Gregsy

  • *
  • 2
  • IXUS55
IXUS55 (SD450) scripts freezing.
« on: 01 / October / 2008, 15:18:23 »
Advertisements
Hi all.

I've been trying out CHDK for a few months now, mainly for control of exposure times, I don't need to tell you how brilliant it is.

Recently I've tried to use some scripts, I've built a small USB remote for use with my telescope for astrophotography. I've tried quite a few remote shutter scripts, HDR script and motion detection scripts.

All of these scripts start ok and take a picture but then the camera freezes/locks up. I then have to press the shutter button to stop the script. Sometimes pressing the alt button with move the script on (works on the HDR script but only 1 photo is taken). This happens with all the scripts I've tried. I've also tried changing the "shoot" command to "shoot_full" which I read in another post but with exactly the same results.

My camera is an IXUS55 (SD450) firmware 1.00d. I've only tried the allbest builds (3 releases so far, using the newest now).

Has anyone had similar problems and is there a fix? This is driving me mad.

Regards

Gregsy

*

Offline fe50

  • ******
  • 3038
  • IXUS50 & 860, SX10 Star WARs-Star RAWs
    • fe50
Re: IXUS55 (SD450) scripts freezing.
« Reply #1 on: 01 / October / 2008, 15:30:05 »
Hello & welcome Gregsy !

you should try it with disabled flash (OFF) in manual mode, this behaviour was reported sometimes when the flash was ON or AUTO...

You can use a workaround for the shoot command: emulate half-press, wait until the cam is ready / has focused, then do a full-press...something like this:

press "shoot_half"
sleep 2000
press "shoot_full"
sleep 2000

*

Offline Gregsy

  • *
  • 2
  • IXUS55
Re: IXUS55 (SD450) scripts freezing.
« Reply #2 on: 02 / October / 2008, 04:57:42 »
Hi fe50,

Thanks for the very quick reply. I had tried the scripts before with the flash off (mentioned in another topic) but I hadn't tried in manual mode. Unfortunately it still didn't work.

I tried incorporating your workaround into the scripts in various ways but all with the same results. The HDR script tried to take more than 1 photo and stepped through the script but only 1 picture was taken when complete.

Does anyone have scripts specifically written for the IXUS55 (or are they universal to all models)?

Cheers

Gregsy

Re: IXUS55 (SD450) scripts freezing.
« Reply #3 on: 02 / November / 2008, 15:12:01 »
Hello all,

I'm facing the same problem with my SD450 (IXUS 55). It shoots the first picture and then just stops, even after incorporating the script change mentioned above.

Has anyone found a solution?

Thanks.

Hi fe50,

Thanks for the very quick reply. I had tried the scripts before with the flash off (mentioned in another topic) but I hadn't tried in manual mode. Unfortunately it still didn't work.

I tried incorporating your workaround into the scripts in various ways but all with the same results. The HDR script tried to take more than 1 photo and stepped through the script but only 1 picture was taken when complete.

Does anyone have scripts specifically written for the IXUS55 (or are they universal to all models)?

Cheers

Gregsy


Re: IXUS55 (SD450) scripts freezing.
« Reply #4 on: 02 / November / 2008, 16:34:27 »
I found a solution that worked for me. Using Ultra Intervalometer as a base, I just changed the "shoot" to "click "shoot_full"".

I give credit to xnau in this thread: Ixus 55 / SD450: First beta version of CHDK port available for 1.00B and 1.00C

Hello all,

I'm facing the same problem with my SD450 (IXUS 55). It shoots the first picture and then just stops, even after incorporating the script change mentioned above.

Has anyone found a solution?

Thanks.

Hi fe50,

Thanks for the very quick reply. I had tried the scripts before with the flash off (mentioned in another topic) but I hadn't tried in manual mode. Unfortunately it still didn't work.

I tried incorporating your workaround into the scripts in various ways but all with the same results. The HDR script tried to take more than 1 photo and stepped through the script but only 1 picture was taken when complete.

Does anyone have scripts specifically written for the IXUS55 (or are they universal to all models)?

Cheers

Gregsy

*

Offline gtrecordings

  • *
  • 18
  • sd550
    • three-rings
Re: IXUS55 (SD450) scripts freezing.
« Reply #5 on: 05 / November / 2008, 15:59:21 »
so... how would that look for the remote script....? i have the sd550

*

Offline gtrecordings

  • *
  • 18
  • sd550
    • three-rings
Re: IXUS55 (SD450) scripts freezing.
« Reply #6 on: 07 / November / 2008, 15:44:24 »
Code: [Select]
@title GT Remote

:loop
 wait_click 1
 is_key k "remote"
 if k=1 then click "shoot_full"
goto "loop"

end

you can name it what ever you want, but i ran this through the debuger and it seems to work now.  thanks yosemite_sam

Re: IXUS55 (SD450) scripts freezing.
« Reply #7 on: 09 / December / 2008, 09:53:05 »
I just changed the "shoot" to "click "shoot_full"".

AMAZING
I had been trying to figure this out for a while
THANK YOU!!!!


*

Offline fe50

  • ******
  • 3038
  • IXUS50 & 860, SX10 Star WARs-Star RAWs
    • fe50
Re: IXUS55 (SD450) scripts freezing.
« Reply #8 on: 09 / December / 2008, 15:37:11 »
Hmm - the Ixus 55 still has the shoot issue (described very well here: Problem with SCRIPT_WAIT_SAVE in the Ixus55 port).

As described there we could remove the check for propcase 205, it works well with a safe value for 'Script Shoot Delay', e.g. 10 or 20 (tested & documented in the german forum, IXUS und der shoot - Befehl).

Substitute shoot with click xxxx works in most cases, but you have to adapt the script...

 

Related Topics