s-series - enable flash during video recording for still images (in trunk now!) - page 3 - General Discussion and Assistance - CHDK Forum supplierdeeply

s-series - enable flash during video recording for still images (in trunk now!)

  • 38 Replies
  • 10401 Views
*

Offline PhyrePhoX

  • *****
  • 2254
  • make RAW not WAR
    • PhyreWorX
Advertisements
well i am already doing it in main.c after "if (raw_need_postprocess) raw_postprocess();"
but it seems to be too fast. because after raw_postprocess the jpg hasnt been written yet. i guess i have to run some kind of "watchdog" for example in gui.c that checks some variables and resets them if need be. but theres has gotta be some way to call something after the jpg has been written, no?

*

Offline ewavr

  • ****
  • 1057
  • A710IS
but theres has gotta be some way to call something after the jpg has been written, no?

Properycase can be restored after jpeg creation (from RAW), jpeg saving procedure can lengthen many seconds after shoot (if continuous mode is on and card is slow).

*

Offline PhyrePhoX

  • *****
  • 2254
  • make RAW not WAR
    • PhyreWorX
after jpg creation (from raw) <--  i'm afraid i dont understand that O_o

*

Offline PhyrePhoX

  • *****
  • 2254
  • make RAW not WAR
    • PhyreWorX
by the way here is another video that uses this new technique in conjunction with motion detection: Motion Detection in the bathtub - CHDK in action on Flickr - Photo Sharing! as you see the whitebalance in the video is off, thats really annoying me. but i will find out how & where to set/reset it, so i can produce actual footage one can work with.
amazing that motion detection works in video mode (used fudgeys one-script-fits-all script), though in the video it failes once (guess i should have waited  a bit longer between shots).


wait so does this work?  can this be integrated into the latest version of chdk? 

sweet!  i just realized that the newest version of chdk adds the flash feature for videos.

thanks.  but i'm not sure how to operate the flash during the video. 
1) i enabled the flash for the video
2) hit the record button
3) entered into the script mode for motion detection
4) it took a picture
5) it took another picture
6) it crashed.

hahaha.  awesome

tried it again when recording  (shooting on an s5, i believe in your video you were shooting with an s3, so the script might have to be adjusted for this?)


1 precharged flash
2 started video
3 ran MD script
4 tripped the image
5 camera shut off

fyi i'm using fudgey's lightning script.  i can't get the flash to fire during the video with any of the other scripts.  standard motion detection does not trip flash during the video.  what am i doing wrong?  flash output is at 1


*

Offline PhyrePhoX

  • *****
  • 2254
  • make RAW not WAR
    • PhyreWorX
hm, does it work without a script? did you unpop the flash?

it doesn't work even with no script running.  the only time the flash will fire is during the fudgey lightning motion detection script, however running that script simultaneously during video causes the camera to shut down.

there must be a minor code tweak somewhere that doesn't apply to the s5 as does the s3.

 

Related Topics