the sx10 porting thread

  • 613 Replies
  • 141028 Views
  • Publish
    Re: Is CHDK for SX10 possible in the future
    « Reply #40 on: 28 / February / 2009, 15:11:58 »
    Advertisements
    Actually, right now all I need is the ability to run scripts and I'd be happy.

    *

    Offline reyalp

    • ******
    • 9858
  • Publish
    Re: Is CHDK for SX10 possible in the future
    « Reply #41 on: 28 / February / 2009, 15:41:27 »
    Don't forget what the H stands for.

  • Publish
    Re: Is CHDK for SX10 possible in the future
    « Reply #42 on: 28 / February / 2009, 16:21:48 »
    Sorry, I was not trying to commercialize CHDK or violate GPL licensing. My misunderstanding.
    « Last Edit: 28 / February / 2009, 16:27:54 by gsbergman »

  • Publish
    Re: Is CHDK for SX10 possible in the future
    « Reply #43 on: 01 / March / 2009, 00:30:13 »
    I think it is a great idea and would donate too since I own a SX10.  The problem is CHDK is really just a few developers scattered around the world and there is no central organization.  The donations could be given to anyone who successfully completes a port but this also raises a whole host of other issues because no developer currently owns a SX10, etc.


  • Publish
    Re: Is CHDK for SX10 possible in the future
    « Reply #44 on: 01 / March / 2009, 02:48:27 »
    « Last Edit: 01 / March / 2009, 02:50:02 by galocza »

  • Publish
    Re: Is CHDK for SX10 possible in the future
    « Reply #45 on: 04 / March / 2009, 17:03:02 »
    This thread makes me sad. :( I'll keep hope alive that one day it will happen!

    *

    Offline ewavr

    • ****
    • 1057
    • A710IS
  • Publish
    Re: Is CHDK for SX10 possible in the future
    « Reply #46 on: 11 / March / 2009, 08:23:38 »
    Porting started for 1.01A.
    For developers - current sources - http://ewavr.nm.ru/chdk/for_test/sx10.zip
    Not usable yet for practical use.
    « Last Edit: 11 / March / 2009, 14:51:10 by ewavr »

  • Publish
    Re: Is CHDK for SX10 possible in the future
    « Reply #47 on: 11 / March / 2009, 12:07:34 »
    HOPE!


    *

    Offline fe50

    • ******
    • 3033
    • IXUS50 & 860, SX10 Star WARs-Star RAWs
      • fe50
  • Publish
    Re: Is CHDK for SX10 possible in the future
    « Reply #48 on: 11 / March / 2009, 18:48:55 »
    Porting started for 1.01A.
    For developers - current sources - http://ewavr.nm.ru/chdk/for_test/sx10.zip
    Not usable yet for practical use.

     :xmas - great news !

    I'm a bit busy atm, so i've just compiled (patched #716, gcc 3.4) it & did some short tests...wow, an absolutely fine "first shoot" !

    Keyboard, menu, OSD, alternative Shortcut (flash key), TV bracketing, scripting, Flashlight, Zebra, Histo, USB remote (PC test)
    ...works great (and IS already usable for practical use) !!!
    I hope i can do more testing tomorrow.

    THX ewavr, damned good work !   ... btw - do you own a SX10 now ?

    *EDIT:
      DNG works fine (with badpixel.lua; <5000 badpixels on my cam), saving time ~ 3,5 seconds,
      good colors, EXIF data is ok, opens with PS3, PS4, XNView, UFRAW/GIMP, Picasa, Pain.NET...
     
      Also tested (short): Games, Filebrowser, Textfile reader; llibtst.lua runs without errors (logfile attached)

      I've attached the compiled binaries (the "complete" package) for the other SX10 1.01A users...
    « Last Edit: 11 / March / 2009, 19:37:08 by fe50 »

    *

    Offline ewavr

    • ****
    • 1057
    • A710IS
  • Publish
    Re: Is CHDK for SX10 possible in the future
    « Reply #49 on: 11 / March / 2009, 20:23:26 »
    THX ewavr,
    Many thanks to reyalp for his SD990 code.
    Quote
    btw - do you own a SX10 now ?
    No, this camera is too big, heavy and expensive for me. I love my a710  :).

    Quote
    DNG works fine (with badpixel.lua; <5000 badpixels on my cam), saving time ~ 3,5 seconds,  good colors
     
    Color matrix from other camera (s5is?). I see that 'RAW buffer cached' option has no effect in this camera.
    Now I see two bugs:
    - 'force manual flash' don't work in video (I will look on this later)
    - NR works incorrectly in Tv override mode. For example, if camera Tv=1/10s and CHDK Tv=5s, no dark frame will be subtracted (NR is set to 'auto'). I have no idea how to fix it  :(.
    Quote
    I've attached the compiled binaries
    Very many things not done yet.


     

    Related Topics