supplierdeeply

the sx10 porting thread

  • 613 Replies
  • 142278 Views
*

Offline fe50

  • ******
  • 3034
  • IXUS50 & 860, SX10 Star WARs-Star RAWs
    • fe50
  • Publish
    Re: the sx10 porting thread
    « Reply #120 on: 20 / March / 2009, 20:20:23 »
    Advertisements
    What should be the ideal allocation sizes?
          (creates a small 2MB partition + a big one with the rest)
    ;)

    And does volume name have any role?
    No, the name doesn't matter.

    *

    Offline fe50

    • ******
    • 3034
    • IXUS50 & 860, SX10 Star WARs-Star RAWs
      • fe50
  • Publish
    Re: the sx10 porting thread
    « Reply #121 on: 20 / March / 2009, 20:37:57 »
    @ewavr
    The flash override works also in the ISO3200 scene mode, but only after a shoot & without releasing the shutter.
    A nice & extremly fast test setup:
    - ISO override, e.g. set to 100
    - force flash on, lowest intensity 0
    - ISO3200 scene mode, continuous mode or custom timer
    - half-press, full-press for one shot, release-half
    - full-press shutter again
    ...gives you nice 2M sized images with full ISO3200-mode speed (~3-4 pps), all with flash  :o
    Bracketing works this way, too...

    In Video mode the flash override is not yet working, with the release-half+press-full again - method the cam powers off
    (Maybe the issue you discovered while porting, the full-press / half+full press thing ?)
    « Last Edit: 20 / March / 2009, 20:58:59 by fe50 »

    *

    Offline R0Y.1

    • *
    • 14
    • R0Y.1
  • Publish
    Re: the sx10 porting thread
    « Reply #122 on: 20 / March / 2009, 21:40:34 »
    I was talking about the cluster sizes...

    *

    Offline PhyrePhoX

    • *****
    • 2253
    • make RAW not WAR
      • PhyreWorX
  • Publish
    Re: the sx10 porting thread
    « Reply #123 on: 21 / March / 2009, 05:07:48 »
    @ewavr

    In Video mode the flash override is not yet working, with the release-half+press-full again - method the cam powers off
    (Maybe the issue you discovered while porting, the full-press / half+full press thing ?)

    sounds like the same issue as on the s5is - see http://chdk.setepontos.com/index.php/topic,2444.msg27666.html#msg27666 (and all following posts).


    *

    Offline R0Y.1

    • *
    • 14
    • R0Y.1
  • Publish
    Re: the sx10 porting thread
    « Reply #124 on: 21 / March / 2009, 14:34:31 »
    CHDK did the partition, but I can only format the first 2MB one. The second partition can't be formatted. XP says it should be "enabled" by rebooting but that doesn't work. Help please...

    *

    Offline fe50

    • ******
    • 3034
    • IXUS50 & 860, SX10 Star WARs-Star RAWs
      • fe50
  • Publish
    Re: the sx10 porting thread
    « Reply #125 on: 21 / March / 2009, 14:58:05 »
    CHDK did the partition, but I can only format the first 2MB one. The second partition can't be formatted. XP says it should be "enabled" by rebooting but that doesn't work. Help please...

    That's the normal M$ Windows behaviour, the driver for such devices don't support multiple partitions ;)

    Copy the CHDK PS.FI2 file to the small 2MB FAT12 partition, start CHDK, call "Swap partitions" from the Misc menu, exit <Alt> mode and power the camera off.

    Now you have access to the 2nd partition (and only this one !), you can format (FAT32 with default cluster size), copy files etc.
    If you start from the "big" FAT32 partition, the CHDK autoboot do not work - but you can start CHDK with the firmware update method, so you always can run CHDK & use it's "Swap partitions" function...

    Another way for Windows user is to use the sdminste.exe, that's the small installer app from the SDM - you'll find it on the SDM Homepage in the "Common files" package...
    When using the sdm installer you should always double check the drive letter before you press any button !

    You can also use a special, modified hard disc driver for your card reader to access the drive like a hard disc...http://mind-fields-ahead.blogspot.com/2008/04/canon-s5-is-chdk-hack-step-by-step.html

  • Publish
    Re: the sx10 porting thread
    « Reply #126 on: 22 / March / 2009, 02:46:00 »
    To everyone who has made CHDK for the SX10-

    Thank you so much for all of your work and for everything you have done!  I love my camera so much more now and I am having a blast exploring what CHDK can do!!!

     :)

  • Publish
    Re: the sx10 porting thread
    « Reply #127 on: 22 / March / 2009, 02:56:46 »
    HEY! i had a question, but i dont know if it goes in this thread or not.

    When i go and put my microsd in the card reader [adapter in my case] and then the window pops up so i can copy the files over using card tricks and stuff. so when i select my card and click ok and click the button on cardtricks to make it bootable and transfer chdk onto it.. it freezes.

    and then i tried it manually.. to transfer the files onto the card from windows explorer thingy but then my computer freezes.. and the only way to unfreeze it is to pull the adapter out.

    any help?

    also.. my camera is the sx10 is and the card size is 4gigs

    also... it says SDHC on it.. and in tiny letters it says turbo.. i don't know if that makes a difference or not..
    « Last Edit: 22 / March / 2009, 03:20:32 by Racial »


    *

    Offline whim

    • ******
    • 2013
    • A495/590/620/630 ixus70/115/220/230/300/870 S95
  • Publish
    Re: the sx10 porting thread
    « Reply #128 on: 22 / March / 2009, 04:08:31 »
    Quote
    also... it says SDHC on it.. and in tiny letters it says turbo.. i don't know if that makes a difference or not..

    that's typical behaviour if your card reader doesn't support SDHC ...
    i fully agree Windows should tell you instead of just f***ing up .

    wim

  • Publish
    Re: the sx10 porting thread
    « Reply #129 on: 22 / March / 2009, 05:05:59 »
    My camera model is the SX10, versions are GM1.01B. CHDK temporarily do not have this version of the procedure can be used. Please help develop this version of the procedure

     

    Related Topics