Delay the flash untill a button is pressed, during long exposure

  • 32 Replies
  • 7484 Views
*

Offline ewavr

  • ****
  • 1057
  • A710IS
  • Publish
    Re: Delay the flash untill a button is pressed, during long exposure
    « Reply #10 on: 27 / November / 2008, 16:03:26 »
    Advertisements
    do you think you can also help here: s-series - enable flash during video recording for still images ?

    Maybe these functions cannot help here.
    How about override flash (on/off) state in shooting_expo_param_override():

     int xxx=1;
     _SetPropertyCase(79, &xxx, sizeof(xxx)); // for digic2

    , like "rear curtain override" in last builds?

    This works on A710 (flash fired, even if flash is turned off manually), but without preflash (flash power must be adjusted manually).
    « Last Edit: 27 / November / 2008, 17:01:28 by ewavr »

    *

    Offline PhyrePhoX

    • *****
    • 2253
    • make RAW not WAR
      • PhyreWorX
  • Publish
    Re: Delay the flash untill a button is pressed, during long exposure
    « Reply #11 on: 27 / November / 2008, 17:34:57 »
    huh? 79? i thought 16 sets the mode? i tested a few weeks ago with propcase 16, and yes, it worked - not in movie mode though. setting prop 16 to 1 in a script worked fine, even when i disabled flash via the flash button. hm, 79? gonna test it tomorrow.
    may i ask how you found 79? didnt find it in source nor in the wiki O_o

    *

    Offline ewavr

    • ****
    • 1057
    • A710IS
  • Publish
    Re: Delay the flash untill a button is pressed, during long exposure
    « Reply #12 on: 27 / November / 2008, 18:01:03 »
    may i ask how you found 79? didnt find it in source nor in the wiki O_o
    Using camera and propertycase browser ;).
    Now #78 used as PROPCASE_FLASH_FIRED for EXIF creation in DNG shooting, but maybe this is read-only value.
    #79 is R/W and also can be used as PROPCASE_FLASH_FIRED.

    *

    Offline PhyrePhoX

    • *****
    • 2253
    • make RAW not WAR
      • PhyreWorX
  • Publish
    Re: Delay the flash untill a button is pressed, during long exposure
    « Reply #13 on: 27 / November / 2008, 18:41:32 »
    tried following script during video recording:
    Quote
    rem flash setting
    @title flash
    @param a off or on
    @default a 1
    @param b off or on
    @default b 1
    set_prop 79 a
    set_prop 16 b
    doesnt work :( still doesnt fire flash when i press the shutter.

    btw in your video, did you fire the flash during recording on the same camera? so power isnt the reason canon disallowed the usage of flash during video on s-series.
    so i guess i gotta integrate EF.StartInternalPreFlash in shooting_expo_param_override().
    btw i dont need power when firing flash in record mode, i just need the flash to trigger my external flashes. and i need it synced to the actual exposure when i press the shutter  :'(
    « Last Edit: 27 / November / 2008, 18:43:12 by PhyrePhoX »


    *

    Offline ewavr

    • ****
    • 1057
    • A710IS
  • Publish
    Re: Delay the flash untill a button is pressed, during long exposure
    « Reply #14 on: 27 / November / 2008, 19:10:57 »
    tried following script during video recording:
    doesnt work :( still doesnt fire flash when i press the shutter.

    Maybe this script is better:
    Quote
    rem set flash mode to "off" before shoot
    press "shoot_half"
    sleep 1000
    rem override flash mode to "on"
    set_prop 79 1
    press "shoot_full"
    sleep 1000
    release "shoot_full"
    end
    It works in my camera in photo mode.

    Quote
    btw in your video, did you fire the flash during recording on the same camera?
    Of course. Time between flashes is flash charge time:

    Quote
    struct {long t; long p1; long p2;} flash_p={1, 10, 10};
     int i;
     for (i=0; i<20; i++) {
     StartEFCharge(NULL);
     while(!IsStrobeChargeCompleted()) msleep(10);
     StopEFCharge();
     StartInternalPreFlash(&flash_p);
    }
    « Last Edit: 27 / November / 2008, 19:13:50 by ewavr »

    *

    Offline PhyrePhoX

    • *****
    • 2253
    • make RAW not WAR
      • PhyreWorX
  • Publish
    Re: Delay the flash untill a button is pressed, during long exposure
    « Reply #15 on: 27 / November / 2008, 19:51:44 »
    wow, ur script is working! wow. thank you!
    i made a quick video and testshots: vid pic1 pic2

    okay, how would one add this as an option like you did with rear curtain stuff?
    thanks so much ewavr :)

    *

    Offline quietschi

    • ***
    • 116
    • Ixus70 102a
  • Publish
    Re: Delay the flash untill a button is pressed, during long exposure
    « Reply #16 on: 28 / November / 2008, 04:14:03 »
    @ewavr
    tried your script but it doesn't work on my ixus70
    on digic3 this shout be propcace 143 or?

    *

    Offline ewavr

    • ****
    • 1057
    • A710IS
  • Publish
    Re: Delay the flash untill a button is pressed, during long exposure
    « Reply #17 on: 28 / November / 2008, 04:19:54 »
    @ewavr
    tried your script but it doesn't work on my ixus70
    on digic3 this shout be propcace 143 or?
    This script makes sense only for S series for picture shooting in video mode.
    For DIGIC 3 this propertycase maybe is 122 or other (camera or IDA+lot of time requires to find it), not 143.


    *

    Offline quietschi

    • ***
    • 116
    • Ixus70 102a
  • Publish
    Re: Delay the flash untill a button is pressed, during long exposure
    « Reply #18 on: 28 / November / 2008, 04:30:27 »
    thanks
    propcase 122 seems to be correct
    in photo mode disable flash - start your script - picture is taken without flash - script stopped
    edit: that`s not correct :wait a few seconds and then another half press on the shutter and the flash fires
    after a few seconds the flash fires itself
    « Last Edit: 28 / November / 2008, 07:08:09 by quietschi »

    *

    Offline PhyrePhoX

    • *****
    • 2253
    • make RAW not WAR
      • PhyreWorX
  • Publish
    Re: Delay the flash untill a button is pressed, during long exposure
    « Reply #19 on: 28 / November / 2008, 04:38:36 »
    Quote
    rem flash setting
    @title flash
    @param a off or on
    @default a 1
    set_prop 16 a

    a = 1 -> Flash on. a = 2 -> Flash Off. a = 0 -> Flash Auto.

    this script is working on my s3is in non-movie mode. so it *should* work on your digic3 when you replace the 16 with the 143, no?

    edit: will try implementing a) flash during video on s-series (i guess g-series doesnt have this feature, as they dont have a dedicated video start/stop button) and b) a ubasic/lua command to fire the flash (which will only be unlocked if you tick a checkbox in the misc or debug menu!)
    « Last Edit: 28 / November / 2008, 04:41:34 by PhyrePhoX »

     

    Related Topics