SX110IS - howto start porting

  • 573 Replies
  • 111138 Views
Re: SX110IS - howto start porting
« Reply #110 on: 13 / April / 2009, 20:32:21 »
Advertisements
Can someone PLEASE tell me how I can get the long exposures, up to the 64 seconds?

I have been playing with the override shutter speed and I change it but using it in Manual or TV mode, it does not get changed, even with the "Disable Overrides" set to off.

So can someone please tell me the steps to do a long exposure? Then, the instructions should be the same for doing a sort shutter, right?


*

Offline axu89

  • *
  • 29
Re: SX110IS - howto start porting
« Reply #111 on: 13 / April / 2009, 21:20:26 »
Can someone PLEASE tell me how I can get the long exposures, up to the 64 seconds?

I have been playing with the override shutter speed and I change it but using it in Manual or TV mode, it does not get changed, even with the "Disable Overrides" set to off.

So can someone please tell me the steps to do a long exposure? Then, the instructions should be the same for doing a sort shutter, right?

The overrides should work no matter which mode is selected but after experimenting with the Tv-override I couldnt get it working neither.
Need to do some fixing on that too..
[SX110 IS]

Re: SX110IS - howto start porting
« Reply #112 on: 14 / April / 2009, 05:45:11 »
Someone with better knowledge could update the wiki-page? http://chdk.wikia.com/wiki/SX110IS

I updated it a little bit...

I was on holiday and when I returned...

 :oWOW :o

Porting is nearly finished  :D :D :D

Thanks at all developer! I will test the "beta" and will report bugs.
Canon PowerShot SX110 IS
CHDK: at Autobuild now
Wiki: SX110IS

Re: SX110IS - howto start porting
« Reply #113 on: 14 / April / 2009, 07:38:12 »
Can someone PLEASE tell me how I can get the long exposures, up to the 64 seconds?

I have been playing with the override shutter speed and I change it but using it in Manual or TV mode, it does not get changed, even with the "Disable Overrides" set to off.

So can someone please tell me the steps to do a long exposure? Then, the instructions should be the same for doing a sort shutter, right?



Manual & TV Mode are good (P & Av show extreme exposure calculations)

Then you have to change

Shutterspeed enum type: from Ev Step to Factor
Set "Override shutter speed" to let's say 9
Set Value Factor to let's say 10

--> 9*10 = 90 sec Exposure!

:-)

--> Found in initial A580 Port Thread and subsequent "Long Exposure" Thread



*

Offline Hyst

  • *
  • 18
Re: SX110IS - howto start porting
« Reply #114 on: 14 / April / 2009, 15:35:17 »
Manual & TV Mode are good (P & Av show extreme exposure calculations)

Then you have to change

Shutterspeed enum type: from Ev Step to Factor
Set "Override shutter speed" to let's say 9
Set Value Factor to let's say 10

--> 9*10 = 90 sec Exposure!

:-)

--> Found in initial A580 Port Thread and subsequent "Long Exposure" Thread



it does not work for me...
i could not manage to override the exposure. the OSD shows me my overrided exposure time. but just when i press the shot-button it switches to the original one. (it does not matter if i am in P, Tv, Av or M mode)
Canon Powershot SX110

*

Offline axu89

  • *
  • 29
Re: SX110IS - howto start porting
« Reply #115 on: 14 / April / 2009, 17:20:43 »
it does not work for me...
i could not manage to override the exposure. the OSD shows me my overrided exposure time. but just when i press the shot-button it switches to the original one. (it does not matter if i am in P, Tv, Av or M mode)

None of the overrides work, TV, AV, ISO.. all show up in the OSD but when you press the button the TV-value shows original and the rest show the overrided value but none is affected by the overrides. Could it be similar problem?: http://chdk.setepontos.com/index.php/topic,2654.msg24845.html#msg24845
[SX110 IS]

*

Offline Inferno

  • *
  • 18
  • In RAW we trust!
Re: SX110IS - howto start porting
« Reply #116 on: 15 / April / 2009, 06:42:08 »
Actually I can't make DNG4PS-2 that Yarvieh compiled to work. It says
F:\DCIM\100CANON\IMG_4114.CRW
Error: wrong_camera_type
When I go to options to specify the camera and go back to convert it doesn't say anything
Just writes
-----------
finish.
When I press "refresh" RAW file list dissipates. When I start program again everything starts again.

Re: SX110IS - howto start porting
« Reply #117 on: 15 / April / 2009, 07:16:00 »
I used the latest CHDK from Yarvieh and put the newest Verion of CHDK full in it.
So now you have all languages, sample scripts, alternative symbols and so on.
If you already have CHDK you only have to copy the CHDK folder over the existing one.

thx @ nomi_68k, chdkj, Yarvieh and all other helper!



 :o :o After over 500 Downloads !IMPREESIVE! SX110IS Port is at Autobuild Server now :o :o


Download CHDK  SX110IS 1.00B full: -- in Autobuild now --> http://mighty-hoernsche.de/or look for the newest version in this thread
« Last Edit: 21 / April / 2009, 16:32:01 by Obihoernchen »
Canon PowerShot SX110 IS
CHDK: at Autobuild now
Wiki: SX110IS


Re: SX110IS - howto start porting
« Reply #118 on: 15 / April / 2009, 07:41:09 »
I have mentioned a very big bug if you use OSD-Codepage Win1252 (for german for example) instead of 1251 the camera hang on boot.
It wasnt the Codepage it is the Startup Sound. When I enable the Startup Sound in the CHDK menu the camera hang on boot. Maybe the CHDK dont know how to contact the Camera with Sound...
« Last Edit: 15 / April / 2009, 09:34:47 by Obihoernchen »
Canon PowerShot SX110 IS
CHDK: at Autobuild now
Wiki: SX110IS

*

Offline axu89

  • *
  • 29
Re: SX110IS - howto start porting
« Reply #119 on: 15 / April / 2009, 11:04:57 »
Actually I can't make DNG4PS-2 that Yarvieh compiled to work. It says
F:\DCIM\100CANON\IMG_4114.CRW
Error: wrong_camera_type
When I go to options to specify the camera and go back to convert it doesn't say anything
Just writes
-----------
finish.
When I press "refresh" RAW file list dissipates. When I start program again everything starts again.

It works for me. If you dont have the JPEG file with the RAW, you must select camera type from the menu (in the options). (the (CHDK) RAW file doesnt have EXIF data, JPEG file contains the EXIF data with the camera model info)

I used the latest CHDK from Yarvieh and put the newest Verion of CHDK full in it.
So now you have all languages, sample scripts, alternative symbols and so on.
If you already have CHDK you only have to copy the CHDK folder over the existing one.

With the "tv_uni_e.lua" script bundled in the full version I succeed to override the TV value..
It would be nice thou if I could change it directly from the CHDK menu. Running a script for that purpose isnt very practical  :(
[SX110 IS]

 

Related Topics