supplierdeeply

Unusual problem with the Ultra Intervalometer

  • 6 Replies
  • 1506 Views
  • Publish
    Unusual problem with the Ultra Intervalometer
    « on: 20 / January / 2009, 22:56:56 »
    Advertisements
    Hi everyone!

    I have been using the CHDK for a little while, and been slowly getting the hang of it. I decided to try making some timelapse videos using the ultra intervalometer I found here: http://chdk.wikia.com/wiki/UBASIC/Scripts:_Ultra_Intervalometer

    Here is the problem I'm having. I set all the values to zero exept for 'delay first shot' (I put the time I want between images here), 'number of shots' (I used 1 so it should repeat the timer after each shot), and "endless?" (I set it to one so it would repeat endlessly).

    When I try and run the script, it counts down however many seconds I told it to, takes one photo and then reports it is 'finished'
    I can't get endless to work if I have 'number of shots' set to 1. If I set number of shots to 2, it will count down as usual, take two shots in rapid succession, and then count down and repeat. This is what I want, but with one shot instead of two.


    I can of course work around this problem by setting 'number of shots' to two, and setting the delay between those shots to match the 'delay first shot' This gives me the result I want, but I would rather just have to adjust the one value.


    Any idea what is causing the endless option not to function correctly when it is set to one shot? Anyone know what can be changed in the script to cause it to function correctly? Or is it somthing I'm doing wrong in the parameters? Help is appreciated. Also I tried searching the forums and wiki for this issue but couldn't find it.

    I'm using a canon A540. (and I re-downloaded chdk a couple of days ago so I could have the newest version)
    On a side note, I can't get sokoban to work (all the other games do) Any idea why?


    Here's the time lapse I took with the workaround: http://au.youtube.com/watch?v=4o6IOFqBRMo#


    Thanks for any help.



    *

    Offline barret

    • ***
    • 125
    • S3 & a550
  • Publish
    Re: Unusual problem with the Ultra Intervalometer
    « Reply #1 on: 21 / January / 2009, 08:27:58 »
    script have some default values inside, and also, it checks if entered values are correct, for example if you set delay to -5, then it will automagically correct it to some default value.

    if you need fast shot intervalometer (using burst mode) then you should use another script (i don't remember the name now).

    anyway, ultra_intervalometer is quite simple and robust script, so you can try to read it and analyze why it behaves in such way.

    greetings & good luck

  • Publish
    Re: Unusual problem with the Ultra Intervalometer
    « Reply #2 on: 21 / January / 2009, 08:29:34 »
    sokoban only works when you download and "install" the FULL package.

  • Publish
    Re: Unusual problem with the Ultra Intervalometer
    « Reply #3 on: 21 / January / 2009, 18:12:50 »
    script have some default values inside, and also, it checks if entered values are correct, for example if you set delay to -5, then it will automagically correct it to some default value.

    if you need fast shot intervalometer (using burst mode) then you should use another script (i don't remember the name now).

    anyway, ultra_intervalometer is quite simple and robust script, so you can try to read it and analyze why it behaves in such way.

    greetings & good luck


    Hmm. I realise that I can't put stupid values into it, but it even says in the wiki article about this script that for time lapse (where I need a 5-20 second gap between pictures) that I can just set number of shots to 1 (telling it that after the initial count-down to take one photo), set the count-down to the distance I want between shots (say, 6 seconds) and set the 'endless' option to 1 (which SHOULD make it repeat over and over)

    It keeps reporting as finished even when I set it to repeat, and I don't know enough about code to figure out what's going wrong. When I tell it to take more than one photo after the count-down (without changing any other values) it works perfectly... I just need to tell it to delay the distance between shots so I get the effect I need. Does this happen to anyone else using this script?

    I don't need a fast intervalometer, this one works fine. Just want to know what is causing this weird glitch.
    « Last Edit: 21 / January / 2009, 18:20:46 by Insomniac »


    *

    Offline barret

    • ***
    • 125
    • S3 & a550
  • Publish
    Re: Unusual problem with the Ultra Intervalometer
    « Reply #4 on: 22 / January / 2009, 02:57:32 »
    Code: [Select]
    if c=1 then endc is number of shots (when you set it to less than one, then it will be set to 5).
    maybe this line is causing the problem? you set c=1, and script takes one shot and ends, just as script says.
    maybe you could modify the script like this:

    Code: [Select]
    rem Author - Keoeeit
    rem Modified by barret
    rem Written for S-Series
    rem Should be okay on others
    rem Use Endless mode with caution
    rem See documentation for important info
    @title Ultra Intervalometer
    @param a Delay 1st Shot (Mins)
    @default a 0
    @param b Delay 1st Shot (Secs)
    @default b 0
    @param c Number of Shots
    @default c 5
    @param g Endless? No=0 Yes=1
    @default g 0

    p=a*60000+b*1000
    w=0

    if c<1 then let c=5
    if g<0 then let g=0
    if g>1 then let g=1
    if p<0 then let p=0

    print "1 Cycle Time:", p/60000; "min", p%60000/1000; "sec"

    goto "interval"

    :interval
      if p>0 then gosub "pause"
      print "Shot ", w
      shoot
      next w
      if g=1 then goto "interval" else end

    :pause
      n=(a*60)+b
      for m=1 to n
      q=n-m
      print "Intvl Begins:", q/60; "min", q%60; "sec"
      sleep 930
      next m
      return

    i'm not sure if this would work, i don't have camera here. just try it :)

  • Publish
    Re: Unusual problem with the Ultra Intervalometer
    « Reply #5 on: 22 / January / 2009, 04:32:32 »
    Thanks, seems to be working perfectly. Although I will still keep the un-modded script as well as your modification (more options in the original.)

    *

    Offline barret

    • ***
    • 125
    • S3 & a550
  • Publish
    Re: Unusual problem with the Ultra Intervalometer
    « Reply #6 on: 22 / January / 2009, 04:52:09 »
    yeah, i've removed some things from the script, so now it can work only as a one-time-shooter, or unlimited shooter.
    glad i could help :)

     

    Related Topics