supplierdeeply

ixus870_sd880 port started

  • 245 Replies
  • 36593 Views
  • Publish
    Re: ixus870_sd880 port started
    « Reply #50 on: 23 / April / 2009, 17:24:47 »
    Advertisements
    Thanks for figuring out the precise conditions, mhoram. I'll add it to the wiki and have a look.

  • Publish
    Re: ixus870_sd880 port started
    « Reply #51 on: 24 / April / 2009, 00:53:49 »
    Thanks to Sethv for starting the process and mweerden for continuing with the port of the SD880.  Many, ,many thanks to both.

    I do have a slight issue if anyone can help.  I do have a 16GB SDHC so unfortunately I can't autoboot CHDK and have to manually start it with the review button each time I may just go back to a 4gb card.  The problem I am having is this:

    When running the bracketing script it will take the first picture but then just stops with the last picture being displayed on the screen.  I was hoping it would take 3 consecutive pictures at 0 -2 +2 and when reviewing the pictures to see the exposure difference info in the display.  Any help much appreciated.  I prefer using the script instead of the continuous shooting bracketing mode since when holding the camera free hand without a tripod the pictures come out clearer.

    Under bracketing settings I have:
    Number Images -1)2   1..1 [   3]  (I'm guessing this means three consecutive pictures)
    Step Size (1/3 EV)       1..1 [   2]  (I'm guessing this means a difference of -2 0 +2 exposure setting)
    Correction (1/3 EV)   -12..1 [   0]  (I'm clueless what this does)

    Any help much appreciated.

    This is the script:

    @title Bracketing
    @param a (Number images-1)/2   1..12
    @default a 3
    @param b Step size  (1/3 EV)   1..12
    @default b 2
    @param c Correction (1/3 EV) -12..12
    @default c 0

    get_prop 25 w
    get_prop 26 x

    let y=1

    do
      let z=0

      do
        if a<1   then let a=1
        if a>12  then let a=12
        if b<1   then let b=1
        if b>12  then let b=12
        if c<-12 then let c=-12
        if c>12  then let c=12
        if y<1 then y=3
        if y>3 then y=1

        print ""
        if y=1 then print "Num : <" 2*a+1 ">"     else print "Num :  " 2*a+1
        if y=2 then print "Step: <" b/3,b%3 "/3>" else print "Step:  " b/3,b%3 "/3"
        if y=3 then print "Corr: <" c/3,c%3 "/3>" else print "Corr:  " c/3,c%3 "/3"
        print "[Set]=shoot [Disp]=exit"

        wait_click
        if is_key "up"   then let y=y-1
        if is_key "down" then let y=y+1
        if y=1 and is_key "left"  then let a=a-1
        if y=2 and is_key "left"  then let b=b-1
        if y=3 and is_key "left"  then let c=c-1
        if y=1 and is_key "right" then let a=a+1
        if y=2 and is_key "right" then let b=b+1
        if y=3 and is_key "right" then let c=c+1
        if is_key "set"     then z=1
        if is_key "display" then z=2
      until z>0
      if z=2 then goto "exit1"

      let d=c*32-a*b*32

      for s=1 to 2*a+1
        set_prop 25 d
        set_prop 26 d
        print "Shoot at",d/96,(d/32)%3 "/3"
        do
          get_prop 205 p
        until p=0
        press "shoot_full"
        do
          get_prop 205 p
        until p=1
        release "shoot_full"
        let d=d+b*32
      next s
     
      :exit1
    until z=2

    set_prop 25 w
    set_prop 26 x

    end

  • Publish
    Re: ixus870_sd880 port started
    « Reply #52 on: 24 / April / 2009, 11:30:09 »
    Many thanks to mweerden, you made my day 8) :D 8)

    So far, everything i tried worked fine. I only once had an issue after testing the bracketing with a custom timer. After taking a series of 5 pictures with different EV, i ended up in an endless loop with a "custom script" message scrolling down in the lower left corner of my screen. I wasn't able to take new pictures until i "rebooted" my camera. This issue occurred only once and i couldn't reproduce it til now, so this might be only a minor issue. I will update you, if i find a way to reproduce the issue.

    Once again many, many thanks for your awful work.

    Regards
    Ecki

  • Publish
    Re: ixus870_sd880 port started
    « Reply #53 on: 24 / April / 2009, 12:21:00 »
    I do have a slight issue if anyone can help.  I do have a 16GB SDHC so unfortunately I can't autoboot CHDK and have to manually start it with the review button each time I may just go back to a 4gb card.  The problem I am having is this:

    You can boot from bigger cards; I have an 8GB SDHC from which I boot. The instructions are here: http://chdk.wikia.com/wiki/Bootable_SD_card. The way I did it the first time (which might not be the most efficient way, but it works) is by doing the following (don't forget to backup your photos!):

    • In CHDK menu: Miscellaneous stuff -> Debug parameters -> Create card with two partitions
    • Get the card and format it, make it bootable and add DISKBOOT.BIN in the root
    • Start up CHDK again (should autoboot): Miscellaneous stuff -> Swap partitions
    • Get the card and format it (FAT32) and put CHDK on it (including PS.FI2 for the next step!)
    • Start up CHDK yet again (firmware update, this time) and swap partitions a final time.

    Hope this helps.

    Quote
    When running the bracketing script it will take the first picture but then just stops with the last picture being displayed on the screen.  ...

    The script you're using seems to be made for older cameras. I changed the two occurrences of "get_prop 205 p" by "get_prop 206 p" and this made it work correctly.

    So far, everything i tried worked fine. I only once had an issue after testing the bracketing with a custom timer. After taking a series of 5 pictures with different EV, i ended up in an endless loop with a "custom script" message scrolling down in the lower left corner of my screen. I wasn't able to take new pictures until i "rebooted" my camera. This issue occurred only once and i couldn't reproduce it til now, so this might be only a minor issue. I will update you, if i find a way to reproduce the issue.

    If it happens again, try pressing the shoot button (if you didn't already). Normally this should interrupt the running script.


  • Publish
    Re: ixus870_sd880 port started
    « Reply #54 on: 24 / April / 2009, 14:31:13 »
    Time for a new version. I'm also going to try and get the port added to the autobuild system now. Regarding the issues found with the previous version, I have done the following:

    • Partially fixed optical zoom in video mode. It works fine if you disable digital zoom; with digital zoom enabled you can use optical zoom as long as you don't actually make use of digital zoom.
    • The badpixel script runs fine now and in addition I've fixed DNG support. (DNG files are RAW files with, for example, extra information on how to read them.)
    • Fixed the crash resulting from using "Custom auto ISO".

    Something I really need some help with is the colour calibration for DNG files. If somebody would be so kind to figure out the matrix (CAM_COLORMATRIX1 in include/camera.h), for example using http://www.vips.ecs.soton.ac.uk/index.php?title=Colour_calibration_with_nip2, that would be great.

    Next thing I will probably do is have a look at the new firmware (1.02b). I won't be able to test it, but I don't think that will be a big problem.

    N.B.: Something I forgot to mention last time, the attached patch file is not needed to run CHDK. It contains the source files of the port.

  • Publish
    Re: ixus870_sd880 port started
    « Reply #55 on: 24 / April / 2009, 17:44:38 »
    USB remote works ?

  • Publish
    Re: ixus870_sd880 port started
    « Reply #56 on: 24 / April / 2009, 21:04:22 »
    USB remote works ?

    It seems to work. I don't have a real trigger, but simulation by plugging and unplugging a (powered) USB cable does work. Of course, this method does not allow testing of more advanced features. If someone can test these, please let us know the results.

  • Publish
    Re: ixus870_sd880 port started
    « Reply #57 on: 24 / April / 2009, 21:16:27 »
    I downloaded the first version (I have not tried the newest) and found a minor glitch that I thought might be helpful to report.  In general, it's working great, I haven't experimented with all the core functions yet, I kind of got sidetracked on trying to beat one of the games.  Wile playing i realized that if I rotated the camera when it was on auto rotate mode the game would close.  When I turned off auto rotate it  worked fine.  I am new to chdk so for all I know this could be normal.


    *

    Offline reyalp

    • ******
    • 9803
  • Publish
    Re: ixus870_sd880 port started
    « Reply #58 on: 24 / April / 2009, 21:46:20 »
    This port is now checked in and should be available from the autobuild server shortly. Thanks mweerden!
    Don't forget what the H stands for.

  • Publish
    Re: ixus870_sd880 port started
    « Reply #59 on: 24 / April / 2009, 23:22:48 »
    I have another minor thing to report. The focal length is always reported as 111mm in EFL mode. In 'X' and FL mode, the numbers aren't right either.

     

    Related Topics