ixus870_sd880 port started

  • 245 Replies
  • 52284 Views
Re: ixus870_sd880 port started
« Reply #80 on: 30 / April / 2009, 09:31:05 »
Advertisements
Holy [admin: avoid swearing please], nice work mweerden!
Just got back from vacation the other day, didn't expect to see this much progress. I'm at work right now and I haven't read the the whole thread yet but I'd love to help out if you need anything done.

Re: ixus870_sd880 port started
« Reply #81 on: 30 / April / 2009, 10:14:59 »
Welcome back, sethv! I've tried to keep the most important things that should be done on the wiki page, so if want you can do any of those things. Also just testing various features could be useful.

Regarding the 1.02b port: I think I've found the problem (thanks to chippa for the feedback that allowed me to focus on the right part). If it really works this time, a new firmware dump is not a big priority. (However, I still think it would be nice if we can make sure we have the complete dumps.)

Re: ixus870_sd880 port started
« Reply #82 on: 30 / April / 2009, 15:11:30 »
Another attempt at 1.02b:

Re: ixus870_sd880 port started
« Reply #83 on: 30 / April / 2009, 15:17:33 »
And here's one for 1.00e. If someone still uses this firmware, please let me know if these images work.


Re: ixus870_sd880 port started
« Reply #84 on: 30 / April / 2009, 19:25:23 »
@mweerden i just tried those latest files for 1.02b (both from reply post #82 and #82) and the firmware update menu won't even show up when i copy those files to the sdcard.

Re: ixus870_sd880 port started
« Reply #85 on: 30 / April / 2009, 19:57:05 »
@mweerden i just tried those latest files for 1.02b (both from reply post #82 and #82) and the firmware update menu won't even show up when i copy those files to the sdcard.

Did you start the camera in review/playback mode? If you don't the update menu item does not appear.

Re: ixus870_sd880 port started
« Reply #86 on: 30 / April / 2009, 22:04:10 »
yes, i did. when i copy the 1.01a files onto the sdcard the firmware upgrade menu option shows up just fine, but when i overwrite PS.FI2 and DISKBOOT.BIN with the 1.02b ones, the menu option won't show up.

Re: ixus870_sd880 port started
« Reply #87 on: 30 / April / 2009, 22:46:04 »
yes, i did. when i copy the 1.01a files onto the sdcard the firmware upgrade menu option shows up just fine, but when i overwrite PS.FI2 and DISKBOOT.BIN with the 1.02b ones, the menu option won't show up.

Very strange. Perhaps you can try to autoboot? The only explanations I can think of at the moment is that either a different encryption key is needed (which seems strange as the 1.01a does work) or that something goes wrong with downloading the files (I just tried the last 1.02b PS.FI2 - md5: 549aa75434aecd939c4165c4170f867a - and I did get the menu option).


Re: ixus870_sd880 port started
« Reply #88 on: 30 / April / 2009, 22:57:52 »
ok i figured it out.. obviously it's a mac problem. when i save the PS.FI2 and DISKBOOT.BIN onto the sdcard through my mac, the menu options won't show up. i just downloaded the files to the sdcard again using a pc and the menu option showed up. very weird.

anyway, when i try to upgrade the firmware i get the black screen mentioned in previous posts and i need to take out the battery to power up again.

Re: ixus870_sd880 port started
« Reply #89 on: 30 / April / 2009, 23:30:30 »
tried autoboot now, but the same effect. as soon as i put the sdcard with autoboot in and power up, the camera goes dead and needs the battery takeout procedure to recover.

 

Related Topics