SD600 - RAW Exceptions and Shortcut do not seem to work

  • 11 Replies
  • 2997 Views
  • Publish
    SD600 - RAW Exceptions and Shortcut do not seem to work
    « on: 28 / June / 2009, 00:20:01 »
    Advertisements
    I have build 779 installed on my SD600, and I love being able to shoot in RAW.  My only issue is that the exceptions do not seem to be working for me.  I've set it (I think) to disable RAW when the camera is in auto mode, but it always shoots in RAW anyway.   I also am not able to get it to switch between RAW and JPEG by using the ALT+FUNCTION shortcut.  Am I doing something wrong, or is this not supported in this camera?  TIA.

    *

    Offline reyalp

    • ******
    • 9955
  • Publish
    Re: SD600 - RAW Exceptions and Shortcut do not seem to work
    « Reply #1 on: 28 / June / 2009, 00:52:17 »
    The mode map for that camera is not correct, so raw exceptions wont work.
    You can help us fix this:
    In the CHDK menu, got to miscellaneous stuff -> debug parameters
    Set "Debug data display" to "props"
    Set "PropCase/ParamsData page" to 0
    Leave the menu. You should now see the propcase display, which is a window with some lines like
      0: ...
      1: ...
    Switch to record mode.
    The value after 0: should change every time you change the shooting mode.
    Now select each possible shooting mode, and write down the mode and the value after 0: in the propcase display.
    Note that this should include not just the modes available in the dial, but also the various sub-modes you can select in scn mode etc.

    Quote
    I also am not able to get it to switch between RAW and JPEG by using the ALT+FUNCTION shortcut.
    If I've read things correctly, the raw shortcut should be the display button.
    Don't forget what the H stands for.

  • Publish
    Re: SD600 - RAW Exceptions and Shortcut do not seem to work
    « Reply #2 on: 28 / June / 2009, 01:20:36 »
    reyalp, Thanks for the quick reply.  I think this is all the modes, hopefully it helps:

    Auto -- 0: 32768
    Manual --  0: 32772
    Digital Macro -- 0: 33288
    Portrait -- 0: 32781
    Night Snapshot -- 0: 32779
    Color Accent -- 0: 16920
    Color Swap -- 0: 16921
    Kids&Pets -- 0: 16399
    Indoor -- 0: 16400 (this may be 16408, the second zero does not look exactly like the first, but it does not look like the 8 either)
    Foliage -- 0: 16401
    Snow -- 0: 16402
    Beach -- 0: 16403
    Fireworks -- 0: 16404
    Underwater -- 0: 16405


    Quote
    Quote
    I also am not able to get it to switch between RAW and JPEG by using the ALT+FUNCTION shortcut.
    If I've read things correctly, the raw shortcut should be the display button.
    Yes, that works.  Thank you.
    « Last Edit: 28 / June / 2009, 01:24:46 by NewbieTX »

    *

    Offline reyalp

    • ******
    • 9955
  • Publish
    Re: SD600 - RAW Exceptions and Shortcut do not seem to work
    « Reply #3 on: 28 / June / 2009, 01:46:34 »
    There should be one or more video modes as well
    Don't forget what the H stands for.


  • Publish
    Re: SD600 - RAW Exceptions and Shortcut do not seem to work
    « Reply #4 on: 28 / June / 2009, 10:49:24 »
    There should be one or more video modes as well

    Here are the video modes:

    Standard -- 0: 2593
    Fast Frame Rate -- 0: 2594
    Compact -- 0: 2595
    Color Accent -- 0: 2591
    Color Swap -- 0: 2592

    *

    Offline reyalp

    • ******
    • 9955
  • Publish
    Re: SD600 - RAW Exceptions and Shortcut do not seem to work
    « Reply #5 on: 28 / June / 2009, 16:48:08 »
    I've checked in an updated modemap, should be on the autobuild shortly as build 780
    Don't forget what the H stands for.

  • Publish
    Re: SD600 - RAW Exceptions and Shortcut do not seem to work
    « Reply #6 on: 28 / June / 2009, 23:03:44 »
    Thanks!  It works perfectly.

    *

    Offline msl

    • *****
    • 1177
    • A720 IS, SX220 HS 1.01a
      • CHDK inside
  • Publish
    Re: SD600 - RAW Exceptions and Shortcut do not seem to work
    « Reply #7 on: 31 / August / 2009, 09:10:50 »
    Hi,

    A user of the german forum has reported that the tv bracketing in the manually mode is not working correctly since rev. 780. In auto mode it works correctly.

    For example: tv bracketing 2 ev, bracketing type +, manually mode

    1. img 1/500
    2. img 1/4 (should be 1/125)
    Next Images are all correctly.

    Before this revision everything was ok. I think we need a mode P in modemap.

    ixus60 1.00a
    German CHDK pages:  CHDK forum | CHDK inside | CHDK Twitter News by msl | Download CHDK-DE (Autobuild)
    Note: SDM violates the GPL rules!


    *

    Offline reyalp

    • ******
    • 9955
  • Publish
    Re: SD600 - RAW Exceptions and Shortcut do not seem to work
    « Reply #8 on: 31 / August / 2009, 20:44:13 »
    Before this revision everything was ok. I think we need a mode P in modemap.

    ixus60 1.00a
    Likely. The "Manual" mode in this camera is like P on other cameras AFAIK (it uses the same canon number as P mode on my a540, not M)

    If you can try changing MODE_M to MODE_P in platform/ixus60_sd600/main.c and report back, that would be helpful.
    Don't forget what the H stands for.

    *

    Offline msl

    • *****
    • 1177
    • A720 IS, SX220 HS 1.01a
      • CHDK inside
  • Publish
    Re: SD600 - RAW Exceptions and Shortcut do not seem to work
    « Reply #9 on: 03 / September / 2009, 05:05:26 »
    Ok, the test was successful. The "Manual" mode  now work correctly by changing MODE_M to MODE_P.

    You can make the small change in the svn source code.
    German CHDK pages:  CHDK forum | CHDK inside | CHDK Twitter News by msl | Download CHDK-DE (Autobuild)
    Note: SDM violates the GPL rules!

     

    Related Topics