SD870 porting - first steps? - page 5 - DryOS Development - CHDK Forum  

SD870 porting - first steps?

  • 65 Replies
  • 29496 Views
*

Offline GrAnd

  • ****
  • 916
  • [A610, S3IS]
    • CHDK
Re: SD870 porting - first steps?
« Reply #40 on: 25 / March / 2008, 09:16:05 »
Advertisements
well, you are right, there arent many options there. but on New Ticket - Demo33 - Trac for example they do have some more options.
Yes, that fields can be enabled and their content is adjustable. But that's all. They even can't be renamed.

edit: Regarding mantis... I installed it more than two months ago my local machine (under VMWare) to play with, because the discussion regarding the using of such system was started that time already (sorry, in the "For Developers" private forum). I've run it again, so you can play with it too: My View - Bug Tracker
The reporter's login/password: guest/guest (anonymous access can be used to view)
The developer's login/password: chdk/chdk
Do not broke anything. ;)
« Last Edit: 25 / March / 2008, 09:31:51 by GrAnd »
CHDK Developer.

*

Offline dodgersp

  • *
  • 9
  • Ixus 860is - SD 870is
Re: SD870 porting - first steps?
« Reply #41 on: 25 / March / 2008, 10:30:21 »
I've tried to put one of the bugs successfully, I think it's a good method to wear some bug-features-control. It's very easy to work with.

Good Work!

*

Offline GrAnd

  • ****
  • 916
  • [A610, S3IS]
    • CHDK
Re: SD870 porting - first steps?
« Reply #42 on: 25 / March / 2008, 10:55:42 »
But please be noticed that it was just a prototype for demonstration to acseven. It's running just for a couple hours and will be shutdown soon... :)

PS And it's easy to setup. The installation took me just an hour with tuning and branding....  :D
« Last Edit: 25 / March / 2008, 10:58:44 by GrAnd »
CHDK Developer.

*

Offline dodgersp

  • *
  • 9
  • Ixus 860is - SD 870is
Re: SD870 porting - first steps?
« Reply #43 on: 25 / March / 2008, 10:58:01 »
I know, I was only saying that seems to be a good program ;)


Re: SD870 porting - first steps?
« Reply #44 on: 25 / March / 2008, 18:20:12 »
I installed mantis without any issue, the trouble is when integrating the login with smf, I haven't been able to make it work.

I haven't had much to look at it, I must be honest :S

Re: SD870 porting - first steps?
« Reply #45 on: 26 / March / 2008, 02:42:55 »
GrAndAG has placed a video on YouTube of CHDK running on the Ixus 860 (SD870):
  YouTube - IXUS 860 IS CHDK
The build is dated 23 March 2008.

Is this just a work in progress or what?  I can't see any news elsewhere...

*

Offline PhyrePhoX

  • *****
  • 2254
  • make RAW not WAR
    • PhyreWorX
Re: SD870 porting - first steps?
« Reply #46 on: 26 / March / 2008, 02:53:43 »
you can get the binary here: Index of /hdk/autobuild/
grAnd added it 3 days ago: https://tools.assembla.com/chdk/changeset/341
Quote
Added prelimary varsion of SD870 (IXUS860)
now i dont know what prelimary means in these circumstances :)

Re: SD870 porting - first steps?
« Reply #47 on: 26 / March / 2008, 17:27:23 »
Deleted
« Last Edit: 22 / April / 2008, 15:01:04 by Barney Fife »
[acseven/admin commented out: please refrain from more direct offensive language to any user. FW complaints to me] I felt it imperative to withdraw my TOTAL participation. Nobody has my permission, nor the right, to reinstate MY posts. Make-do with my quoted text in others' replies only. Bye


*

Offline GC

  • *
  • 4
Re: SD870 porting - first steps?
« Reply #48 on: 27 / March / 2008, 08:58:34 »
Hello,

I'm a newbie, so first of all I'd like to thank you all for the great work, especially GrAnd :)

Please find below some of my test results - be also aware, that I'm a new user of CHDK so if I'm wrong I'd like to ask for your understanding...

OK, now what I've found:

1. While using zebra with histogram and setting DRAW OVER ZEBRA = HISTO and setting RESTORE ORIGINAL SCREEN histogram appears only if zebra (BLINK) is on. Is this expected behaviour?

2. If above is correct, so is there any way to put into CHDK's OSD also the standard values of Canan's OSD (I found aperture, but cannot find shutter speed ...)

3. In OSD I set SHOW ZOOM and SHOW ZOOM VALUE AS EFL and it is displayed all the time (even in playback mode) despite setting SHOW MISC VALUES to SHOOT.

4. I cannot switch on/off histo and/or zebra using HALF SHOOT + LEFT or HALF SHOOT + UP. Instead it turns on AEL and AFL

Thanks in advance for help/answer

*

Offline RyeBrye

  • **
  • 73
  • SD-870
Re: SD870 porting - first steps?
« Reply #49 on: 28 / March / 2008, 18:48:31 »
That's great!

In all honesty, this port WAS on my list of "things-to-do" when two more projects finish up - but that's not for another few months at least... so THANK YOU for your work! Maybe when my plate clears off I can spend time adding more features to it.

Just out of curiosity - did you use my dump file as the basis? (hoping I was at least somewhat of a help)

 

Related Topics