A2000IS porting

  • 95 Replies
  • 23169 Views
  • Publish
    Re: A2000IS porting
    « Reply #80 on: 09 / December / 2009, 02:57:29 »
    Advertisements
    Hi,

    Thx a lot for doing this greate port.
    I use it with my A200is and Firmware 1..0B. So far everything is working very fine :)
    Only the "force manual flash" seems not work correctly. It will only work for me if i fix the lightning by pressing shoot_half and the ISO-button (up). This would not an greate Problem, but if i use this, scripts with md_detect_motion may take only one shoot then it seem broken.
    Mayby you have any ideas on this?
    Or is it possible to put the 1.00C firmware into my cam?

    Thx for helping

    *

    Offline reyalp

    • ******
    • 9957
  • Publish
    Re: A2000IS porting
    « Reply #81 on: 09 / December / 2009, 03:43:23 »
    Unless canon has issued a firmware update (which they usually don't), you cannot update. In general, I wouldn't expect problems with a CHDK port to be solved by updating canon firmware.

    I'm not completely clear what you are saying the relationship between the flash problem and the motion detection problem is.
    Don't forget what the H stands for.

  • Publish
    Re: A2000IS porting
    « Reply #82 on: 09 / December / 2009, 05:19:29 »
    thx for you fast reply.
    I'll try to decribe it with easy words. There is no relationship between manual flash and motion detection.
    The manual flash is one thing. It works for me only if i use the AEL-setting of the camera.
    On the other hand there is one problem with continious motion detection, mayby. This will work perfectly in normal camera-modes.
    But it can do only one shoot if i use AEL or FEL-mode. Hope i could say it a bit more clear.

    Thx

  • Publish
    Re: A2000IS porting
    « Reply #83 on: 09 / December / 2009, 06:29:44 »
    short update.
    Manual flash works also fine then flash is turned on!
    It works also if cameraflash is off and i use AEL-mode.
    If cameraflash is off in all normal modes manual flash is not working! Sorry if i'm wrong. I was thinking it should work then normal flash is turned off like in AEL-mode. So mayby this is not an issue.


    *

    Offline reyalp

    • ******
    • 9957
  • Publish
    Re: A2000IS porting
    « Reply #84 on: 23 / February / 2010, 01:26:21 »
    A user reported damage while using SD override on this camera http://chdk.wikia.com/wiki/Talk:A2000IS#My_camera_broke_down_last_night

    A2000 user may want to be cautious with this feature. If you have used it successfully without problems, that may also be useful information.
    Don't forget what the H stands for.

  • Publish
    Re: A2000IS porting
    « Reply #85 on: 23 / February / 2010, 01:34:44 »
    Strange...
    I've successfully used the SD override on two different A2000's and haven't had any problems like that. That lens error is a bad one though, I've had it happen on a couple of cameras from physical damage. Actually, that's what did my first A2000 in, I dropped it from a height of about 15ft.

    jono

  • Publish
    Re: A2000IS porting
    « Reply #86 on: 12 / April / 2010, 16:37:36 »
    Just tested it on my A2000 with GM1.00a Firmware, everything I've tested so far seems to work perfect. Maybe the wiki page should be updatetd

    *

    Offline OldGit

    • ****
    • 303
  • Publish
    Re: A2000IS porting
    « Reply #87 on: 09 / May / 2010, 05:10:59 »
    Hi,
    a new user ( pineyphotosnj ) raised the issue of focus after zoom in video.

    I have taken a look and it seems you do not have the ability to fire a single AF Scan.
    I don't have this camera, but I have compiled a test version to allow the assignment of a key
    (set or half shoot) to fire a single scan.

    If it is usefull, and tests out OK, then someone will need to ask the senior devs to apply it.
    Compiled against trunk 889
    Hope it works for you
    OldGit
    SX200 IS-100C


  • Publish
    Re: A2000IS porting
    « Reply #88 on: 23 / May / 2010, 03:56:20 »
    "AF Key" now works on my camera (FW GM1.00B)
    Thank you OldGit!

  • Publish
    Re: A2000IS porting
    « Reply #89 on: 25 / May / 2010, 14:16:03 »
    "AF Key" now works on my camera (FW GM1.00B)
    Thank you OldGit!

    I downloaded the latest version and it still dont work on my A2000IS. There's no AF key. But I then figured out it the links were in the above post. Thanks!
    « Last Edit: 25 / May / 2010, 14:20:23 by pineyphotosnj »

     

    Related Topics