SD1200 IS Porting Thread - page 13 - DryOS Development - CHDK Forum

SD1200 IS Porting Thread

  • 312 Replies
  • 101092 Views
Re: SD1200 IS Porting Thread
« Reply #120 on: 01 / July / 2010, 02:36:43 »
Advertisements
Do you think repairing the USB remote function would be a difficult task? 

I really don't know, I haven't even tried that part. I'd like to correct basic functionality first.

Anyway, from what I've seen, it seems that none of the overrides is working. Can you confirm that, or point to some that is working? I am still finding my way about chdk.




Re: SD1200 IS Porting Thread
« Reply #121 on: 01 / July / 2010, 03:22:36 »
As far as I know none of the manual overrides in the menu work.  However the shutter speed can be adjusted through one of the scripts up to 64 seconds.

Re: SD1200 IS Porting Thread
« Reply #122 on: 01 / July / 2010, 04:43:58 »
As far as I know none of the manual overrides in the menu work.  However the shutter speed can be adjusted through one of the scripts up to 64 seconds.

I checked the SetPropertyCase function and it seems to be OK, according to the firmware. However, looking at the property values from debug menu, values are not modified. I'll see if the function gets called.

Re: SD1200 IS Porting Thread
« Reply #123 on: 01 / July / 2010, 14:34:36 »
There was a wrong address entered for "GetCurrentTargetDistance". Zoom from script now works, as well as changing distance modes.


Re: SD1200 IS Porting Thread
« Reply #124 on: 01 / July / 2010, 14:59:53 »
Manual flash override is ok if used within script. I have tried this:

set_prop(121,1)
   
set_prop(141,0) //
press "shoot_half"
repeat
      until get_shooting() == true
press "shoot_full"
release "shoot_full"
release "shoot_half"

,and it works fine. Maybe something is overwriting the property value?

Re: SD1200 IS Porting Thread
« Reply #125 on: 03 / July / 2010, 07:02:04 »
Ok, remote capture seems to be working. You can enable the option via menu, or use the script. The only problem was that the code was commented.

I have not enabled the code to wait for remote release in capt_task, so some strange behavior is possible. I have only tested by plugging the cable into PC. If you notice anything, please report.

If this is confirmed to be working, I'm sending the sources to be integrated in the main trunk.

*

Offline tillo

  • *
  • 43
Re: SD1200 IS Porting Thread
« Reply #126 on: 03 / July / 2010, 13:12:18 »
wow you have finally done it, and you make it sound like it was so easy, I didn't even understand what I saw in the codes last time i tried by myself, I thought that CHDK + scripts was really cool but now you say you got flash, thats something I needed, good job man *thumbs up*

Re: SD1200 IS Porting Thread
« Reply #127 on: 03 / July / 2010, 18:47:39 »
The functions for changing focus modes, zooming from script, USB remote appear to be working fine through the script.  USB remote appears to work without a script too but I think I have a setting wrong for the sync.  

Looks awesome so far!  You should upload the script to the trunk, chdk for the SD1200 has more than basic functionality now! :)
« Last Edit: 04 / July / 2010, 01:17:17 by awdark »


Re: SD1200 IS Porting Thread
« Reply #128 on: 04 / July / 2010, 05:51:05 »
The functions for changing focus modes, zooming from script, USB remote appear to be working fine through the script.  USB remote appears to work without a script too but I think I have a setting wrong for the sync. 

Remote trigger on release probably doesn't work properly, as it's missing a function call in capt_seq to wait for release.
Manual focus works (activate by pressing UP in alt mode, change focus using zoom lever, change increment using LEFT/RIGHT).

I don't know why manual flash is not working from the menu. Can anyone report what's the behavior on similar cameras (sd780, sd990)?

Anyway, I'm uploading sources, and diff log to trunk 903. Have fun.

Re: SD1200 IS Porting Thread
« Reply #129 on: 04 / July / 2010, 10:46:01 »
One more update. Code for menu overrides was missing. Flash, Tv and ISO override should work now.

I will post source update after the merge. I am attaching the firmware in case you want to test it.

What remains to be done:
- wait on release for remote trigger
- extra long tv (above 64s)
- optical zoom in video recording
- quality modes override (not sure)
- Edge overlay and zebra

Please add to the list if you notice anything else.

 

Related Topics