the sx20 porting thread - page 18 - General Discussion and Assistance - CHDK Forum supplierdeeply

the sx20 porting thread

  • 1279 Replies
  • 259911 Views
*

Offline neszt

  • ***
  • 174
Re: the sx20 porting thread
« Reply #170 on: 08 / November / 2009, 13:58:29 »
Advertisements
Oh, yes, I thought I did nullsub it in the code I gave you?
And I spent a lot of time trying to find it too.
Yes it was nullsub in your code too.

Can you pls tell me, where from

DEF(enabled_refresh_physical_screen, 0x1B34C+0x20)

address comes from in you firmware?

My guess:

loc_FF9F8554
sub_FF9F8694

I have canon menu refresh problems when this address is set to

DEF(enabled_refresh_physical_screen, 0x9D60 + 0x28)

Regarding my frimware, but, i'am sure, this is the correct address.

edit: I mean, i have problems with original canon menu, not chdk menu. (when not in alt mode)
« Last Edit: 08 / November / 2009, 14:00:09 by neszt »

*

Offline RaduP

  • *****
  • 890
Re: the sx20 porting thread
« Reply #171 on: 08 / November / 2009, 19:56:39 »
Yes, it is from sub_FF9F8694

What issues do you have with your menu? Can you describe?

*

Offline neszt

  • ***
  • 174
Re: the sx20 porting thread
« Reply #172 on: 09 / November / 2009, 03:51:57 »
Yes, it is from sub_FF9F8694

What issues do you have with your menu? Can you describe?
The canon menu does not appear. It works, i know, because it beeps. This happens with all the canon menu elements, including the manual focus, iso values, etc..

The canon menu refreshes only when switch to alt mode.

For example, i push the menu button, beeps, and nothing visual happens. I switch to alt mode, press the menu button, and boot the canon menu and the chdk menu appears.

*

Offline RaduP

  • *****
  • 890
Re: the sx20 porting thread
« Reply #173 on: 09 / November / 2009, 04:09:31 »
Well, remember that thing I told you about setting that new variable to make the screen be refreshed correctly? Try to comment out the code that does that, and see if it works..


*

Offline neszt

  • ***
  • 174
Re: the sx20 porting thread
« Reply #174 on: 09 / November / 2009, 04:51:03 »
Well, remember that thing I told you about setting that new variable to make the screen be refreshed correctly? Try to comment out the code that does that, and see if it works..
It is not regarding your code. That's ok. When i removed, i got yet another problem, with chdk menu refreshing..

*

Offline neszt

  • ***
  • 174
Re: the sx20 porting thread
« Reply #175 on: 09 / November / 2009, 19:07:59 »
I found the reason of games freezes. It was because of wrong VbattGet address.

*

Offline neszt

  • ***
  • 174
Re: the sx20 porting thread
« Reply #176 on: 09 / November / 2009, 19:10:35 »
Actually, the following main things works and tested:

- Shutter speed override
- Override ISO value
- Save RAW (without SetFileTimeStamp)
- Visual settings
- Scripts, including motion detection
- Filebrowser, calendar, textfilreader, draw palette
- Benchmark, and others in Debug parameters
- Startup sound. :)
- Games

*

Offline yakabmarci

  • *
  • 16
  • sx20is
Re: the sx20 porting thread
« Reply #177 on: 10 / November / 2009, 01:13:47 »
This is great news.
Can you please share your SW?
I'M very anxious to try this out.


*

Offline jan

  • *
  • 48
  • PowerShot SX20 IS (100f)
    • cms -db
Re: the sx20 porting thread
« Reply #178 on: 10 / November / 2009, 05:54:36 »
I would as well like to try it out.

*

Offline neszt

  • ***
  • 174
Re: the sx20 porting thread
« Reply #179 on: 11 / November / 2009, 03:48:23 »
Ok, give me a few time, to make the actual source publicable.

 

Related Topics