the sx20 porting thread - page 45 - General Discussion and Assistance - CHDK Forum supplierdeeply

the sx20 porting thread

  • 1279 Replies
  • 351871 Views
Re: the sx20 porting thread
« Reply #440 on: 18 / April / 2010, 14:30:50 »
Advertisements
Testers please use this 102b build


Re: the sx20 porting thread
« Reply #441 on: 18 / April / 2010, 14:59:22 »
...and the aspect correction found in camera.h I got the GUI resizing correctly without changing gui.c. AFAIK apart from some changes in the propset file merging with the latest trunk should be fairly easy now.

Excellent, I never thought of modifying those values :) - actually the camera does seem to have those number of pixels, so I assumed that the C code was incorrect and not displaying properly. Good job!

*

Offline fe50

  • ******
  • 3132
  • IXUS50 & 860, SX10 Star WARs-Star RAWs
    • fe50
Re: the sx20 porting thread
« Reply #442 on: 18 / April / 2010, 15:03:43 »
Maintainers, a number of propset values need to be changed for the SX20. Do we need to create another propset file to be compatible with the trunk revision or can we #define?
Doesn't the SX20 use the new propset #3, like the G11 ?
- http://tools.assembla.com/chdk/changeset/874/trunk/CHDK/LUALIB/propcase.lua
- http://chdk.wikia.com/wiki/PropertyCase#New_Digic_IV_.28propset3.29

Re: the sx20 porting thread
« Reply #443 on: 18 / April / 2010, 15:56:23 »
Testers please use this 102b build


I have tried both builds and when I try to import the RAW using Lightroom or PS I get a "Corrupt File or Error" message.

Edited for clarification:
I am using the full version of sx10, in which I removed and replaced the file from this beta, for the 1.02B. I was shooting in Superfine, with Raw on. I also just tried with Raw Therapee, and can not get the images to import.
« Last Edit: 18 / April / 2010, 16:03:41 by kaych »


Re: the sx20 porting thread
« Reply #444 on: 18 / April / 2010, 16:02:03 »
Quote
Doesn't the SX20 use the new propset #3, like the G11 ?
- http://tools.assembla.com/chdk/changeset/874/trunk/CHDK/LUALIB/propcase.lua
- http://chdk.wikia.com/wiki/PropertyCase#New_Digic_IV_.28propset3.29

I think your right, i've change  #define CAM_PROPSET  3 and it hasn't done anything too weird. This is good news because it means the SX20 port is back in-line with the main trunk.

Quote
Excellent, I never thought of modifying those values  - actually the camera does seem to have those number of pixels, so I assumed that the C code was incorrect and not displaying properly. Good job!

Still an issue with the time or something in the top right corner on my port though.



Does anyone know about the CAM_HAS_ND_FILTER setting. I'm pretty sure the SX20 has NR and checking the dump reveals a few strings but I can't find any functions that reference them. Probably IDA has got confused. Oddly the required functions are not auto detected or even added to the stubs file. These being _PutInNdFilter and _PutOutNdFilter.

Am I doing something wrong, i'm assuming not having that #define means that NR is turned off?

Re: the sx20 porting thread
« Reply #445 on: 18 / April / 2010, 16:13:37 »
Quote
I have tried both builds and when I try to import the RAW using Lightroom or PS I get a "Corrupt File or Error" message.

What is the extension of the file you are trying to import.

Re: the sx20 porting thread
« Reply #446 on: 18 / April / 2010, 16:16:14 »
Quote
I have tried both builds and when I try to import the RAW using Lightroom or PS I get a "Corrupt File or Error" message.

What is the extension of the file you are trying to import.

I'm using the default crw. Ive read around but not found anything that says I should use other. I will try the other formats real quick.

Re: the sx20 porting thread
« Reply #447 on: 18 / April / 2010, 16:19:35 »
You have not read/understood the documentation.

Please read the documentation again. CRW is not the correct raw format, it needs to be converted either on camera or in software to DNG.

Its worth noting that some of the tools out there like DNG4PS do not yet support the SX20. Its worth spending a little time and effort getting the camera to output DNG.

Remember this is BETA it will not 'just work'. There are many bugs and places where functionality just doesn't work. Just in case you can't get DNG output to work i've attached a reg file that MIGHT make dng4ps compatible. It works for me but anyone else might have to make some changes - I didn't use the reg file or test it - just made it ;).
« Last Edit: 18 / April / 2010, 16:53:41 by acid2000 »


Re: the sx20 porting thread
« Reply #448 on: 18 / April / 2010, 16:22:43 »
You have not read/understood the documentation.

Please read the documentation again. CRW is not the correct raw format, it needs to be converted either on camera or in software to DNG.
Mya pologies for wasting your time. I will search again (and harder :))

*

Offline fe50

  • ******
  • 3132
  • IXUS50 & 860, SX10 Star WARs-Star RAWs
    • fe50
Re: the sx20 porting thread
« Reply #449 on: 18 / April / 2010, 16:28:47 »
Does anyone know about the CAM_HAS_ND_FILTER setting.
AFAIK the SX20 doesn't have a ND (Neutral density) filter. ([1])

The IXUS series and the cheaper A series cameras use a ND filter instead of a "real" aperture (diaphragm iris),
other Powershots with a "real" aperture - all the cameras with an Av mode - don't have an additional ND filter;
only some of the more expensive models from the G series are equipped with both, a iris diaphragm and a ND filter.

NR (noise reduction) isn't related to the ND filter...

 

Related Topics