supplierdeeply

PowerShot SX210 IS - Porting Thread

  • 588 Replies
  • 140163 Views
Re: PowerShot SX210 IS - Porting Thread
« Reply #90 on: 16 / August / 2010, 13:54:01 »
Advertisements
I can blink LEDs using Powershot script on my ixus130(sd1400), here is steps

1. format the SD using ixus130 (my SD is 2GB Kingston microSD with Kingston adapter)
2. edit the boot sector(offset 0x1f0) to "SCRIPT" using HxD
3. On Linux, echo -n "for DC_scriptdisk" > script.req
4. copy script.req to SD root directory
5. create the script extend.m

Code: [Select]
dim f,b,c
private sub Initialize()
        System.Create()
        Driver.Create()
        for c=0 to 5
        for b=0 to 10
        LEDDrive(b,0)
        next
        Wait(500)
        for b=0 to 10
        LEDDrive(b,1)
        next
        Wait(500)
        next
end sub
private sub Terminate()
end sub

6. copy extend.m to SD root directory
7. Start with the play button then press SET key, both LEDs blink

my "script.req" and "extend.m"
http://www.filefactory.com/file/b2gd615/n/blink_LED.zip




Re: PowerShot SX210 IS - Porting Thread
« Reply #91 on: 16 / August / 2010, 15:25:13 »
Quote
I can blink LEDs using Powershot script on my ixus130(sd1400), here is steps
Try reyalp's script to dump firmware. I think it should works

Re: PowerShot SX210 IS - Porting Thread
« Reply #92 on: 16 / August / 2010, 15:26:06 »
Please someone try this on the sd210.  I'm in York, uk and cannot at the moment.  This is exciting....!

Reading the thread I see people are already trying.  Hope to see success soon...

Jason
« Last Edit: 16 / August / 2010, 15:46:24 by HarpoMa »
Canon Models - SD300, SD780, & SX210

*

Offline reyalp

  • ******
  • 10069
Re: PowerShot SX210 IS - Porting Thread
« Reply #93 on: 16 / August / 2010, 22:52:23 »
Great news guys! I use first reyalp's dump script on A3100 and it works! But start adress is not 0xFFC00000, it's 0xFF810000
Here this dump (24 969 204 bytes, A3100 ver. 1.00B P-ID: 31F1):
DUMP_FF810000_A3100_1.00B.BIN - 23.81MB
Sounds good, but I'm confused as to how you got a 24MB dump ? The original script was already setup for FF810000 and should have produced an exactly 8323068 byte dump.

The second version should handle either start address, and is known to work with FF810000

edit:
@cyrustam  if the dumper does not work, you can try commenting out the LCD stuff. ' is the comment character.

edit:
General thought for new cameras: Ameglin mentioned the key and iv are different in A3100, so trying these (and the dancingbits value once it's found) on other new cameras might be productive if the dumper script doesn't work.
« Last Edit: 17 / August / 2010, 00:07:27 by reyalp »
Don't forget what the H stands for.


Re: PowerShot SX210 IS - Porting Thread
« Reply #94 on: 17 / August / 2010, 01:29:00 »
2reyalp First time I tried to dump 8mb dump with start adress=0xFFC00000 because of A-series and get bad dump, that is why I just in case changed script to 24 mb dump and 0xFF810000 start adress. ::)

*

Offline reyalp

  • ******
  • 10069
Re: PowerShot SX210 IS - Porting Thread
« Reply #95 on: 17 / August / 2010, 02:11:23 »
I've added flavor #4 to dancingbits, please report whether it makes bootable diskboots for any of these cameras.
Don't forget what the H stands for.

*

Offline emlyn

  • **
  • 88
Re: PowerShot SX210 IS - Porting Thread
« Reply #96 on: 17 / August / 2010, 03:52:50 »
I can blink LEDs using Powershot script on my ixus130(sd1400), here is steps

That is excellent news! I can't wait to get back from work and find out where I went wrong, and start playing around with this...

Re: PowerShot SX210 IS - Porting Thread
« Reply #97 on: 17 / August / 2010, 04:07:43 »
Great news, i have a SD4000 and could try this later today. I am a n00b and need some simple instructions.

Thanks everyone for the fantastic work :)


Re: PowerShot SX210 IS - Porting Thread
« Reply #98 on: 17 / August / 2010, 06:56:57 »
2contacts
Use cyrustam's method described in Reply#90 (3 and 5 points you can skip, just download files). If you all do right, all LED's must start blinking. And if it works, use reyalp's dump script (Reply #78 or #80) and share dump to us :)

upd:
Finally, I made it. 8) Here SX210IS firmware: SX210_1.00C.BIN - 7.94MB
Start Adress: 0xFF810000

I used nudryos udumper encoded new set of dancingbits

Code: [Select]
main.c:
typedef int (*f_w)(int, int, int, int, int, int, int,int);
#define MIN_ADDRESS     0xFF810000
#define FW_SIZE         0x800000
#define START_SECTOR    2048

int main()
{
unsigned int i,j;
unsigned long sa;
f_w wr = 0;
for (i=0xFF810000; i < 0xFFFF0000; i+=4)
{
if (        (*(char*)i == 'B')
&&  (*(char*)(i+1) == 'O')
       &&  (*(char*)(i+2) == 'O')
       &&  (*(char*)(i+3) =='T')
       &&  (*(char*)(i+4)== 'D')
       &&  (*(char*)(i+5) == 'I')
       &&  (*(char*)(i+6) == 'S')
       &&  (*(char*)(i+7) == 'K')
       &&  (*(char*)(i+8) == 0)
)
{
for (j=i+8; j<0xFFFF0000;j+=4)
{
 if (      (*(unsigned int*)(j)>MIN_ADDRESS)
       &&(*(unsigned int*)(j+4)>MIN_ADDRESS)
    )
 {
   wr=(f_w)*(unsigned int*)(j+4);
  for (i = 0x1c00; i<0x30000; i+=4)  *(int*)i=0;
sa=(unsigned long)0xFF810000;
wr(0, START_SECTOR, (0xFFFFFFFF - sa + 1)/512, sa,0,0,0,0);
 break;
 }
}

break;
}
}

while(1);
return 0;
}
Also it works on A3100, so if scripts don't work on your camera, try this method

PS: Can someone tell me why I can't attach files to messages?
« Last Edit: 17 / August / 2010, 12:10:55 by Ameglin »

Re: PowerShot SX210 IS - Porting Thread
« Reply #99 on: 17 / August / 2010, 11:05:34 »
Just back to home and try to dump the FW, it works!!, here is the dump of my ixus 130

http://www.filefactory.com/file/b2gh73d/n/20100717_ixus130_dump_PRIMARY.BIN






 

Related Topics