PowerShot SX210 IS - Porting Thread

  • 588 Replies
  • 136604 Views
*

Offline emlyn

  • **
  • 88
  • Publish
    Re: PowerShot SX210 IS - Porting Thread
    « Reply #100 on: 17 / August / 2010, 15:25:30 »
    Advertisements
    I can confirm that it works with the Ixus 130! It wasn't working before because I had stupidly written the SCRIPT string to the device representing the partition instead of the whole disk.
    I first tried the LED blinker script, and it worked, so I then tried reyalp's dumper script (the second improved version), and got a dump!
    The file is here: http://www.sendspace.com/file/wgjbef
    A quick diff shows that it is not identical to cyrustam's dump, but I haven't looked how it differs.

  • Publish
    Re: PowerShot SX210 IS - Porting Thread
    « Reply #101 on: 17 / August / 2010, 15:55:46 »
    Quote
    I had stupidly written the SCRIPT string to the device representing the partition instead of the whole disk.

    What's the difference? I might have made the same mistake on SX210...

    EDIT: Grammar

  • Publish
    Re: PowerShot SX210 IS - Porting Thread
    « Reply #102 on: 17 / August / 2010, 15:59:07 »
    Yep, dumps are different because cyrustam's firmware version is 1.00A and emlyn's is 1.00C

    *

    Offline emlyn

    • **
    • 88
  • Publish
    Re: PowerShot SX210 IS - Porting Thread
    « Reply #103 on: 17 / August / 2010, 16:24:05 »
    Quote
    I had stupidly written the SCRIPT string to the device representing the partition instead of the whole disk.

    What's the difference? I might have made the same mistake on SX210...

    EDIT: Grammar

    The string must be a fixed offset from the beginning of the disk, in the first sector. The partition is only part of the whole disk, starting at some offset from the beginning, after the boot sector and partition table.
    On OS X, two devices appear when I insert the SD card, /dev/disk1 and /dev/disk1s1, disk1 represents the whole disk, and disk1s1 is the first partition.


    *

    Offline reyalp

    • ******
    • 9810
  • Publish
    Re: PowerShot SX210 IS - Porting Thread
    « Reply #104 on: 17 / August / 2010, 16:44:21 »
    Yep, dumps are different because cyrustam's firmware version is 1.00A and emlyn's is 1.00C
    A full dump will also be different for each camera, because the firmware uses some areas of "ROM" for crash dumps, settings etc.
    Don't forget what the H stands for.

  • Publish
    Re: PowerShot SX210 IS - Porting Thread
    « Reply #105 on: 17 / August / 2010, 16:52:19 »
    A full dump will also be different for each camera, because the firmware uses some areas of "ROM" for crash dumps, settings etc.
    This dumps differs also in first 4mb half and fw version strings are also different ::)

    *

    Offline emlyn

    • **
    • 88
  • Publish
    Re: PowerShot SX210 IS - Porting Thread
    « Reply #106 on: 17 / August / 2010, 17:45:55 »
    I've added flavor #4 to dancingbits, please report whether it makes bootable diskboots for any of these cameras.

    It works with the Ixus 130!
    I've only tried a loop from 0xc0220000 to 0xc022f000 writing 0x46 - the front LED and the flash both flash and then the camera switches off. I guess I must be hitting something that makes it power off because it doesn't crash, I can just press the power button again and it repeats.
    I'll play around some more tomorrow and try to work out the LED addresses.

    *

    Offline reyalp

    • ******
    • 9810
  • Publish
    Re: PowerShot SX210 IS - Porting Thread
    « Reply #107 on: 17 / August / 2010, 18:05:31 »
    This dumps differs also in first 4mb half and fw version strings are also different ::)
    Right, not disputing that they are different versions. Don't have any reason to doubt that.

    I'm just saying, as a general piece of information for anyone reading, that that full dumps from cameras with the same model/firmware version are not be expected to be identical.
    Don't forget what the H stands for.


  • Publish
    Re: PowerShot SX210 IS - Porting Thread
    « Reply #108 on: 17 / August / 2010, 20:43:44 »
    So what should we do next..?
    I tried to import the fw to IDA but where's the DryOS signature thing?

    *

    Offline fe50

    • ******
    • 3033
    • IXUS50 & 860, SX10 Star WARs-Star RAWs
      • fe50
  • Publish
    Re: PowerShot SX210 IS - Porting Thread
    « Reply #109 on: 18 / August / 2010, 00:34:09 »
    So what should we do next..?
    I tried to import the fw to IDA but where's the DryOS signature thing?
    --> http://chdk.wikia.com/wiki/Loading_dump_to_IDA

     

    Related Topics