IXUS110IS / SD960IS porting

  • 51 Replies
  • 5335 Views
  • Publish
    Re: IXUS110IS / SD960IS porting
    « Reply #40 on: 01 / February / 2013, 10:58:50 »
    Advertisements
    In a few days. Thx for the dump.

    I'm looking forward to test it.

    *

    Offline srsa_4c

    • ******
    • 3118
  • Publish
    Re: IXUS110IS / SD960IS porting
    « Reply #41 on: 01 / February / 2013, 20:31:20 »
    First test version for firmware 1.00b
    Since I can't test this myself, please report whether it works, and any issues that you find.
    You have to use the bootable SD card method.
    Please note that
    - you can enter/leave ALT mode by a short press on the play [>] button
    - you have to press the play button longer for its original function
    - you must leave ALT mode to be able to switch the camera off with the on/off button

    To all "testers":
    You need to convince me to enable autobuild for the pending fw revisions (1.00b, 1.01f, 1.01g) :)
    edit: attachment no longer necessary, removed
    ixus110_sd960-100b-1.1.0-full.7z (463.71 kB - downloaded 2 times.)
    « Last Edit: 14 / February / 2013, 18:28:09 by srsa_4c »

    *

    Offline fe50

    • ******
    • 3033
    • IXUS50 & 860, SX10 Star WARs-Star RAWs
      • fe50
  • Publish
    Re: IXUS110IS / SD960IS porting
    « Reply #42 on: 02 / February / 2013, 04:12:49 »
    Added the
    • IXUS110 / SD960 1.00B
    full 8MB dump (dumped with cBasic udumper) by cyberT from this forum post to the CHDK P&S FW dumps repository.

  • Publish
    Re: IXUS110IS / SD960IS porting
    « Reply #43 on: 03 / February / 2013, 17:31:15 »
    First test version for firmware 1.00b
    Since I can't test this myself, please report whether it works, and any issues that you find.
    You have to use the bootable SD card method.
    Please note that
    - you can enter/leave ALT mode by a short press on the play [>] button
    - you have to press the play button longer for its original function
    - you must leave ALT mode to be able to switch the camera off with the on/off button

    To all "testers":
    You need to convince me to enable autobuild for the pending fw revisions (1.00b, 1.01f, 1.01g) :)

    That was fast. Thank you so much.
    The first feeback I can give, boot of CHDK and RAW photography works good as expected.


    *

    Offline srsa_4c

    • ******
    • 3118
  • Publish
    Re: IXUS110IS / SD960IS porting
    « Reply #44 on: 04 / February / 2013, 10:59:56 »
    The first feeback I can give, boot of CHDK and RAW photography works good as expected.
    Sounds good so far.
    If you could additionally try some exposition overrides (extra photo operations submenu), and confirm that video recording doesn't crash, that would be enough for me to enable autobuild. (that applies to testers with 1.01f and g too).

  • Publish
    Re: IXUS110IS / SD960IS porting
    « Reply #45 on: 04 / February / 2013, 16:42:28 »
    Sounds good so far.
    If you could additionally try some exposition overrides (extra photo operations submenu), and confirm that video recording doesn't crash, that would be enough for me to enable autobuild. (that applies to testers with 1.01f and g too).

    - Video recording, incl. zooming and focus update is working
    - Exposure override works as well

    Thank you very much. Just let me know in case you'd like to see something else to be tested.

    *

    Offline srsa_4c

    • ******
    • 3118
  • Publish
    Re: IXUS110IS / SD960IS porting
    « Reply #46 on: 04 / February / 2013, 20:13:33 »
    - Video recording, incl. zooming and focus update is working
    - Exposure override works as well

    Thank you very much. Just let me know in case you'd like to see something else to be tested.
    Thanks for the feedback. I have enabled autobuild for 1.00b.

  • Publish
    Re: IXUS110IS / SD960IS porting
    « Reply #47 on: 12 / February / 2013, 21:29:52 »
    Hey there.  I just wanted to let you know that 101f appears to be working just fine on my SD960 IS.  I had a little problem with wink and ended up using Cardtricks for the install but I'm sure that's all due to my own learning curve.  I will be testing the different functions as I learn chdk but thought I would share my feedback.  I will attempt to try what you asked with the video as well and see if it crashes.

    Thanks for all the work I'm excited to have an intervalometer on my $30 ebay camera.


  • Publish
    Re: IXUS110IS / SD960IS porting
    « Reply #48 on: 12 / February / 2013, 22:56:52 »
    On 101f I have tested video both zooming and autofocus and all is well.  Shutter Speed override is also working.  However ISO override is acting peculiar.  Here are my findings

    ISO set in CHDK - ISO reported by camera during shot and review
    140 - 200
    1400 - 2000
    150 - 250
    1500 - 2500
    160 - 250
    1600 - 2500

    I tried actual settings in the camera set at both 1600 ISO and Auto.  I hope this helps and let me know if you want me to test anything else.

  • Publish
    Re: IXUS110IS / SD960IS porting
    « Reply #49 on: 12 / February / 2013, 23:11:25 »
    However ISO override is acting peculiar. 
    Perfectly normal for CHDK.  Welcome to the world of "Marketing ISO"  vs  "Real ISO".   There are lots of discussions about this in this forum going back many years.  Basically Canon's stated ISO values are too high when you do actual exposure calculation based on scene luminance,  shutter speed and aperature.   So CHDK uses "real ISO" values that actually make the calculations work.   The Canon ISO value are pretty much a marketing play to make you  think your sensor is more sensitive  than it really is.

    http://chdk.wikia.com/wiki/CHDK_User_Manual#Override_ISO_value

    http://chdk.setepontos.com/index.php?topic=895.msg9036#msg9036
    « Last Edit: 12 / February / 2013, 23:15:01 by waterwingz »

     

    Related Topics