Canon SX10IS stabilty problems with CHDK

  • 7 Replies
  • 1512 Views
Canon SX10IS stabilty problems with CHDK
« on: 25 / May / 2013, 10:03:40 »
Advertisements
I am using CHDK version 1.1.0-2766 on a Canon SX10IS version 101a, and am having some stability issues at startup.  It usually boots up correctly, but sometimes will crash (lock up) when starting CHDK.  When this happens, none of the buttons work, and the only way to regain control of the camera is to open and close the battery case...and try again.  "Play" mode is much more likely to lock up than the regular "camera" mode.  BTW, I am using a dual-partition 8GB SDHC card.

Step-by-step:
  1: Power-on
  2: Lens comes out, screen lights up with the camera view (splash screens disabled)
  3: A second later, the blue light flashes (in the default CHDK button), and the camera locks up (picture stops updating, buttons don't work)
  4: About ten seconds later later (more or less), the screen turns off, with the camera still locked up.  Weird things can happen here: sometimes it resets, once there was a "pop" from the focusing assembly, etc.  One time, the screen lit back up for a second with "E16" on the lower left corner.  Try, try, try again, and then it boots correctly.

One minor bug in CHDK: When the screen is facing towards the subject (away from the user), the CHDK text is mirrored left-to-right, making it rather hard to read.

Problems aside, a thanks for CHDK to everyone who has worked on it.  The cameras truly can do more!

Re: Canon SX10IS stabilty problems with CHDK
« Reply #1 on: 25 / May / 2013, 10:19:19 »
A couple of questions?

1) Does the problem get worse as the number of images on your SD card increases ? 

I noticed this fix is not enabled for the sx10 :
http://chdk.setepontos.com/index.php?topic=6179.0

2) Have you tried smaller card with a single partition?

Ported :   A1200    SD940   G10    Powershot N    G16

Re: Canon SX10IS stabilty problems with CHDK
« Reply #2 on: 25 / May / 2013, 11:16:42 »
To answer:
  1: In a quick test with a large video on the card, "Play" mode locks up a lot more frequently.
  2: I tried a 2GB SD card (not SDHC) formatted with FAT16, and could not reproduce the problem.  The camera also boots a lot faster with the SD card, as compared to the class 10 SDHC card.

With the 8GB SDHC card, when turned on in "Play" mode, the camera can lock up with either a blank screen (photo), or with a video thumbnail.  On rare occasions, CHDK will boot up with a garbled font, making the menus particularly hard to use.  Perhaps this might be a related problem?  (I can provide a photo of the screen, if that would help.)

Re: Canon SX10IS stabilty problems with CHDK
« Reply #3 on: 25 / May / 2013, 11:35:12 »
Try the attached build - I enabled the :

#define CAM_STARTUP_CRASH_FILE_OPEN_FIX 1

option.
Ported :   A1200    SD940   G10    Powershot N    G16


Re: Canon SX10IS stabilty problems with CHDK
« Reply #4 on: 25 / May / 2013, 11:56:06 »
That build seems to fix the startup crashing: despite quite a few tests, it hasn't crashed.  Thanks. :)

P.S. Now, if only something like this existed for the Sony DSC-HX100V... ;).  Sony appears to release source code on their website http://www.sony.net/Products/Linux/DI/DSC-WX7.html.




Re: Canon SX10IS stabilty problems with CHDK
« Reply #5 on: 25 / May / 2013, 12:44:51 »
That build seems to fix the startup crashing: despite quite a few tests, it hasn't crashed.  Thanks. :)
Please post again if you see another crash.  Otherwise I'll post the patch for inclusion in the svn & autobuild.

Quote
P.S. Now, if only something like this existed for the Sony DSC-HX100V... ;).  Sony appears to release source code on their website http://www.sony.net/Products/Linux/DI/DSC-WX7.html.
I took a quick look - looks like they are releasing anything covered under the GPL - as required where they are using GPL'd code.   Not sure if you can actually rebuild camera firmware from that but I didn't take any additional time looking.
Ported :   A1200    SD940   G10    Powershot N    G16

Re: Canon SX10IS stabilty problems with CHDK
« Reply #6 on: 26 / May / 2013, 19:57:13 »
The patch seems to have solved the problem.  When using the camera normally yesterday evening (over 200 photos on a trip) and today, the camera didn't crash on startup.  Thanks a lot.

Re: Canon SX10IS stabilty problems with CHDK
« Reply #7 on: 27 / May / 2013, 11:15:34 »
The patch seems to have solved the problem. 
I submitted the patch for inclusion in the autobuild  (stable & dev trunks).

There seems to be some debate about whether the same patch should be applied to all DryOS cameras so it might be a few days before the fix gets into the normal release channel.

Ported :   A1200    SD940   G10    Powershot N    G16


 

Related Topics