CHDK loads off one card, not off another? - General Help and Assistance on using CHDK stable releases - CHDK Forum

CHDK loads off one card, not off another?

  • 5 Replies
  • 2549 Views
*

Offline eheil

  • *
  • 12
CHDK loads off one card, not off another?
« on: 09 / April / 2008, 21:07:34 »
Advertisements
Hey, I've been a very happy CHDK user (with an A570IS) for a few weeks now.  I've just bought my second memory card and I'm having problems getting CHDK to load from it.

My first card was very nice -- a SanDisk Ultra II, 1 gig.  I got the latest Allbest (#49) running from it, no problem, and have been using it for a few weeks.

I got a second card, a much cheaper one, from PNY, also 1 gig, to use as a backup.  I put it in the A570 and had the camera give it a low-level format.  Then, using a card reader and my computer (a macbook) I copied my PS.FIR and DISKBOOT.BIN files from the old card directly to the root directory of this one.

No love!  I don't get a firmware upgrade menu item at all.  The camera behaves as if PS.FIR and DISKBOOT.BIN are not there at all.  I tried flipping on the lock but then the camera just complains about a locked card.  Still no firmware upgrade menu item.

Just to make sure I was doing the right thing I re-downloaded the zipfile of the build that had worked for me before, unzipped it and copied *those* files in there.  No effect.

Any obvious things I should check on here?  I have no idea what I did differently from the old card to this one.  Maybe I shouldn't have low-level formatted it?  No idea.

Thanks very much for any assistance!

*

Offline GrAnd

  • ****
  • 916
  • [A610, S3IS]
    • CHDK
Re: CHDK loads off one card, not off another?
« Reply #1 on: 09 / April / 2008, 23:52:32 »
Try take a picture using your new SD and then look the "Firmware Update" menu again. There were some reports that some cameras do not display update menu on new cards.
CHDK Developer.

Re: CHDK loads off one card, not off another?
« Reply #2 on: 10 / April / 2008, 03:54:18 »
Deleted
« Last Edit: 22 / April / 2008, 17:06:21 by Barney Fife »
[acseven/admin commented out: please refrain from more direct offensive language to any user. FW complaints to me] I felt it imperative to withdraw my TOTAL participation. Nobody has my permission, nor the right, to reinstate MY posts. Make-do with my quoted text in others' replies only. Bye

*

Offline eheil

  • *
  • 12
Re: CHDK loads off one card, not off another?
« Reply #3 on: 10 / April / 2008, 08:12:54 »
Thanks for the reply!

Hmm -- that would explain why it didn't work when I used the freshly unzipped files, but not why it didn't work when I used copies of the files that had worked previously on the other card.  (I had unzipped those with a command line utility that didn't add the security flag!)

I tried again, using the command line utility for the zipfile this time so there would be no security flag, using the 'xattr -d' command just to make doubly sure, and making sure there were no '@' signs in the ls -l output, with no better luck than before.

I wonder if it could be the low level format I gave the card?  Would that affect anything?

I'm about ready to return the card.  "Sorry, guys, it didn't work.  I mean, it took pictures just fine but it stopped me from hacking my firmware!"


*

Offline eheil

  • *
  • 12
Re: CHDK loads off one card, not off another?
« Reply #4 on: 10 / April / 2008, 18:16:42 »
Well, I took the darn thing back, bought another of the kind I already had (SanDisk Ultra II 1 gig) and that one works great.  I guess I won't be buying PNY again!

Re: CHDK loads off one card, not off another?
« Reply #5 on: 07 / May / 2008, 21:07:06 »
I can confirm that in trying to get CHDK to work on a 2gb PNY card that it also gave problems and would not load CHDK. My friend took it back and got a Sandisk Ultra II and it loaded fine.
~~~~~~~~~~~~~~~~~~~~~

<")%%%><<

 

Related Topics