Turning Flash off disables saving RAW files - RAW Shooting and Processing - CHDK Forum

Turning Flash off disables saving RAW files

  • 18 Replies
  • 5829 Views
*

Offline McG

  • *
  • 7
Turning Flash off disables saving RAW files
« on: 25 / June / 2013, 18:06:53 »
Advertisements
I'm using the current stable release of ixus70_sd1000-101a-1.1.0-2904 on my SD1000, and have tried the latest dev build, but both have the same problem. If I leave the flash set to Auto (in the standard Canon menu), then jpeg & raw files are created, but when I turn the flash off, only the jpeg file is generated. I don't have any RAW exceptions set.

I've tried using the "Extra Photo Operations->Force Manual Flash" setting with a Flash Power of 0, but the flash still fires. This is a problem because I'm doing some nature photography and the flash can scare away the animals.

Any suggestions? Or is this a known issue?

Thanks.

Re: Turning Flash off disables saving RAW files
« Reply #1 on: 25 / June / 2013, 19:07:21 »
If I leave the flash set to Auto (in the standard Canon menu), then jpeg & raw files are created, but when I turn the flash off, only the jpeg file is generated. I don't have any RAW exceptions set.
Its certainly not something my cameras do - but I tested to confirm that just in case.

How are you "turning off the flash?"? Using the flash symbol on the right  hand side of the "multifuntion ring" on the back of the camera?

CHDK has a couple of funny modes where it disables RAW based on the camera configuration and scene mode.  But it doesn't look like anything you should have hit.
Ported :   A1200    SD940   G10    Powershot N    G16

*

Offline srsa_4c

  • ******
  • 4416
Re: Turning Flash off disables saving RAW files
« Reply #2 on: 25 / June / 2013, 19:08:31 »
I'm using the current stable release of ixus70_sd1000-101a-1.1.0-2904 on my SD1000, and have tried the latest dev build, but both have the same problem. If I leave the flash set to Auto (in the standard Canon menu), then jpeg & raw files are created, but when I turn the flash off, only the jpeg file is generated. I don't have any RAW exceptions set.
...
is this a known issue?
There is another similar report for this camera, the issue is probably related: http://chdk.setepontos.com/index.php?topic=9613.0

I'll post a couple of test builds (diskboot.bin files only) for your camera. If you can report which one works correctly (if any), that would help.

Re: Turning Flash off disables saving RAW files
« Reply #3 on: 25 / June / 2013, 19:22:12 »
There is another similar report for this camera, the issue is probably related: http://chdk.setepontos.com/index.php?topic=9613.0
That one had an interesting resolution - it appears the OP was using the wrong build ( i.e. wrong firmware version)?

@McG :  how did you determine that your camera has firmware version 1.01A  rather than one of the other three firmware versions?
Ported :   A1200    SD940   G10    Powershot N    G16


*

Offline srsa_4c

  • ******
  • 4416
Re: Turning Flash off disables saving RAW files
« Reply #4 on: 25 / June / 2013, 19:46:58 »
That one had an interesting resolution - it appears the OP was using the wrong build ( i.e. wrong firmware version)?
No, his(?) last post was edited, he messed up copying my test build - or at least I think so.

@McG
Test builds attached (diskboot.bin files only), you can use all other files from a recent autobuld release. If any of these makes your issue go away, please report it.
« Last Edit: 25 / June / 2013, 20:15:48 by srsa_4c »

*

Offline McG

  • *
  • 7
Re: Turning Flash off disables saving RAW files
« Reply #5 on: 25 / June / 2013, 22:06:17 »
@waterwingz

I am using the multifunction ring to turn off the flash

I used the vers.req and came back with
Firmware Ver GM1.01A
I also tried CameraVersion to confirm from the EXIF data.


@srsa_4c

I saw that other post, but I did a complete fresh install to be sure.

I tried each of the diskboot.bin files, but still have the same problem.

Re: Turning Flash off disables saving RAW files
« Reply #6 on: 25 / June / 2013, 22:13:15 »
Its curious that this is always a function of the flash setting - a bit different than the random behavior reported in the other thread.

Makes me suspicious of the is_raw_enabled() function in https://www.assembla.com/code/chdk/subversion/nodes/2904/trunk/core/conf.c  but its not immediately obvious to me how.
Ported :   A1200    SD940   G10    Powershot N    G16

*

Offline srsa_4c

  • ******
  • 4416
Re: Turning Flash off disables saving RAW files
« Reply #7 on: 25 / June / 2013, 22:31:10 »
I tried each of the diskboot.bin files, but still have the same problem.
Just to be sure, you are using a locked SD card to load CHDK automatically on start, right?
The test build you can find in the linked thread should also work on your camera (CHDK is the same for 1.01a and 1.01b), but that build simply overrides the whole raw check (and will not help identifying the issue).

Makes me suspicious of the is_raw_enabled() function
My test build series here tests for disabling each check in that function (one of the checks is disabled in every build).


*

Offline reyalp

  • ******
  • 13234
Re: Turning Flash off disables saving RAW files
« Reply #8 on: 25 / June / 2013, 22:53:09 »
Makes me suspicious of the is_raw_enabled() function
My test build series here tests for disabling each check in that function (one of the checks is disabled in every build).
If raw is disabled by one of these checks "Raw disabled" (or DNG disable) should appear on the screen.
Don't forget what the H stands for.

*

Offline McG

  • *
  • 7
Re: Turning Flash off disables saving RAW files
« Reply #9 on: 25 / June / 2013, 23:07:17 »
@srsa_4c

Yes, I'm using a locked SD card to load chdk automatically.

I tried the build from that post, and it doesn't help, but I guess that confirms that it's not simply an accidentally enabled exception.

@reyalp

"Raw disabled" messages aren't appearing on the screen.

 

Related Topics