supplierdeeply

Problem with scripts on 2 partition 8 GB card in Canon G10

  • 7 Replies
  • 1071 Views
Problem with scripts on 2 partition 8 GB card in Canon G10
« on: 26 / June / 2013, 19:51:56 »
Advertisements
I have a 2 partition card with CHDK installed.  CHDK loads properly at startup.  When I go to the Scripts menu it cannot find any scripts.  I have tried loading the CHDK files in partition 1, in partition 2, and both.  The bootdisk.bin and ps.f12 are in partition 1 the disk lock is on.  In each configuration when I start the Scripts menu and try to load a menu from the files it says that the scripts file does not exist.  I have also loaded CHDK on a single partition 4GB card and scripts works fine.  What am I doing wrong?  What CHDK files go in which partition of the 8GB card?

Re: Problem with scripts on 2 partition 8 GB card in Canon G10
« Reply #1 on: 26 / June / 2013, 20:41:07 »
In each configuration when I start the Scripts menu and try to load a menu from the files it says that the scripts file does not exist. 
This is confusing.  You go to the Scripts menu and try to load a menu from the files?   

Or do you mean that you go to the Script menu,  and select the "Load Script From File..." menu item? And at that point you get a message box that says "Script Files Do Not Exist"?

Please be precise.

Quote
What CHDK files go in which partition of the 8GB card?
The ps.fi2 and diskboot.bin files go in the small FAT16 primary partition.   All the other files go with their folders into the larger FAT32 partition.
Ported :   A1200    SD940   G10    Powershot N    G16

Re: Problem with scripts on 2 partition 8 GB card in Canon G10
« Reply #2 on: 26 / June / 2013, 21:06:21 »
I have just reset the files to the way you describe.  When I go to <alt>  and press the func key, the "Script" menu displays.  When I highlight "Load Script from File" and press the func key I get me message "Fail to load fselect.f1t file not found". :(

Re: Problem with scripts on 2 partition 8 GB card in Canon G10
« Reply #3 on: 26 / June / 2013, 21:12:07 »
I have just reset the files to the way you describe.  When I go to <alt>  and press the func key, the "Script" menu displays.  When I highlight "Load Script from File" and press the func key I get me message "Fail to load fselect.f1t file not found". :(
The error message basically says that the fselect.flt  (file select) module is not on your SD card.  It should be in the /CHDK/MODULES directory on the large partition of your SD card.

If its there then the only other thing I can think of is some problem with how you setup your dual partitioned card.  What instructions did you follow and what tools did you use?
Ported :   A1200    SD940   G10    Powershot N    G16


Re: Problem with scripts on 2 partition 8 GB card in Canon G10
« Reply #4 on: 26 / June / 2013, 21:36:06 »
Success at last. :D  I put the SD card in my computer and looked at the CHDK directory on the card.  All of the sub directories were their, but when I looked in each of these directories, they were all empty.  I copied the CHDK directory from the 4GB card, that I know worked, to partition 2 of the 8GB card.  I loaded the card in my G10 and it worked as advertised. :D

I am runing Linux.  It makes it easy to work with multi partition SD cards.  I used a UNIX program named LICKS to set up the partitions.

Thank you for your assistance.  You pointed me in the right direction.  I still do not understand what happened to all the files in the sub-directories.

Now on the the next step in the steep learning curve. :)

Re: Problem with scripts on 2 partition 8 GB card in Canon G10
« Reply #5 on: 26 / June / 2013, 21:43:04 »
I am runing Linux.  It makes it easy to work with multi partition SD cards.  I used a UNIX program named LICKS to set up the partitions.
There is a successor to LICKS called STICK.  Written by the same programmer but a much more compete program - does the whole download, card format,  CHDK install for you on Linux, Windows or Mac.
Ported :   A1200    SD940   G10    Powershot N    G16

Re: Problem with scripts on 2 partition 8 GB card in Canon G10
« Reply #6 on: 26 / June / 2013, 21:54:54 »
Thanks, I have now downloaded Stick.

Re: Problem with scripts on 2 partition 8 GB card in Canon G10
« Reply #7 on: 26 / June / 2013, 23:17:20 »
Thanks, I have now downloaded Stick.
Glad we could help.

Roll Tide.
Ported :   A1200    SD940   G10    Powershot N    G16


 

Related Topics