supplierdeeply

Override ISO doesn't override noise reduction

  • 2 Replies
  • 1007 Views
Override ISO doesn't override noise reduction
« on: 27 / June / 2013, 15:42:17 »
Advertisements
Normally in HQ burst mode in the SX50, the camera is set to "auto iso" and that unfortunately means high ISO and high noise. CHDK will allow me to manually override ISO to a lower value and HQ burst works well. However, it is useless for my purposes because the camera processes the image with noise reduction appropriate for the fictional one it would have chosen instead of the override value it used due to CHDK. So you get the changed ISO but still get the watercolor look of overdone noise reduction.

It sure would be nice of the camera either disabled its noise reduction (yes I found earlier requests but no solution) or it convinced the JPG engine that the new ISO was the true ISO.

Don

*

Offline philmoz

  • *****
  • 3070
    • Photos
Re: Override ISO doesn't override noise reduction
« Reply #1 on: 27 / June / 2013, 18:50:36 »
Normally in HQ burst mode in the SX50, the camera is set to "auto iso" and that unfortunately means high ISO and high noise. CHDK will allow me to manually override ISO to a lower value and HQ burst works well. However, it is useless for my purposes because the camera processes the image with noise reduction appropriate for the fictional one it would have chosen instead of the override value it used due to CHDK. So you get the changed ISO but still get the watercolor look of overdone noise reduction.

It sure would be nice of the camera either disabled its noise reduction (yes I found earlier requests but no solution) or it convinced the JPG engine that the new ISO was the true ISO.

Don

Some things to try:
  • Set 'High ISO NR' to Low in the Canon menu.
  • Use the 'Custom Color' option in the 'My Colors' settings and set sharpening to the lowest value, then sharpen in post processing.

AFAIK no-one has reversed engineered how the ISO based noise reduction is handled in the firmware, so there is no option to turn it off.

Phil.
CHDK ports:
  sx30is (1.00c, 1.00h, 1.00l, 1.00n & 1.00p)
  g12 (1.00c, 1.00e, 1.00f & 1.00g)
  sx130is (1.01d & 1.01f)
  ixus310hs (1.00a & 1.01a)
  sx40hs (1.00d, 1.00g & 1.00i)
  g1x (1.00e, 1.00f & 1.00g)

Re: Override ISO doesn't override noise reduction
« Reply #2 on: 28 / June / 2013, 18:26:21 »

Some things to try:
  • Set 'High ISO NR' to Low in the Canon menu.
  • Use the 'Custom Color' option in the 'My Colors' settings and set sharpening to the lowest value, then sharpen in post processing.
Thanks for replying Phil. Already had set "high ISO NR" to low and sharpening to lowest value. Unfortunately that doesn't work very well. Preferable would be to somehow be able to do a high speed burst in raw mode (probably necessarily shorter) and/or be able to disable jpg NR.
Quote
AFAIK no-one has reversed engineered how the ISO based noise reduction is handled in the firmware, so there is no option to turn it off.

Phil.

I saw that in my search of old posts. There are two approaches I can imagine: either disable NR or somehow extend the overridden value of ISO to the routine where it decides, based on ISO, how much NR to apply. It would really improve the utility of the HQ Burst mode which right now is crippled by Canon's forced values. It becomes high speed water color paintings instead of HQ bursts.

Don

 

Related Topics