Anyway to turn off lens check and thus the E32 error.

  • 3 Replies
  • 1472 Views
Anyway to turn off lens check and thus the E32 error.
« on: 11 / July / 2013, 13:50:28 »
Advertisements
I have a SD1300 camera.  It works fine for about 40 seconds after power up then I get the E32 error and restart message.  Since the lens does come out all the way and works, I think the flex cable has a broken wire so that the camera can't detect that the lens is fully extended and thus it shuts down after 40 seconds.  Is there a way to override this using CHDK so that it doesn't check to prevent the E32 error?

*

Offline srsa_4c

  • ******
  • 3665
Re: Anyway to turn off lens check and thus the E32 error.
« Reply #1 on: 11 / July / 2013, 16:50:11 »
E32 means that there's a problem with the image stabilizer (it's probably not working).

You can use the following Lua script to prevent camera shutdown:
Code: [Select]
call_event_proc("Mecha.Create")
call_event_proc("StartImStEventProc")
call_event_proc("DisableISDriveError")
Copy these lines into a text file named like "e32fix.lua", and execute it each time you switch the camera into record mode. You need CHDK 1.2 to run the script, and you need to enable "Lua native calls" in the Misc. menu.
You could also get a special CHDK build that doesn't need this script, if you tell me your camera's firmware version.

*

Offline ahull

  • *****
  • 634
Re: Anyway to turn off lens check and thus the E32 error.
« Reply #2 on: 12 / July / 2013, 07:10:41 »
You may be able to work round this by putting the camera in manual mode, and from the Settings Menus change IS Mode to Off.
It rather depends on what exactly the issue is with the camera. (Returning to Auto mode will switch it back on BTW).

If that is not an option, then one other trick  you might like to try is to power on the camera and gently tap the base of the camera on a soft surface a few times to see if the IS "un-sticks"

Failing that... flog it on ebay and get another one  :blink:

Re: Anyway to turn off lens check and thus the E32 error.
« Reply #3 on: 12 / July / 2013, 13:03:50 »
Thanks all.  I tried turning off the IS and that didn't seem to do anything.  No matter, what srsa_4c suggested works perfect.  I have a fully functional camera again.  Thanks for the offer to compile but I had to compile it anyways to turn native calls on.  This will be use as my experimental security cam.


 

Related Topics