Problems overriding shutter speed on SX40 - page 2 - General Help and Assistance on using CHDK stable releases - CHDK Forum

Problems overriding shutter speed on SX40

  • 36 Replies
  • 8655 Views
Re: Problems overriding shutter speed on SX40
« Reply #10 on: 14 / July / 2013, 21:45:30 »
Advertisements
That build was from the camera's firmware info - the same place I see 100.G. Can I get a newer Canon firmware or something?

- Eric

*

Offline reyalp

  • ******
  • 13386
Re: Problems overriding shutter speed on SX40
« Reply #11 on: 14 / July / 2013, 21:54:34 »
That build was from the camera's firmware info - the same place I see 100.G. Can I get a newer Canon firmware or something?
No.

You need to give sufficient detail about what you are doing for philmoz to reproduce your problem. He has the camera, with the same firmware version. The overrides work for him. So either you are doing something wrong, or there is some specific thing you are doing that triggers the problem.

This could be Canon settings, CHDK settings, or other factors like having an external flash attached or pressing the shutter quickly without giving the camera time to do AE and AF (examples of things that have triggered similar problems in the past.)
Don't forget what the H stands for.

Re: Problems overriding shutter speed on SX40
« Reply #12 on: 14 / July / 2013, 22:05:04 »
I just reset all settings from the camera, and CHDK. I then set the TV override to 30 seconds, and took a picture. Shutter was <1 second.

Is that helpful?

Re: Problems overriding shutter speed on SX40
« Reply #13 on: 14 / July / 2013, 22:15:05 »
A build from Sep 2011 is very old - try downloading the latest 1.2 build onto a clean SD card.
I just reset all settings from the camera, and CHDK. I then set the TV override to 30 seconds, and took a picture. Shutter was <1 second.
Is that helpful?
Until you download and install a current version of CHDK, I don't think any testing you are doing is going to be helpful.
Ported :   A1200    SD940   G10    Powershot N    G16


Re: Problems overriding shutter speed on SX40
« Reply #14 on: 14 / July / 2013, 22:42:37 »
My CHDK Version is 1.2.0-2954
Revision: 0
Date: July 14 2013


*

Offline reyalp

  • ******
  • 13386
Re: Problems overriding shutter speed on SX40
« Reply #15 on: 14 / July / 2013, 22:53:03 »
I just reset all settings from the camera, and CHDK. I then set the TV override to 30 seconds, and took a picture. Shutter was <1 second.
What are the actual settings you entered in the "extra photo operations" menu?
What Canon shooting mode is the camera in (M, Tv, some special scene mode, etc)?
What does the override display (in red in the upper left) show?
Did you wait press half shoot long enough for the camera to pre-focus?
Is an external flash attached?
Don't forget what the H stands for.

Re: Problems overriding shutter speed on SX40
« Reply #16 on: 14 / July / 2013, 23:19:20 »
Disable Overrides: No
Override Tv Type: LongExp
Long Exp Value: 0:00:30 (can't figure out how to adjust the minutes here)

And that it. Everything else is factory default both Canon and CHDK.

I'm shooting in Manual mode. Can you suggest any settings/modes that I should try?

Re: Problems overriding shutter speed on SX40
« Reply #17 on: 14 / July / 2013, 23:22:36 »
Oh, and to answer the other questions:

There's red text in the upper left of the screen: TV:0:00:30

Yes on the half shooting, and no external flash.

Thanks!


Re: Problems overriding shutter speed on SX40
« Reply #18 on: 15 / July / 2013, 00:04:08 »
(can't figure out how to adjust the minutes here)
Use your zoom lever to move back and forth across the input field.
Ported :   A1200    SD940   G10    Powershot N    G16

*

Online philmoz

  • *****
  • 3332
    • Photos
Re: Problems overriding shutter speed on SX40
« Reply #19 on: 15 / July / 2013, 01:41:29 »
Oh, and to answer the other questions:

There's red text in the upper left of the screen: TV:0:00:30

Yes on the half shooting, and no external flash.

Thanks!

When you half press the shutter does the Canon selected shutter speed (bottom of the LCD) change to 30 seconds?

Phil.
CHDK ports:
  sx30is (1.00c, 1.00h, 1.00l, 1.00n & 1.00p)
  g12 (1.00c, 1.00e, 1.00f & 1.00g)
  sx130is (1.01d & 1.01f)
  ixus310hs (1.00a & 1.01a)
  sx40hs (1.00d, 1.00g & 1.00i)
  g1x (1.00e, 1.00f & 1.00g)
  g5x (1.00c, 1.01a, 1.01b)
  g7x2 (1.01a, 1.01b, 1.10b)

 

Related Topics