G15 problems after installing CHDK

  • 5 Replies
  • 1741 Views
G15 problems after installing CHDK
« on: 14 / July / 2013, 12:55:03 »
Advertisements
Hello All,
I am new to this forum and relatively technically savvy, but not to the point of creating firmware/programs, nor even understanding a lot of the tech language I have been reading on this site. Hoping someone can help me anyway. I installed the CHDK g15-100b-1.1.0-2921-full_BETA on my G15 a few days ago. It was late at night, so I did not have a chance to program or test it right away. Two days later, I was shooting some pics in standard mode, without having done anything to or in CHDK yet, except to see if the menu came up. Everything was going along OK, until about 20 pics into the shoot, some of the camera's functions started freezing up. For instance, I could no longer zoom in or out. I restarted the camera and it went well for a few more shots, then started doing the same thing. Thinking it might be the CHDK on my card that was responsible, I switched to another card that did not contain the CHDK. But it still kept on doing it. And, as time went by, the situation got worse and worse, to where now, the camera will shoot pics, but only on the presets present. It will not let me into the Menu or the Function Set areas, it will not zoom in or out. I can review pics made, but only in scroll mode. No single pics, no zooming in. When I try to access the menu, I get the flashing red camera shake icon.

Totally not sure if this is CHDK Beta causing my camera to do this, or if it's just something with the camera itself. It was never bumped or dropped or exposed to any extreme conditions. The only thing that was done to it that was different than before, is the CHDK installation on the card and the viewing of the CHDK menu.

Any thoughts or similar experiences from anyone?

Thanks in advance!

Re: G15 problems after installing CHDK
« Reply #1 on: 14 / July / 2013, 13:19:31 »
Any thoughts or similar experiences from anyone?
Thanks in advance!
So are you still having these problems when using an SD card on which CHDK has never been loaded?  CHDK makes no permanent changes to your camera so when you power off - it is 100% gone. 

If so,  anything it possible.  You might have "zapped" the firmware on your camera while experimenting with CHDK although there has never been a known documented case of CHDK doing that.  And certainly not if all you did was active the CHDK menu as a test.

It seems more likely that you have a hardware problem with your camera and that it's unrelated to CHDK.  Which leaves you with returning to Canon for repair I guess.
Ported :   A1200    SD940   G10    Powershot N    G16

Re: G15 problems after installing CHDK
« Reply #2 on: 14 / July / 2013, 13:50:06 »
Thanks for your reply. Which now then leads me to another question/concern: in the unlikely event that CHDK might have "zapped" the firmware on my card, will that be apparent to Canon when they receive my camera? And would that void my warranty?

Re: G15 problems after installing CHDK
« Reply #3 on: 14 / July / 2013, 14:09:12 »
Thanks for your reply. Which now then leads me to another question/concern: in the unlikely event that CHDK might have "zapped" the firmware on my card, will that be apparent to Canon when they receive my camera? And would that void my warranty?
Can't speak for Canon but I think the most likely answer is "no - it won't be apparent" - especially as I don't believe this was caused by CHDK.  But I would not return the camera with an SD card loaded with CHDK and tempt fate.
Ported :   A1200    SD940   G10    Powershot N    G16


*

Offline reyalp

  • ******
  • 11336
Re: G15 problems after installing CHDK
« Reply #4 on: 14 / July / 2013, 15:06:18 »
Thanks for your reply. Which now then leads me to another question/concern: in the unlikely event that CHDK might have "zapped" the firmware on my card, will that be apparent to Canon when they receive my camera? And would that void my warranty?
I would add that CHDK "zapping" the factory firmware is pretty hypothetical.

Experienced programmers are very reluctant to speak in absolutes, so waterwingz is trying to make sure all the bases are covered.

It is theoretically possible in the sense that the camera has the capability to modify the on-board flash where the Canon firmware resides, but there isn't any specific known mechanism that would cause CHDK to do this. CHDK never intentionally writes to the on-board flash. The possibility that it could accidentally do this, and leave the firmware in a semi-functional state is very, very small.

The Canon firmware does store some settings in the on-board flash. It is theoretically possible that CHDK could cause this process to fail in some way that would affect camera function but again, there is no known, specific mechanism for CHDK to cause this kind of problem. It's very difficult to see how the symptoms you describe would fit this scenario.

In general, if you don't have CHDK on the card, there should be no sign that you used CHDK. However if the camera crashes or encounters a hardware error that makes it shut down, the Canon firmware does record a log to internal flash. This log can include some signs of CHDK. I would be quite surprised if Canon looked at this as a matter of course.
Don't forget what the H stands for.

Re: G15 problems after installing CHDK
« Reply #5 on: 14 / July / 2013, 18:24:12 »
Thank you both. I appreciate the input. I guess I will be calling Canon.  :)

 

Related Topics