IXUS 132 / ELPH 115 IS Porting Thread - page 8 - DryOS Development - CHDK Forum

IXUS 132 / ELPH 115 IS Porting Thread

  • 110 Replies
  • 50129 Views
*

Offline gon

  • *
  • 6
Re: IXUS 132 / ELPH 115 IS Porting Thread
« Reply #70 on: 16 / March / 2014, 14:17:52 »
Advertisements
Now that it's in the trunk,  also getting a mf test result for this camera would be good. 

Somebody?

http://chdk.setepontos.com/index.php?topic=11078.msg108859#msg108859

1)
2) set_focus: turns off
3) set_aflock: passed
4) PressSW1AndMF: turns off
5) ss.create: passed
6) RegisterShootSeqEvent: fail


Quote
Sun Mar 16 19:11:30 2014,MF Test 2.12 Log
ixus132_elph115,100b,CHDK,1.3.0-3371
Mode:P,Continuous_AF:1,Servo_AF:0
tests : set_focus:1, set_aflock:1, levents:1, event_procs:1, bypass:1
test,set,actual,result,prop.FOCUS_STATE,prop.AF_LOCK,prop.FOCUS_MODE,prop.REAL_FOCUS_MODE
1) Testing initial conditions
Sun Mar 16 19:12:05 2014,MF Test 2.12 Log
ixus132_elph115,100b,CHDK,1.3.0-3371
Mode:P,Continuous_AF:1,Servo_AF:0
tests : set_focus:1, set_aflock:1, levents:1, event_procs:1, bypass:1
test,set,actual,result,prop.FOCUS_STATE,prop.AF_LOCK,prop.FOCUS_MODE,prop.REAL_FOCUS_MODE
1) Testing initial conditions
...interlock bypass function available
...start, , , ,0,0,0,0
...shot1,108,106,passed,32,0,0,0
2) Testing set_focus() only
...start, , , ,32,0,0,0
Sun Mar 16 19:12:43 2014,MF Test 2.12 Log
ixus132_elph115,100b,CHDK,1.3.0-3371
Mode:P,Continuous_AF:1,Servo_AF:0
tests : set_focus:0, set_aflock:1, levents:1, event_procs:1, bypass:1
test,set,actual,result,prop.FOCUS_STATE,prop.AF_LOCK,prop.FOCUS_MODE,prop.REAL_FOCUS_MODE
1) Testing initial conditions
...interlock bypass function available
...start, , , ,0,0,0,0
...shot1,126,123,passed,32,0,0,0
2) Testing set_focus() only
   ..disabled
3) Testing set_aflock()
...start, , , ,32,0,0,0
...set_aflock(1), , , ,32,0,0,0
set_prop.AF_LOCK(1)
...start, , , ,32,1,0,0
...shot1,400,402,passed,32,1,0,0
...shot2,800,810,passed,32,1,0,0
...set_prop.AF_LOCK(0), , , ,32,0,0,0
...set_aflock(0), , , ,32,0,0,0
4) Testing levent PressSw1AndMF
...start, , , ,32,0,0,0
post_levent
...start, , , ,32,0,0,0
Sun Mar 16 19:14:54 2014,MF Test 2.12 Log
ixus132_elph115,100b,CHDK,1.3.0-3371
Mode:P,Continuous_AF:1,Servo_AF:0
tests : set_focus:0, set_aflock:1, levents:0, event_procs:1, bypass:1
test,set,actual,result,prop.FOCUS_STATE,prop.AF_LOCK,prop.FOCUS_MODE,prop.REAL_FOCUS_MODE
1) Testing initial conditions
...interlock bypass function available
...start, , , ,0,0,0,0
...shot1,117,123,passed,32,0,0,0
2) Testing set_focus() only
   ..disabled
3) Testing set_aflock()
...start, , , ,32,0,0,0
...set_aflock(1), , , ,32,0,0,0
set_prop.AF_LOCK(1)
...start, , , ,32,1,0,0
...shot1,400,403,passed,32,1,0,0
...shot2,800,813,passed,32,1,0,0
...set_prop.AF_LOCK(0), , , ,32,0,0,0
...set_aflock(0), , , ,32,0,0,0
4) Testing levent PressSw1AndMF
   ..disabled
5) Testing SS.Create
...start, , , ,32,0,0,0
...SS.Create success
...>testing SS.MFOn
...SS.MFOn success
...start, , , ,0,0,1,0
...shot1,600,614,passed,0,0,1,0
...shot2,1000,1030,passed,0,0,1,0
...disable_SS.MFOn, , , ,0,0,0,0
...>testing PT_MFOn
...PT_MFOn failed
6) Testing RegisterShootSeqEvent
...RegisterShootSeqEvent failed
7) Done

Re: IXUS 132 / ELPH 115 IS Porting Thread
« Reply #71 on: 16 / March / 2014, 14:47:09 »
I ran the test-script. Camera switches off. But it generates a file.
Can you please go into the script parameter setup (down at the bottom of the Script Menu), disable the set focus only test, and then rerun the script?

TIA

Ran the script again

Re: IXUS 132 / ELPH 115 IS Porting Thread
« Reply #72 on: 18 / March / 2014, 10:53:29 »
Hi everyone, and thanks for all your work porting CHDK to the IXUS 132.

I was looking for a cheap digital camera that can be controlled remotely, so the 132 + CHDK looked like a perfect match.

However, I can't get the camera to switch to record mode when being controlled through PTP.
I'm using chdk-ptpcam from a Linux host, and I think I managed to get the hang of basic functionality. Running scripts, sending LUA commands, downloading and uploading files all work fine. It's only the mode switch that doesn't work. When I connect the USB cable, the display turns off, the lens retracts and the camera goes into playback mode. Sending a "mode 1" doesn't seem to have any effect. In fact, it's even worse: As soon as I disconnect the USB cable, the camera hangs and can only be brought back by removing and reinserting the battery. Curiously, this also happens when I send a "mode 0" while the camera is already in playback mode.

I'm running the official 1.3.0-3378 build on firmware 100b.

Re: IXUS 132 / ELPH 115 IS Porting Thread
« Reply #73 on: 18 / March / 2014, 11:21:55 »
However, I can't get the camera to switch to record mode when being controlled through PTP.

= switch_mode_usb(1)
Ported :   A1200    SD940   G10    Powershot N    G16


Re: IXUS 132 / ELPH 115 IS Porting Thread
« Reply #74 on: 18 / March / 2014, 11:59:38 »
= switch_mode_usb(1)

I believe that's the same thing ptpcam --chdk="mode 1" does, and it has the same effect: It freezes the camera.

I should not that the camera doesn't crash immediately and completely, I can still send PTP commands. But as soon as I try to turn it off or disconnect USB, it freezes and only a battery re-insertion will help.

*

Offline srsa_4c

  • ******
  • 4426
Re: IXUS 132 / ELPH 115 IS Porting Thread
« Reply #75 on: 18 / March / 2014, 18:48:49 »
However, I can't get the camera to switch to record mode when being controlled through PTP.
I'm using chdk-ptpcam from a Linux host, and I think I managed to get the hang of basic functionality. Running scripts, sending LUA commands, downloading and uploading files all work fine. It's only the mode switch that doesn't work. When I connect the USB cable, the display turns off, the lens retracts and the camera goes into playback mode.
If you'd like to control the camera over ptp, start it in playback mode. When the cam is in playback mode and you connect it to the computer, the display should not turn off. If it does, something on the PC is communicating with the camera (it's likely some service/daemon related to gphoto), and brings it into a state where mode switch no longer works.

Re: IXUS 132 / ELPH 115 IS Porting Thread
« Reply #76 on: 19 / March / 2014, 11:38:10 »
If you'd like to control the camera over ptp, start it in playback mode. When the cam is in playback mode and you connect it to the computer, the display should not turn off. If it does, something on the PC is communicating with the camera (it's likely some service/daemon related to gphoto), and brings it into a state where mode switch no longer works.

Thanks a lot, this did the trick. I ran the setmode.lua test script remotely, it doesn't produce any errors with a timeout of 200ms.

I haven't figured out how to configure gphoto2 to specifically ignore this camera, neither hal nor udev overrides helped. Uninstalling libgphoto2 kept the camera turned on like it's supposed to be, and PTP image transfer never worked for me anyway.

The only feature I'm missing now is powering/charging the camera through USB, which doesn't seem to work with or without CHDK. I guess I need one of these battery adapters (like ACK-DC90).

Re: IXUS 132 / ELPH 115 IS Porting Thread
« Reply #77 on: 22 / June / 2014, 03:17:48 »
my camera is ixus 132 (actually ixy90f bought in japan).
I have found a CHDK for my camera of the firmware 100b, but my firmware is 100a. There is no upgrade option of this firmware. But I need CHDK.
What can I do now??


Re: IXUS 132 / ELPH 115 IS Porting Thread
« Reply #78 on: 22 / June / 2014, 08:51:16 »
my camera is ixus 132 (actually ixy90f bought in japan).
I have found a CHDK for my camera of the firmware 100b, but my firmware is 100a. There is no upgrade option of this firmware. But I need CHDK.
What can I do now??
Canon seldom allows you to upgrade when they produce a new rev of their firmware unless it is to fix a major bug.  This wiki page tried to track available upgrades : http://chdk.wikia.com/wiki/Official_Canon_firmware_updates

However, it's not all bad news.  Sometimes two firmware versions can use the same CHDK port - but almost always only if they have sequential revision numbers (like yours).   And if not, it's pretty easy these days for someone to produce a new port once the first one for a camera model is finished.

What is needed is a firmware dump.  Either to check and see if the versions are compatible or to be used in producing a new port.  If you feel up to taking the first step, here's the instructions : http://chdk.wikia.com/wiki/Canon_Basic/Scripts/Dumper

Also, here's a little background about the project :
link> CHDK FAQ : My camera isn't ported yet

Or you could just try installing the 1.00B version without any tests - as always with CHDK, there is some small risk in doing that but if it loads the other CHDK version then it's probably okay.
Ported :   A1200    SD940   G10    Powershot N    G16

Re: IXUS 132 / ELPH 115 IS Porting Thread
« Reply #79 on: 22 / June / 2014, 08:56:24 »
yeah, i have just installed in my camera. it is working smoothly till now.  :D   if something goes wrong, I will try these. thanks

 

Related Topics