stick not working properly

  • 12 Replies
  • 3196 Views
stick not working properly
« on: 02 / August / 2013, 16:46:43 »
Advertisements
When trying to install the new CHDK I found that stick will no longer let me drag and drop an image, I must now browse for one then it will work. I think that it is a java update problem. Can't give you any details but since the latest Java 7 update the problems have started. Stick worked flawlessly before that. There were problems with the initial release of Java 7 and since has been fixed but problems with stick persist. In looking around I found that wicks is doing the same thing. Here is the error message that appears in stick and wicks "Experimentelles CHDK_DE table failed to load" but the drag and drop image here feature still works and the program will load the build that you choose via the browse button. I haven't changed anything but Java update. Anyone else experiencing the same problem?
Thanks
I did get the new release loaded via acid and wicks. Great programs, stick is just more efficient for the dummy.

*

Offline msl

  • *****
  • 1239
  • A720 IS, SX220 HS 1.01a
    • CHDK inside
Re: stick not working properly
« Reply #1 on: 02 / August / 2013, 17:19:15 »
Please a little bit patience. We have changed some links for the German autobuild. That was necessary to manage future version changes better.

Zeno got the new links via email. I think he will update the programs. Sorry for the circumstances.

msl
German CHDK pages:  CHDK forum | CHDK inside | CHDK Twitter News by msl | Download CHDK-DE (Autobuild)
Note: SDM violates the GPL rules!

Re: stick not working properly
« Reply #2 on: 02 / August / 2013, 18:44:34 »
When trying to install the new CHDK I found that stick will no longer let me drag and drop an image, I must now browse for one then it will work.
...
Here is the error message that appears in stick and wicks "Experimentelles CHDK_DE table failed to load" but the drag and drop image here feature still works and the program will load the build that you choose via the browse button.
These problems surfaced on the CHDK facebook page yesterday and to be clear, there seems to be two issues here. 

The first is the recent change in CHDK to v 1.2.0 and the CHDK-DE update causing the "table failed to load" error.   msl stated that is being worked on.

However,  the drag&drop not working in STICK appears to be a different problem.  D&D works with WICKS but not STICK.   I'll ping zeno.
Ported :   A1200    SD940   G10    Powershot N    G16

Re: stick not working properly
« Reply #3 on: 02 / August / 2013, 18:59:59 »
Thanks to both of you for your prompt response. Like I said in my previous post, I already have it loaded on three cameras so not a problem for me. I just remember the first time I tried to load CHDK and how frustrated I got trying to figure out camera version CHDK verson and then how to get it on my camera. Along came stick and saved the day and a lot of hair. A BIG thanks to all of you for your hard diligent work.


*

Offline zeno

  • *****
  • 884
Re: stick not working properly
« Reply #4 on: 03 / August / 2013, 03:56:39 »
The German CHDK site have just changed the names of the directories, so I've had to update ACID and STICK. Instead of downloading the updated version of STICK and re-installing, you can fix the problem by editing the stick.properties file (with Notepad) and adding the lines:
   chdepages = release_full.txt
   chdepaget = trunk_full.txt

Not sure about the drag-and-drop problem - I know that the 'elevation' mechanism needed to run STICK under Windows 7 and 8 makes drag-and-drop fail (it's a Windows bug not a STICK bug), but it should affect WICKS as well.

4th August - trailing semicolons  and double-quotes removed
« Last Edit: 04 / August / 2013, 04:37:51 by zeno »
A570, S100, Ixus 127
Author of ASSIST, STICK, WASP, ACID, SDMInst, LICKS, WICKS, MacBoot, UBDB, CFGEdit

Re: stick not working properly
« Reply #5 on: 03 / August / 2013, 20:22:21 »
Followed instructions and doesn't seem to make any difference. I still get the message German Experimentelles CHDK_DE table failed to load" and when I browse for file and select photo it works normally. Like I said before about the drag and drop, it was working fine until I upgraded from Java 6 to Java 7. Bottom line for me is I can make it function just fine as long as I don't try to drag and drop. I just feel sorry for Valarie Lindsay on the Facebook page.

Thanks for all your hard work.

*

Offline zeno

  • *****
  • 884
Re: stick not working properly
« Reply #6 on: 04 / August / 2013, 04:13:52 »
Oops. I quickly copied a couple of lines from Stick.java and forgot to remove the trailing semi-colons and double-quotes. When added to a URL they stop it working.

I should have written:
   chdepages = release_full.txt
   chdepaget = trunk_full.txt
« Last Edit: 04 / August / 2013, 04:37:11 by zeno »
A570, S100, Ixus 127
Author of ASSIST, STICK, WASP, ACID, SDMInst, LICKS, WICKS, MacBoot, UBDB, CFGEdit

Re: stick not working properly
« Reply #7 on: 04 / August / 2013, 10:15:58 »
Oops. I quickly copied a couple of lines from Stick.java and forgot to remove the trailing semi-colons and double-quotes. When added to a URL they stop it working.

I should have written:
   chdepages = release_full.txt
   chdepaget = trunk_full.txt
Is the updated version available from your download page ?

TIA
Ported :   A1200    SD940   G10    Powershot N    G16


*

Offline zeno

  • *****
  • 884
Re: stick not working properly
« Reply #8 on: 04 / August / 2013, 17:40:33 »
Both STICK and ACID were updated on my webpage with versions that know the new URLs for the CHDK-DE builds as soon as I was told about the change. I guess I should have updated the webpages to say that.
A570, S100, Ixus 127
Author of ASSIST, STICK, WASP, ACID, SDMInst, LICKS, WICKS, MacBoot, UBDB, CFGEdit

Re: stick not working properly
« Reply #9 on: 05 / August / 2013, 12:50:37 »
 :-) Good news, everything is back to functioning normally, including drag and drop. Good job.

 

Related Topics