A2500 porting thread - page 4 - DryOS Development - CHDK Forum supplierdeeply

A2500 porting thread

  • 154 Replies
  • 46761 Views
Re: A2500 porting thread
« Reply #30 on: 30 / October / 2013, 11:02:16 »
Advertisements
Reporting in.
Loading from bootable card works fine. MF, quality override and Zebra works too. The only problem that I have experienced -- shooting in RAW. I've tried changing prefix, directory and extension settings but the camera saves only JPG.

Re: A2500 porting thread
« Reply #31 on: 02 / November / 2013, 08:57:08 »
Hello, new forum user here. I finally had to give up my trusted SD780 after the motor gave out. Loved using CHDK on it. Seeing the frequent activity on this thread a month or two ago I went with an A2500. The thread has quieted down so I'm not sure how the progress is going, but it seems like it was getting close. I'd like to test CHDK on my A2500, especially to test out the remote shutter. Can someone please provide me with a link to the latest build so I can give it a run. Thanks.

Re: A2500 porting thread
« Reply #32 on: 02 / November / 2013, 09:25:41 »
Hello,

I've just got my new A2550 today, and I should be glad to test CHDK if possible. I'm particularly interested in intervallometer, because I'll used it under a rokkaku kite.

How may I proceed ?

Seb.

PS : sorry for my english...

System :
Dual boot Ubuntu 12.04 i386 / Debian 7.2 i386, 4Go RAM, 500Go HDD, Nvidia 430GT

Re: A2500 porting thread
« Reply #33 on: 02 / November / 2013, 11:21:09 »
Can someone please provide me with a link to the latest build so I can give it a run. Thanks.
I've just got my new A2550 today, and I should be glad to test CHDK if possible.
If you sent nafraf a PM with a real email address and agree to report your testing results,  he will probably send you his latest build.  He's pretty good about doing that.  Link >  click here

Quote
I'm particularly interested in intervallometer, because I'll used it under a rokkaku kite.
You might then be interested in this : KAP & UAV Exposure Control Script
« Last Edit: 02 / November / 2013, 11:28:39 by waterwingz »
Ported :   A1200    SD940   G10    Powershot N    G16


Re: A2500 porting thread
« Reply #34 on: 02 / November / 2013, 12:03:50 »
great thanks.
Yes a high speed is needed because the kite move a lot !

*

Offline srsa_4c

  • ******
  • 4426
Re: A2500 porting thread
« Reply #35 on: 02 / November / 2013, 12:11:14 »
I've just got my new A2550 today
While it is likely that the A2550 is an A2500 with a different look, it would be better if you could dump its firmware to have a proof. http://chdk.wikia.com/wiki/Canon_Basic/Scripts/Dumper

@changer
Please check your cam's firmware version with this tool: http://www.zenoshrdlu.com/acid/acid.html. If it's not 100a, please make a dump.

Re: A2500 porting thread
« Reply #36 on: 02 / November / 2013, 21:25:30 »
@changer
Please check your cam's firmware version with this tool: http://www.zenoshrdlu.com/acid/acid.html. If it's not 100a, please make a dump.

My A2500 is indeed firmware 100a.

Re: A2500 porting thread
« Reply #37 on: 03 / November / 2013, 07:53:17 »

3. CHDK only boots up when I format the card in my computer and set it up and put in the camera. After a shutdown, CHDK doesn't load and the green LED flashes when clicking the playback button (same problem that existed before the last svn update).


Started testing today and getting a problem similar to this. Maybe a little weirder though, since I'm unclear on if the commenter above's camera would still turn on and just not load CHDK, or not turn on at all.

For me, CHDK runs fine and I can go through all the menus and take photos on the first boot. After shutting down, the camera usually won't boot back up at all. (For some reason it did one time, I think because I turned it off then back on very quickly after initial boot). Holding the power button or tapping the playback button sometimes gets a little chime and green LED to flash. One time through randomly tapping the buttons I got the screen to turn on, although it stayed blank (black) and showed nothing. So at this point every time I want to load CHDK I need to remove the card, delete contents with PC, then load back on original CHDK.

The only other thing I tried was saving RAW which didn't work. I didn't try playing with any settings because of the crashes mentioned above.


*

Offline srsa_4c

  • ******
  • 4426
Re: A2500 porting thread
« Reply #38 on: 03 / November / 2013, 08:42:14 »
For me, CHDK runs fine and I can go through all the menus and take photos on the first boot. After shutting down, the camera usually won't boot back up at all.
You could try the following:
- only erase one or more of the CHDK config files in the CHDK folder (*.cfg), and see which one is causing problems
- After the camera crashed, boot up CHDK again (with whatever method you need to use), and
please post the ROMLOG. "miscellaneous stuff->Debug Parameters->Save ROM crash log".

Re: A2500 porting thread
« Reply #39 on: 03 / November / 2013, 16:01:46 »
Using the newest version, I figured out the culprit for my boot problems. As mentioned previously, after first run the camera won't boot again. However, if I load the card on my PC and delete the folder (which is empty) CHDK/MODULES/CFG then reinsert the card, camera and CHDK boot fine. Of course, after I restart once the folder is recreated and I need to use my PC to delete it again.

I also tried to get the ROMLOG:

Code: [Select]
Exception!! Vector 0x04
Occured Time  2013:11:03 19:27:17
Task ID: 13303836
Task name: SpyTask
Exc Registers:
0xA0000013
0x0326EA40
0x002ED550
0x00001954
0x0000006D
0x001797B4
0x001797B4
0x00000001
0x19980218
0x19980218
0x19980218
0x19980218
0x002EE174
0x003049BC
0xFF896D20
0x0000037C
0x00000092
StackDump:
0x0017D9B8
0xFF896D20
0x0017D9B8
0x0015B1D0
0x0015DDED
0x19980218
0x19980218
0x19980218
0x19980218
0x19980218
0x002EDE2C
0x19980218
0x19980218
0x19980218
0x003F3418
0x19980218
0x19980218
0x00002008


 

Related Topics