A2500 porting thread - page 5 - DryOS Development - CHDK Forum supplierdeeply

A2500 porting thread

  • 154 Replies
  • 46762 Views
Re: A2500 porting thread
« Reply #40 on: 04 / November / 2013, 06:26:56 »
Advertisements
Reporting in  ;)

Very first time I am using CHDK, all went quite smoothly, I have been playing with it this morning and I am lovin' it

I have an issue with various intervalometer scripts, they all seem to go twice as fast as expected, i.e. if I ask for 10 seconds interval shots, I obtain 5 seconds one. If I ask for 5 seconds, I obtain about 3 seconds.

Not sure if this is coming from scripts themselves or from A2500 CHDK release.

Also,CHDK splash screen says 6 days left. Will I be an orphan in 6 days ?

Thank you.

Re: A2500 porting thread
« Reply #41 on: 04 / November / 2013, 09:20:53 »
I have an issue with various intervalometer scripts, they all seem to go twice as fast as expected, i.e. if I ask for 10 seconds interval shots, I obtain 5 seconds one. If I ask for 5 seconds, I obtain about 3 seconds. Not sure if this is coming from scripts themselves or from A2500 CHDK release.
That would be a somewhat unusual bug in the A2500 port.  Although some scripts interpret that parameter as the time between the completion of a shot and the start of the next while others interpret it to mean the time between the start of subsequent shots.

Quote
Also,CHDK splash screen says 6 days left. Will I be an orphan in 6 days ?
No - its just a warning inserted to remind people using early test versions to upgrade to a released version when it becomes available.
« Last Edit: 04 / November / 2013, 09:22:52 by waterwingz »
Ported :   A1200    SD940   G10    Powershot N    G16

Re: A2500 porting thread
« Reply #42 on: 04 / November / 2013, 09:26:07 »
Thank you !

Re: A2500 porting thread
« Reply #43 on: 05 / November / 2013, 06:14:29 »
Reporting in:

Override Tv works;
Override Aperture is not on the menu (maybe is not possible with this camera?);
Manual Focus works;
Manual Flash+Power works;
Overrides Jpeg quality seems work;

Raw saving not work as already reported;

zebra work;

Testing with scripts:

llibtst.lua ok;
setmode.lua failed in 2 transitions see attached log;
ubtest.bas ok;
motion detection works;

If i set intervalometer to 20 it takes a first shot, then wait about 5 secs and takes the second shot, then wait about 15 secs and takes the third shot, then wait 5 shot, wait 15 shot, wait 5 shot and so on...
if i set it to 30 secs, the timings are about 5 and 25
if i set it to 10 secs, the timings are about 5 and 5 as reported by philgib.

Sometimes when "booting/switching from camera mode to play mode/taking photo"  CHDK hangs up. i noticed that this situation persists for some reboots (waiting a few second i can reboot the camera with power button but when taking photo or switching to play mode it still hangs up ). i don't konw the cause, but after "some" reboots the chdk works correctly and i don't need to load back the original CHDK as changer.

I think it's not very important but i also noticed that if i select the option "CHDK Settings/Startup sound" at the next reboot CHDK will not start, and i've to replace CHDK folder with the "factory one" to get it started.


Re: A2500 porting thread
« Reply #44 on: 05 / November / 2013, 06:47:46 »
I'll add on that even though I need to reload CHDK after every camera shut down, remote shutter does work fine. 3 volts wasn't enough, but 4.5 is no problem.

Re: A2500 porting thread
« Reply #45 on: 05 / November / 2013, 22:55:05 »
Just tried the newest version. Now the camera won't load at all. On first try it gets stuck on the Canon splash screen and never gets beyond that. Power off button does not work, but it shuts down by itself after about 5-10 seconds. Upon trying to start up again it's the same problem as mentioned previously (chime and green LED flash, but nothing on screen).

Re: A2500 porting thread
« Reply #46 on: 19 / November / 2013, 07:21:58 »
Just tried the newest version.

Willing to give it a try. Is there a link to this version please, and does it save Raws now ?

Thank you

*

Offline nafraf

  • *****
  • 1308
Re: A2500 porting thread
« Reply #47 on: 19 / November / 2013, 07:50:59 »
Willing to give it a try. Is there a link to this version please, and does it save Raws now ?
I have not worked on this port recently, but I sent you the latest version via PM.


Re: A2500 porting thread
« Reply #48 on: 28 / November / 2013, 07:54:12 »
Reporting in with the latest version dd 27/11/2013

- Zero crashes for the moment
- Improvement : if I choose Raw => Save Raw, I , the double-shot problem and intervalometer time divided by 2 problems disappear

Question :
I have choose "Save Raw with Jpg". I was expecting everything to be in the same directory. No, it creates a new TMP dir for each new Raw file  :haha Funny.

I will try to force aperture, etc... and will revert

Re: A2500 porting thread
« Reply #49 on: 28 / November / 2013, 09:42:24 »
Hi everyone. It's good to see that the A2500 port is going on.
Exploring some WPD driver issues I would like to hook up my new A2500 with an actual CHDK port to be able to do some testing.
Any hints or links where to find actual builds?

best PeterT

 

Related Topics