no get_usb_power on A700? - General Help and Assistance on using CHDK stable releases - CHDK Forum  

no get_usb_power on A700?

  • 8 Replies
  • 3192 Views
*

Offline fbonomi

  • ****
  • 469
  • A570IS SD1100/Ixus80
    • Francesco Bonomi
no get_usb_power on A700?
« on: 26 / March / 2008, 03:35:28 »
Advertisements
Just to be sure: can someone confirm that the A700 does not support the get_usb_power command?


Re: no get_usb_power on A700?
« Reply #1 on: 26 / March / 2008, 14:15:12 »
Yes,
it is not implemented yet!
If you have A700 and can test the cam according to procedure on
Works USB  Remote button in A570 Is ?  n/t
then we can try to implement for A700.

*

Offline fbonomi

  • ****
  • 469
  • A570IS SD1100/Ixus80
    • Francesco Bonomi
Re: no get_usb_power on A700?
« Reply #2 on: 27 / March / 2008, 08:38:32 »
Hi fingalo, thanks for your reply.
I don't have an A700, I was just trying to understand if it's the correct camera to buy to play with chdk.

Anyway, I have asked someone who has, and they tried to see if it powers up when connected to the usb.

It does not power up, so I think that get_usb_power command cannot be implemented on the A700.

Am I wrong?


*

Offline PhyrePhoX

  • *****
  • 2254
  • make RAW not WAR
    • PhyreWorX
Re: no get_usb_power on A700?
« Reply #3 on: 27 / March / 2008, 09:18:24 »
you are wrong :)
many cams dont power up when USB connected, but they do sport the get_usb_power command.


*

Offline ewavr

  • ****
  • 1057
  • A710IS
Re: no get_usb_power on A700?
« Reply #4 on: 27 / March / 2008, 09:21:16 »
It seems that cameras with remote capture support can power-up for USB, others - no.

*

Offline PhyrePhoX

  • *****
  • 2254
  • make RAW not WAR
    • PhyreWorX
Re: no get_usb_power on A700?
« Reply #5 on: 27 / March / 2008, 09:33:07 »
my cam (a620) supports remotecapture (via canon software) but it doesnt power-up via usb. maybe it has something to do with architecture/hardware of cam regarding playback/record switch. on my a620 it can be either set to playback or record, on s3is for example it is a "soft switch" that has no "exact position".

*

Offline fbonomi

  • ****
  • 469
  • A570IS SD1100/Ixus80
    • Francesco Bonomi
Re: no get_usb_power on A700?
« Reply #6 on: 28 / March / 2008, 18:09:26 »
PhyrePhoX, I think canon sdk accesses the camera through "proper" USB functions, that's why it will work even on cameras that don't have the "sense 5v" feature.

Of course, the get_usb_power is more primitive and needs some help more from the camera hardware :-)

Re: no get_usb_power on A700?
« Reply #7 on: 14 / May / 2008, 03:32:47 »
Hi Fingalo,

I have tested my A700 in accordance with your previous recommendations and I have obtained the following values:-

On my a700 the remote control is not working yet.

Camera : Canon a700 1.0.1.0
CHDK :   allbest-a700-100b-50

Following values for VIEW mode

NO USB connected but before lens retracts: rapid changing of the first figure
1/ 8cc90080 <> 8cc94080
2/ fcdc09a0
3/ 9fff
4/ 0

NO USB connected but after lens retracts:
1/ 8c4f0080
2/ fcdc09a0
3/ 9fff
4/ 0

USB connected: behaviour of 1/ and 2/ is changed, 3/ and 4/ unchanged
1/ 8c4f0088
2/ fcdc09a2
3/ 9fff
4/ 0

Hoping that you may be able to assist in get USB remote working.

regards


Re: no get_usb_power on A700?
« Reply #8 on: 08 / February / 2014, 12:33:24 »
If you are the owner of an A700 we need your help improving the manual focus / subject distance override capability of CHDK.

Please read the instructions posted here < Link to Testing Instructions > and test your camera.

TIA.
Ported :   A1200    SD940   G10    Powershot N    G16

 

Related Topics