Bracketing and EV correction script (one more) - page 3 - Script Writing - CHDK Forum supplierdeeply

Bracketing and EV correction script (one more)

  • 36 Replies
  • 17961 Views
Re: Bracketing and EV correction script (one more)
« Reply #20 on: 12 / June / 2008, 20:59:12 »
Advertisements
vk2him isn't the one, it's me with the problem. I tried increasing the script time to 60 but it didn't change the timing at all for the script. However, adding the 'sleep 3000' worked perfect. One question though... why is the formula '2*a+1' used vice '3*a'? I realize it's not going to save any time, I'm just curious.

Thanks for all the help!

Re: Bracketing and EV correction script (one more)
« Reply #21 on: 14 / June / 2008, 11:26:14 »
I have a 620 w CHDK installed. Great item and thanks to all involved with development etc.. I loaded this
script in my CHDK scripts folder, went to load it, it shows as Simple Bracketing.bas but to the right of
the name it shows 4 question marks and will not load. I wondered if someone can help me figure this out?
 Thanks carp

*

Offline Cola

  • *
  • 4
  • SD630 with CHDK 0.9.7-719
Re: Bracketing and EV correction script (one more)
« Reply #22 on: 26 / June / 2008, 00:44:57 »
I'm currently using this script but have a question about the last parameter, EV Correction in 1/3.

What exactly is this suppose to do or what is it used for?

Re: Bracketing and EV correction script (one more)
« Reply #23 on: 14 / October / 2008, 16:57:43 »
can anyone help me? i use SD1100 IS and already edited the script to suit DIGIC III

every time i ran the script in my camera and start the script by pressing SET it will snap the first pic
and froze until i stop the script by pressing the shutter button.

Help?


Re: Bracketing and EV correction script (one more)
« Reply #24 on: 28 / March / 2009, 11:48:54 »
I have the same problem as b29pb, using a SD1100IS...
Have also edited the script for DigicIII...
I really want to mess with HDR imagery.
Please help.
Thanks in Advance

Jono

Re: Bracketing and EV correction script (one more)
« Reply #25 on: 23 / April / 2009, 23:50:52 »
I have a SD880 IS Digic IV and seem to having some difficulty running the script properly. When running the bracketing script it will take the first picture but then just stops with the last picture being displayed on the screen.  I was hoping it would take 3 consecutive pictures at 0 -2 +2 and when reviewing the pictures to see the exposure difference info in the display.  Any help much appreciated.

Under bracketing settings I have:
Number Images -1)2   1..1 [   3]  (I'm guessing this means three consecutive pictures)
Step Size (1/3 EV)       1..1 [   2]  (I'm guessing this means a difference of -2 0 +2 exposure setting)
Correction (1/3 EV)   -12..1 [   0]  (I'm clueless what this does)

Any help much appreciated.

*

Offline an0n

  • ***
  • 152
Re: Bracketing and EV correction script (one more)
« Reply #26 on: 24 / April / 2009, 00:04:29 »
I'm not sure about this, it's probably simple but can you tell me why you are using a script rather than bracketing in continuous
mode (in extra photo operations). 
A720IS.

Re: Bracketing and EV correction script (one more)
« Reply #27 on: 24 / April / 2009, 00:46:03 »
I find the script with with my previous SD870 took clearer pictures free handed without the use of a tripod.  By pressing the button in bracketing in continuous mode it seems slightly more blurry.  It just helps when I don't have a tripod with me at the time.


Re: Bracketing and EV correction script (one more)
« Reply #28 on: 24 / April / 2009, 01:57:46 »
you don't need to use continuous; you can use the custom timer and set it for several shots; the continuous bracketing settings apply to these as well.

Re: Bracketing and EV correction script (one more)
« Reply #29 on: 24 / April / 2009, 03:00:08 »
Yes but this requires more setup time.  Even in continuous mode you must guess when to release the shutter button as the camera takes a fairly rapid 1.4fps (SD880) letting ago exactly after 3 shots is difficult sometimes its 4 shots and sometimes just 2 shots.  The script obviously would do it correct every time if I can get it working.

In any event if anyone can offer some info on how to fix the bracketing script for the (SD880) that would be helpful.  I've posted the script below as reference.

Cheers and thanks for the info.

@title Bracketing
@param a (Number images-1)/2   1..12
@default a 3
@param b Step size  (1/3 EV)   1..12
@default b 2
@param c Correction (1/3 EV) -12..12
@default c 0

get_prop 25 w
get_prop 26 x

let y=1

do
  let z=0

  do
    if a<1   then let a=1
    if a>12  then let a=12
    if b<1   then let b=1
    if b>12  then let b=12
    if c<-12 then let c=-12
    if c>12  then let c=12
    if y<1 then y=3
    if y>3 then y=1

    print ""
    if y=1 then print "Num : <" 2*a+1 ">"     else print "Num :  " 2*a+1
    if y=2 then print "Step: <" b/3,b%3 "/3>" else print "Step:  " b/3,b%3 "/3"
    if y=3 then print "Corr: <" c/3,c%3 "/3>" else print "Corr:  " c/3,c%3 "/3"
    print "[Set]=shoot [Disp]=exit"

    wait_click
    if is_key "up"   then let y=y-1
    if is_key "down" then let y=y+1
    if y=1 and is_key "left"  then let a=a-1
    if y=2 and is_key "left"  then let b=b-1
    if y=3 and is_key "left"  then let c=c-1
    if y=1 and is_key "right" then let a=a+1
    if y=2 and is_key "right" then let b=b+1
    if y=3 and is_key "right" then let c=c+1
    if is_key "set"     then z=1
    if is_key "display" then z=2
  until z>0
  if z=2 then goto "exit1"

  let d=c*32-a*b*32

  for s=1 to 2*a+1
    set_prop 25 d
    set_prop 26 d
    print "Shoot at",d/96,(d/32)%3 "/3"
    do
      get_prop 205 p
    until p=0
    press "shoot_full"
    do
      get_prop 205 p
    until p=1
    release "shoot_full"
    let d=d+b*32
  next s
 
  :exit1
until z=2

set_prop 25 w
set_prop 26 x

end

 

Related Topics