I would have been happy with any of the various patches proposed so far. But I think the general CHDK philosophy is for scripts functions to provide the cleanest basic functionality necessary for the script coder to use in building up his script (rather than highly specialized functions with long names).
I agree with that, and would add that it's best to keep things consistent with the existing functions. That's why I originally wrote it as:
set_chdk_osd( 0 | 1 | -1 )
like:
set_backlight( 0 | 1 )
Adding a "get" function doesn't provide any new capability, and is inconsistent with set_backlight. But as long as it doesn't take away any capability, I can live with it.
But I'll have to say, I don't really have this much time to spend trying to get every simple function into the trunk. I'd like to share some of the new capabilities I've added to my version of CHDK, but I just don't think it's going to be possible unless I can make the final decision about how it's done, after listening to all the suggestions. My final decision in this case would still be my original function, with a new name, and fixes for the textbox, file browser, and touch screen issues.
Hiding the console, <alt> line, and osd separately is something that can be done in the future if there is a request for it. I don't need that capability, but if anyone ever does, it could be added as an extra parameter to set_chdk_osd. Or, since the chdk osd is one of the options, perhaps we should change the name to:
set_chdk_display(-1|0|1 [, type])
type= default 0 all, 1 <alt> line, 2 console, 3 osd, 4 touchscreen buttons, >4 future)
Please don't accuse me of just repeating "do it my way". I'd be happy to do it anybody's way if it at least adds the capability I need. But I don't have the time to add code for cosmetic reasons, i.e. that doesn't provide new capabilities, and even restricts current and new capabilities. Even if it might be a little better to some people, we just don't have the programming resources to do it.
Writing a program is necessarily an obsessive thing to do, You have to stick with it until it works. But there's a name for obsessive perfectionism: Paralysis. Here's an interesting article on the subject:
http://www.lifehack.org/articles/productivity/why-being-a-perfectionist-may-not-be-so-perfect.htmlset_alt_line( 0 | false | 1 | true)
get_alt_line()
This way, you could hide everything, or just hide the <alt> line. It would work the same way as set_chdk_osd().
I guess that's as good as it gets. When you say it works the same way as set_chdk_osd() I assume you mean it just enables / disables display of the <ALT> and script name ? Other OSD icons and the console need to be managed seperately?
Yes, that's what I meant. With the current get/set paradigm, we need 2 new functions for every new thing we want to show or hide.
=====
@outslider, I just saw your post while I was typing. How do you like the idea to do it the way I described above?
set_chdk_display(-1|0|1 [, type])