supplierdeeply

Manual Focus not working on IXUS 115HS / ELPH 100

  • 4 Replies
  • 2011 Views
Manual Focus not working on IXUS 115HS / ELPH 100
« on: 03 / October / 2013, 01:09:54 »
Advertisements
Hello everyone,

I've been using CHDK on my Ixus 115HS (firmware 1.01c) since the first alpha release. The manual focus worked fine till now for all the subsequent releases. Recently, I repaired my camera as the lens assembly got broken.

After repairing the manual focus has stopped working.

On the latest beta releases, it just doesn't work at all. No response, nothing.
So I tried the older Alpha-9 release. Here's what happens with alpha-9 release. The manual focus works as long as the camera is not moving i.e. when autofocus is not working. As soon as I try using manual focus while camera is moving, camera "freezes". In manual focus mode, i.e. after change in SD valua, autofocus should turn off. I think here in manual focus mode, the autofocus is failing to halt and it is interfering with the manual focus.

Please provide me a solution for the problem.
Ixus 115 HS / firmware 1.01c

*

Offline reyalp

  • ******
  • 11487
Re: Manual Focus not working on IXUS 115HS / ELPH 100
« Reply #1 on: 03 / October / 2013, 22:56:13 »
After repairing the manual focus has stopped working.
If physically repairing your camera caused manual focus to stop working then it's almost certainly a hardware issue or perhaps a camera setting change, not anything to do with CHDK.

By "manual focus" you mean CHDK subject distance override?

Quote
The manual focus works as long as the camera is not moving i.e. when autofocus is not working. As soon as I try using manual focus while camera is moving, camera "freezes".
Do you have continuous AF enabled ? Newer CHDK builds disable SD override in this mode, because it causes problems.
Don't forget what the H stands for.

Re: Manual Focus not working on IXUS 115HS / ELPH 100
« Reply #2 on: 28 / October / 2013, 02:47:32 »
Servo AF is Enabled and IS mode is Continuous.
Quote from: reyalp
Servo AF is Enabled and IS mode is Continuous.
I would suggest turning Servo AF off. If you want to manually control the focus distance, then you don't want servo AF.

Edit: Mods, please post your replies as reply, so that other can read the actual problems. (I knw, it was by mistake. Otherwise reyalp, you've been very helpful throughout!)
« Last Edit: 31 / October / 2013, 10:29:27 by sarkar »
Ixus 115 HS / firmware 1.01c

*

Offline srsa_4c

  • ******
  • 3686
Re: Manual Focus not working on IXUS 115HS / ELPH 100
« Reply #3 on: 29 / October / 2013, 12:13:32 »
In addition to reyalp's advice, be sure to activate AF lock. On this camera, CHDK SD override can only function when AF lock is active. (If you don't know what AF lock is, you can find it in the camera's manual - the button combination that activates it is usually "half shutter" + "left").


Re: Manual Focus not working on IXUS 115HS / ELPH 100
« Reply #4 on: 31 / October / 2013, 10:34:28 »
srsa_4c and reyalp,

You people are awesome!!

Both of your's suggestions are must to successfully use SD override!
Using only one of those does not work.
I've to turn off the servo AF and then enable AF Lock, and then miracle! SD override is working!

Thanks a ton!

sarkar

« Last Edit: 31 / October / 2013, 10:36:06 by sarkar »
Ixus 115 HS / firmware 1.01c

 

Related Topics