supplierdeeply

video record A3400

  • 5 Replies
  • 1143 Views
*

Offline timgor

  • ***
  • 150
video record A3400
« on: 14 / October / 2013, 16:44:41 »
Advertisements
I got a problem with video recording.
The normal start-stop video would be
Code: [Select]
click("video")
sleep(...)
click("video")


on some reason the first click may not start video and I need to do
Code: [Select]
repeat click("video") sleep(1000)until get_video_status == started...
sleep(...)
click("video")
[/code]


what can be the problem?
what is the difference between click("video") and press("video")?


*

Offline msl

  • *****
  • 1239
  • A720 IS, SX220 HS 1.01a
    • CHDK inside
Re: video record A3400
« Reply #1 on: 14 / October / 2013, 17:23:01 »
'press' needs a 'release'. 'click' is the combination of 'press' + 'release'.

You can try for start recording this:
Code: [Select]
press("video")
sleep(500) -- play with the sleep time
release("video")
msl
German CHDK pages:  CHDK forum | CHDK inside | CHDK Twitter News by msl | Download CHDK-DE (Autobuild)
Note: SDM violates the GPL rules!

Re: video record A3400
« Reply #2 on: 14 / October / 2013, 17:55:52 »
on some reason the first click may not start video and I need to do
Code: [Select]
repeat click("video") sleep(1000)until get_video_status == started...
sleep(...)
click("video")
what can be the problem?
what is the difference between click("video") and press("video")?
The problem is that the "click"  presses and releases the specified button very quickly.  On some camera there are functions that require the button to be pressed for slightly longer than the "click" function presses.  In those cases, you need to use a press and release with a delay between the two statements.
Ported :   A1200    SD940   G10    Powershot N    G16

*

Offline timgor

  • ***
  • 150
Re: video record A3400
« Reply #3 on: 14 / October / 2013, 18:01:19 »
Thanks for reply. Will try it. But it reminds me a joke about too slow electricity.


*

Offline philmoz

  • *****
  • 3070
    • Photos
Re: video record A3400
« Reply #4 on: 14 / October / 2013, 18:17:59 »
on some reason the first click may not start video and I need to do
Code: [Select]
repeat click("video") sleep(1000)until get_video_status == started...
sleep(...)
click("video")
what can be the problem?
what is the difference between click("video") and press("video")?
The problem is that the "click"  presses and releases the specified button very quickly.  On some camera there are functions that require the button to be pressed for slightly longer than the "click" function presses.  In those cases, you need to use a press and release with a delay between the two statements.

Or increase the value of CAM_KEY_PRESS_DELAY in platform_camera.h.

Default is 30ms, G1X & SX40 (amongst others) requires this be increased to 60ms.

Phil.
CHDK ports:
  sx30is (1.00c, 1.00h, 1.00l, 1.00n & 1.00p)
  g12 (1.00c, 1.00e, 1.00f & 1.00g)
  sx130is (1.01d & 1.01f)
  ixus310hs (1.00a & 1.01a)
  sx40hs (1.00d, 1.00g & 1.00i)
  g1x (1.00e, 1.00f & 1.00g)

Re: video record A3400
« Reply #5 on: 14 / October / 2013, 18:25:27 »
Or increase the value of CAM_KEY_PRESS_DELAY in platform_camera.h.  Default is 30ms, G1X & SX40 (amongst others) requires this be increased to 60ms.
For clarity,  this requires rebuilding the CHDK source code for the change to take effect.  This is not something an "end user" can do with the CHDK distribution file.
Ported :   A1200    SD940   G10    Powershot N    G16

 

Related Topics