KAP & UAV Exposure Control Intervalometer Script - page 68 - Completed and Working Scripts - CHDK Forum supplierdeeply

KAP & UAV Exposure Control Intervalometer Script

  • 1068 Replies
  • 340001 Views
Re: KAP & UAV Exposure Control Intervalometer Script
« Reply #670 on: 06 / December / 2015, 21:50:42 »
Advertisements
Thanks so much Waterwingz and Zeno for the prompt response! You were both right, I had loaded the wrong script from my camera menu and by scrolling down further I found the correct script titled "KAP_UAV.LUA" instead of the previously mentioned one. It works great now.

Btw, my school's space balloon team used your script to get some great shots of the curvature of the earth, so we appreciate you sharing it.
« Last Edit: 06 / December / 2015, 21:53:11 by OS401 »

Re: KAP & UAV Exposure Control Intervalometer Script
« Reply #671 on: 06 / December / 2015, 21:51:38 »
Ww...I updated to ver 3.6 and my previously functioning 330HS on ver 3.5 now will not save the pic... my Iris fires the script... it opens the lens and the red af beam lights... but no pic. I'm able to save a pic using the camera shutter release.
Iris = flight controller? 

It would be good to know your setup - can you post the KAP.log file from the root folder of your SD card?

Quote
I deleted my ver 3.5....would you have that version available for me to download so I can troubleshoot?
attached

Quote
Your code is a work of art IMHO.
link > work of art
« Last Edit: 06 / December / 2015, 22:05:42 by waterwingz »
Ported :   A1200    SD940   G10    Powershot N    G16

Re: KAP & UAV Exposure Control Intervalometer Script
« Reply #672 on: 06 / December / 2015, 23:14:22 »
Iris+ is a quad-copter uav from 3dr with a pixhawk controller. Attached the kap log.
Thanks for the 3.5 file.
Dave

Re: KAP & UAV Exposure Control Intervalometer Script
« Reply #673 on: 07 / December / 2015, 18:02:15 »
WW- Update...
I'm not getting any pic saved using KAP 3.5 either. Really scratching my head now.  attached the latest KAP log update as well.
I need to go back to school on this apparently.


Re: KAP & UAV Exposure Control Intervalometer Script
« Reply #674 on: 07 / December / 2015, 18:31:41 »
WW - UPDATE #2.
The attached KAP - wtf happened file shows that with a setting change to "on/Off" apparently I then got the script to take the pic each time the USB was turned on - I "triggered" using a power strip and a phone charge attached to the camera.
Still not understanding what I'm doing, apparently.

Insight?

tks
Dave

Re: KAP & UAV Exposure Control Intervalometer Script
« Reply #675 on: 07 / December / 2015, 19:24:39 »
I'm not getting any pic saved using KAP 3.5 either.
Okay - finally had a chance to look at the logs.  There is a bunch of older log information from this summer showing successful shooting with KAP 3.5 (as well as some really old 3.4 log info from last winter).  So it was working with your camera at one point.

What I see in the log files is the script timing out while waiting for the shooting hook.  The relevent code snippet is this :
Code: [Select]
                hook_shoot.set(10000)
                press('shoot_full')
                wait_timeout(hook_shoot.is_ready, true, 2000, 10, "timeout on hook_shoot.is_ready") 
This part is a bit complicated to explain so I'm hoping reyalp will chime in later.  What is supposed to happen in each line is :
  • the script sets a "hook" in the shooting process - something that interrupts the normal camera shooting process so that the script can do special things that would not normally be possible.
  • the script causes the shooting process to start by simulating a full press of the shutter button
  • the script waits for up to 2 seconds for the shot to reach the "hook" that it set in the first step

In the log I can see the timeout - the shot never gets to the hook and then no picture is taken.

So the question here is why does the press('shoot_full') not work? Or if it works, why does it not hit the hook?

I need to study this some more - nothing obvious comes to mind.  The log shows you are not using Canon continuous shooting mode - that was a possible issue.  I wonder if there is some other camera setup or mode that might be causing this?  After all, it did work a few month ago.  If the script didn't change and CHDK didn't change then it pretty much has to be something in the Canon setup that has changed.

Edit : are you trying to test this indoors?  Possibly in a relatively dark room? The luminance values recorded in the log files are all very dark. Is it possible that the camera is just refusing to shoot as it's not getting enough light?
 
« Last Edit: 07 / December / 2015, 19:30:39 by waterwingz »
Ported :   A1200    SD940   G10    Powershot N    G16

*

Offline reyalp

  • ******
  • 13621
Re: KAP & UAV Exposure Control Intervalometer Script
« Reply #676 on: 07 / December / 2015, 21:37:47 »
Quote
This part is a bit complicated to explain so I'm hoping reyalp will chime in later.
Haven't really digested the code, but I noticed this in the log before the hook timeouts
Quote
2015Dec07 16:10:13    Mode:PLAY,Continuous_AF:0,Servo_AF:0
Suggests the camera hasn't switched to rec, which might explain the timeout. I would expect the shoot_full press to make it switch though, as long as the camera doesn't think USB is connected.
Don't forget what the H stands for.

Re: KAP & UAV Exposure Control Intervalometer Script
« Reply #677 on: 07 / December / 2015, 21:41:38 »

Quote from: reyalp
Suggests the camera hasn't switched to rec, which might explain the timeout. I would expect the shoot_full press to make it switch though, as long as the camera doesn't think USB is connected.
The script explicitly switches to shooting mode only when it is ready to shoot if you start it in playback.  Which is something you generally want to do when launching a kite or UAV.   The log file indicates when that happens.
Ported :   A1200    SD940   G10    Powershot N    G16


*

Offline reyalp

  • ******
  • 13621
Re: KAP & UAV Exposure Control Intervalometer Script
« Reply #678 on: 07 / December / 2015, 22:20:21 »
The log file indicates when that happens.
I'm probably missing something, but I don't see any "Mode switched to...", although it looks like switch_mode(1) should be called, and should print that line if it thinks it needed to switch.

Code: [Select]
2015Dec07 16:11:00    KAP 3.5 started - press MENU to exit
2015Dec07 16:11:00    CHDK 1.3.0-4152 ixus255_elph330hs 100f Apr 15 2015
2015Dec07 16:11:00    Mode:PLAY,Continuous_AF:0,Servo_AF:0
2015Dec07 16:11:00     Tv:1/1000 max:1/2000 min:10 ecomp:0.0
2015Dec07 16:11:00     Av:4.0 minAv:2.8 maxAv:8.0
2015Dec07 16:11:00     ISOmin:100 ISO1:400 ISO2:800
2015Dec07 16:11:00     Focus:OFF  Video:0 USB:1 Tmo:0
2015Dec07 16:11:00     AvM:2 int:4 Shts:0 Dly:0 B/L:0
2015Dec07 16:11:06    timeout on hook_shoot.is_ready
Don't forget what the H stands for.

Re: KAP & UAV Exposure Control Intervalometer Script
« Reply #679 on: 07 / December / 2015, 22:33:01 »
I'm probably missing something, but I don't see any "Mode switched to...",
...
although it looks like switch_mode(1) should be called, and should print that line if it thinks it needed to switch.
The 3.6 version of the script does that but the 3.5 does not.  Just another little thing that got cleared up along the way.
Ported :   A1200    SD940   G10    Powershot N    G16

 

Related Topics