KAP & UAV Exposure Control Intervalometer Script - page 103 - Completed and Working Scripts - CHDK Forum  

KAP & UAV Exposure Control Intervalometer Script

  • 1058 Replies
  • 210020 Views
*

Offline srsa_4c

  • ******
  • 3907
Re: KAP & UAV Exposure Control Intervalometer Script
« Reply #1020 on: 10 / January / 2019, 13:54:17 »
Advertisements
@srsa_4c

Sorry, my bad.  Here is the correct one.
Well, as you can see, this script also reports failures. I'll try to compare the port's capt_seq.c to another cam's from the same era.

*

Offline srsa_4c

  • ******
  • 3907
Re: KAP & UAV Exposure Control Intervalometer Script
« Reply #1021 on: 10 / January / 2019, 18:35:55 »
@cagiva
I posted a test build in the porting thread. Please try and see whether it fixes the hooktest failures. Post your reply in that thread.

Re: KAP & UAV Exposure Control Intervalometer Script
« Reply #1022 on: 19 / January / 2019, 15:37:42 »
Hi @waterwingz,

I'm not able to trigger the camera when "USB Shot Control" is set to Pixhawk and "Shot Interval" is set to Fast.  It works when it's set to OneShot, but the time per shots seems to be slow (attached log -- sunny day outside).  Does the Pixhawk setting only work exclusively with the Tuffwing trigger cable?  I'm using the one from mobilexcopter instead, do you think that is a factor?

« Last Edit: 19 / January / 2019, 22:12:52 by cagiva »

Re: KAP & UAV Exposure Control Intervalometer Script
« Reply #1023 on: 19 / January / 2019, 18:45:01 »
I'm not able to trigger the camera when "USB Shot Control" set to Pixhawk and "Shot Interval" set to Fast.  It works when it's set to OneShot, but the time per shots seems to be slow (attached log -- sunny day outside).  Does the Pixhawk setting only works exclusively with the Tuffwing trigger cable?  I'm using the one from mobilexcopter instead, do you think that is a factor?
Setting "USB Shot Control" to OneShot will trigger a shot each time the USB +5V level toggles.  The "Shot Interval" setting is ignored.  Your mobilexcopter interface triggers shots in that mode so I think it's working just like the Tuffwing trigger cable interface. Your hardwarde choice is not an issue.

Are you actually using a Pixhawk controller?  In Pixhawk mode, the script is waiting for a pulse of a certain length to take a shot - if you are not using a Pixhawk you'll need to setup something to get the same pulse width.

It's been a while since I've delved into this, but from what I recall, the only "Shot Interval" setting that matters in Pixhawk mode is Burst - which starts continuous shooting as fast as the camera will cycle when the Pixhawk requests a shot.

Edit 1: You need to jumper your Pixhawk correctly so that your interface cable can get +5V from the middle pin of its connector. Typically this requires getting the +5V from your BEC and connecting it to the middle row of pins of the pixhawk.

Edit 2:  took another look at your log - thanks for providing that, it helps a lot.  From what I can see, you have tried the following combinations :
ModeSettingResults
PixHawkFastfail
PixHawkBurstfail
PixHawkFastfail
PixHawkFastfail
OneShotFastslow random shots
OneShotBurstrandom shots
On/OffFastfail
One ShotFastfail
NoneFast3 sec per shot
PixHawkFastfail
OneShotFastslow random shots

Note that shooting never starts in Pixhawk mode regardless of the shot rate setting.  This suggests that the script never sees the required 3 mSec start pulse from the Pixhawk. However, it does seem to see some USB activity as shown by the random shooting in OneShot mode (it shoots each time it detect the USB signal changing).

So my guess here is that you are not matching the setup of you PixHawk to what the script is expecting to see on the USB +5V line?


« Last Edit: 20 / January / 2019, 13:49:19 by waterwingz »
Ported :   A1200    SD940   G10    Powershot N    G16


Re: KAP & UAV Exposure Control Intervalometer Script
« Reply #1024 on: 20 / January / 2019, 14:38:06 »
Setting "USB Shot Control" to OneShot will trigger a shot each time the USB +5V level toggles.  The "Shot Interval" setting is ignored.

Hum!  That is a good info to know.

Are you actually using a Pixhawk controller?  In Pixhawk mode, the script is waiting for a pulse of a certain length to take a shot - if you are not using a Pixhawk you'll need to setup something to get the same pulse width.

Yes, I'm using a Pixhawk controller. However, the keywords "pulse width" in your answer above are important.  Out of the four Pixhawk firmware modes, two are relevant here.  The GPIO mode and the PWM mode.  The former triggers a voltage relay output; which requires the current adapter I'm currently using. In that mode, your script "USB Shot Control" value should be set to OneShot.  With the latter (PWM triggering source), I should use this other adapter; which I don't have it.  In this mode, your script "USB Shot Control" value should be set to Pixhawk.  Unfortunately, the description for Tuffwing cable is quite confusing.

the only "Shot Interval" setting that matters in Pixhawk mode is Burst - which starts continuous shooting as fast as the camera will cycle when the Pixhawk requests a shot.

Correct. Of course, as long as you use a PWM adapter instead of the Relay one.

Edit 1: You need to jumper your Pixhawk correctly so that your interface cable can get +5V from the middle pin of its connector. Typically this requires getting the +5V from your BEC and connecting it to the middle row of pins of the pixhawk.

Yep, that is how I have it setup (i.e. a 5V BEC powering the servo headers).

Edit 2:  took another look at your log - thanks for providing that, it helps a lot.  From what I can see, you have tried the following combinations :
ModeSettingResults
PixHawkFastfail
PixHawkBurstfail
PixHawkFastfail
PixHawkFastfail
OneShotFastslow random shots
OneShotBurstrandom shots
On/OffFastfail
One ShotFastfail
NoneFast3 sec per shot
PixHawkFastfail
OneShotFastslow random shots

Note that shooting never starts in Pixhawk mode regardless of the shot rate setting.  This suggests that the script never sees the required 3 mSec start pulse from the Pixhawk. However, it does seem to see some USB activity as shown by the random shooting in OneShot mode (it shoots each time it detect the USB signal changing).

The log info above might not be valid anymore since I was not using the correct adapter for PWM mode.

So my guess here is that you are not matching the setup of you PixHawk to what the script is expecting to see on the USB +5V line?

Based on the two different type of adapters required for one mode or the other, your guess is correct.

Re: KAP & UAV Exposure Control Intervalometer Script
« Reply #1025 on: 26 / January / 2019, 20:49:51 »
Looking for some help with my aerial shoots being extremely over exposed. I have a Powershot SX610 in a fixed wing drone and being triggered by a pixhawk. The attached picture was taken today at 400 ft on a sunny day. Any suggestions would be greatly appreciated. I have not changed any settings in the script or camera.

Thanks

Paul

Re: KAP & UAV Exposure Control Intervalometer Script
« Reply #1026 on: 26 / January / 2019, 21:07:57 »
Looking for some help with my aerial shoots being extremely over exposed. I have a Powershot SX610 in a fixed wing drone and being triggered by a pixhawk. The attached picture was taken today at 400 ft on a sunny day.
Please post the log file created by the script (kap.log) as an attachment here. It should be located in the top level folder of your SD card. 

Were all shots over exposed or just some of them?  If only some were, it would be helpful to know some of affected image filenames too as I look through the log.

Did you try shooting on the ground with the script?  Disable the USB / Pixhawk stuff and just run the script as an intervalometer while the camera is pointed at a normal daylight exposure scene.
Ported :   A1200    SD940   G10    Powershot N    G16

Re: KAP & UAV Exposure Control Intervalometer Script
« Reply #1027 on: 27 / January / 2019, 07:53:47 »
Looking for some help with my aerial shoots being extremely over exposed. I have a Powershot SX610 in a fixed wing drone and being triggered by a pixhawk. The attached picture was taken today at 400 ft on a sunny day.
Please post the log file created by the script (kap.log) as an attachment here. It should be located in the top level folder of your SD card. 

Were all shots over exposed or just some of them?  If only some were, it would be helpful to know some of affected image filenames too as I look through the log.

Did you try shooting on the ground with the script?  Disable the USB / Pixhawk stuff and just run the script as an intervalometer while the camera is pointed at a normal daylight exposure scene.

kap.log attached. All of the pictures (1/26/2019) on that flight were overexposed, 27 in total. I will try the intervalometer later today. Thanks for the guidance and any additional thoughts.


Re: KAP & UAV Exposure Control Intervalometer Script
« Reply #1028 on: 27 / January / 2019, 13:26:47 »
kap.log attached. All of the pictures (1/26/2019) on that flight were overexposed, 27 in total. I will try the intervalometer later today. Thanks for the guidance and any additional thoughts.
Thanks for the log - I'll take a few minutes to study it later today. 

Meanwhile, I see several long runs dating back to Oct 25 2018 of the script with quite a few photos taken .  How did those images look or were you just testing?
Ported :   A1200    SD940   G10    Powershot N    G16

Re: KAP & UAV Exposure Control Intervalometer Script
« Reply #1029 on: 27 / January / 2019, 17:32:22 »
Thanks once again for your assistance.  Those previous logs were all tests in the garage primarily making sure the pixhawk would trigger the camera. I used your suggestion and tested the intervalometer. The intervalometer scripted running looks good. I ran KAP again and made numerous adjustments to TV, ISO, Exposure and I'm getting closer. The link attached has a test flight at 400 feet with pictures, kap log and snapshots of the script settings. The exposure still looks too high to me. I can increase the Exposure from -1 to -2. Is that the best approach. Any other suggestions? Thanks again!! Paul 

https://inet.idealab.com/dbd/512BA359/Croswind_aerial_test.zip

 

Related Topics