G15 permanent problem with mode wheel

  • 6 Replies
  • 1344 Views
G15 permanent problem with mode wheel
« on: 29 / October / 2013, 18:00:45 »
Advertisements
Hello,

Yesterday I updated my Canon G15 with the CHDK 1.3.0 for 100b firmware version, and the mode wheel began to work improperlly. The modes Av, Tv are not activated, and when P mode selected the M mode is activated... quite a mess...
I did it with a bootable SD.
If I change the SD with a normal one, the CHDK is not loaded, but the mode wheel problem persist!!
I updated then with CHDK 1.2.0 100b firmware version, to try to see if the problem was solved, but is not!!

Can help me anyone to solve that issue? Maybe downloading the original Canon 100b firmware for G15?? There's any body that have it to do it??

BR,


Re: G15 permanent problem with mode wheel
« Reply #1 on: 29 / October / 2013, 18:18:01 »
Technically,  CHDK does not "update" or change your camera's firmware.  It loads in RAM and goes away every time the camera is switched off.  No permanent changes are (intentionally) made to the camera firmware.

What you are seeing is very unusual and its not something that was supposed to happen obviously.  There are many G15 users running CHDK with no reports of problems to date.   

So that leaves a hardware failure on your camera - unusual but not impossible.  Or an unfortunate glitch that affected your camera's permanent memory somehow. 

The bad new here is that just as CHDK does not change your camera's firmware,  there is also no way to simply reload the original Canon version. 

Maybe someone else will post something I missed here.
Ported :   A1200    SD940   G10    Powershot N    G16

*

Offline srsa_4c

  • ******
  • 3530
Re: G15 permanent problem with mode wheel
« Reply #2 on: 30 / October / 2013, 12:46:11 »
@kalamarcete
Some thoughts.
- You could try the setmode.lua script (included in the full CHDK distribution zip file) to change modes (I'm not saying that it's a solution, just a test), and see whether Av and Tv modes are accessible.
- You could dump the camera's firmware: http://chdk.wikia.com/wiki/Canon_Basic/Scripts/Dumper (your dump can then be compared to the 100b dump "we" have - only corruptions of the main firmware can be detected though, the camera specific areas are mostly unknown).
- If the cam's under warranty, try sending it back for a repair.

@anybody else with the camera
Are the mode wheel's bits available in physw_status[]?

*

Offline ahull

  • *****
  • 634
Re: G15 permanent problem with mode wheel
« Reply #3 on: 30 / October / 2013, 15:36:26 »
I don't have this particular camera, but one thing I would suggest, is that you try restoring the factory default settings from the Canon menus.

On this particular model, I think it is called something like 'reset all to factory settings'. This often fixes odd quirks like this. If this does the trick, then try CHDK again and see if you can replicate the issue.


Re: G15 permanent problem with mode wheel
« Reply #4 on: 30 / October / 2013, 17:28:03 »
Hello All of you!

Thank you for your comments.

It seems that something during the use of CHDK was out of the RAM, and now it's permanent... so something was wrong

I tried to use the SetMode.lua Script, and it's working selecting Av o Tv the mode is activated correctly. At least with this method I can select this 2 modes.
Would it be possible to create a Script that would be able to assign Modes to Mode Wheel Position?
About the dummping. After do it, I have to send you the results file?

I tried previosly to "Reset default factory settings" and the problem continues.

Any other ideas on how to solve the case?

BR

*

Offline philmoz

  • *****
  • 3059
    • Photos
Re: G15 permanent problem with mode wheel
« Reply #5 on: 30 / October / 2013, 17:52:17 »
Hello All of you!

Thank you for your comments.

It seems that something during the use of CHDK was out of the RAM, and now it's permanent... so something was wrong

I tried to use the SetMode.lua Script, and it's working selecting Av o Tv the mode is activated correctly. At least with this method I can select this 2 modes.
Would it be possible to create a Script that would be able to assign Modes to Mode Wheel Position?
About the dummping. After do it, I have to send you the results file?

I tried previosly to "Reset default factory settings" and the problem continues.

Any other ideas on how to solve the case?

BR

It's highly unlikely that CHDK had anything to do with this - I suspect it's just an unfortunate coincidence that the physical switch has failed just when you were testing CHDK.

There is no way that Canon can know you were running CHDK, so just send the camera back for repair/replacement.

Phil.
CHDK ports:
  sx30is (1.00c, 1.00h, 1.00l, 1.00n & 1.00p)
  g12 (1.00c, 1.00e, 1.00f & 1.00g)
  sx130is (1.01d & 1.01f)
  ixus310hs (1.00a & 1.01a)
  sx40hs (1.00d, 1.00g & 1.00i)
  g1x (1.00e, 1.00f & 1.00g)

Re: G15 permanent problem with mode wheel
« Reply #6 on: 30 / October / 2013, 18:07:43 »
There is no way that Canon can know you were running CHDK, so just send the camera back for repair/replacement.
Just don't return the camera with a CHDK enabled SD card inside it. :D
Ported :   A1200    SD940   G10    Powershot N    G16

 

Related Topics