Override shutter speed - can't get it to work

  • 8 Replies
  • 1065 Views
Override shutter speed - can't get it to work
« on: 17 / November / 2013, 19:32:07 »
Advertisements
The only options I have to override the Tv function are Ev step and Short Exposure.  I'd like to increase the shutter speed from 15 (the existing maximum) to 60 seconds.  Am I out of luck?
(This is on a Canon PowerShot S2IS)
Cheers

Re: Override shutter speed - can't get it to work
« Reply #1 on: 18 / November / 2013, 01:54:40 »
Did you try to do this, while cam is in manual mode? I have one s2is and had no problems.

Also - there's a setting in overrides menu like "Turn off overrides" - or something like this. Check, whether it is set to appropriate value.
if (2*b || !2*b) {
    cout<<question
}

Compile error: poor Yorick

*

Offline philmoz

  • *****
  • 3061
    • Photos
Re: Override shutter speed - can't get it to work
« Reply #2 on: 18 / November / 2013, 02:51:07 »
The S2IS port does not currently support very long shutter speeds (> 64 seconds).

You should still be able to select up to 64 seconds using the Ev Step option.

Phil.
CHDK ports:
  sx30is (1.00c, 1.00h, 1.00l, 1.00n & 1.00p)
  g12 (1.00c, 1.00e, 1.00f & 1.00g)
  sx130is (1.01d & 1.01f)
  ixus310hs (1.00a & 1.01a)
  sx40hs (1.00d, 1.00g & 1.00i)
  g1x (1.00e, 1.00f & 1.00g)

*

Offline nafraf

  • *****
  • 1296
Re: Override shutter speed - can't get it to work
« Reply #3 on: 18 / November / 2013, 03:45:29 »
If you are willing to test and report, I can try to add support for very long shutter speeds.


Re: Override shutter speed - can't get it to work
« Reply #4 on: 18 / November / 2013, 06:28:28 »
Many thanks for the replies!

outslider:  Yeah, I tried in Manual mode (with "Turn off Overrides" unchecked)

philmoz: Can you explain how I can achieve 64 sec using the Ev Step option, please.

nafraf,
Thanks for your kind offer.  I think just getting 64 sec would be fine for now.

Cheers!

*

Offline srsa_4c

  • ******
  • 3540
Re: Override shutter speed - can't get it to work
« Reply #5 on: 18 / November / 2013, 14:50:54 »
The only options I have to override the Tv function are Ev step and Short Exposure.  I'd like to increase the shutter speed from 15 (the existing maximum) to 60 seconds.
philmoz: Can you explain how I can achieve 64 sec using the Ev Step option, please.
You weren't asking me, but you can find the input field just below the "Ev step"/"Short exposure" selector. So, select that line and choose the desired override value with the left/right button. The small tick box to the left of this input field lets you quickly enable/disable this override, press Set to enable [.] or disable [ ].
BTW, questions like this are hopefully well explained in the manual.

Re: Override shutter speed - can't get it to work
« Reply #6 on: 18 / November / 2013, 21:05:06 »
...select that line and choose the desired override value ...
...

Yeah, I got far (setting the exp to 64 sec) but when I go to take a picture how can I select that value?  It's still showing the max is 15 sec.
Thanks!

Re: Override shutter speed - can't get it to work
« Reply #7 on: 18 / November / 2013, 21:17:28 »
Yeah, I got far (setting the exp to 64 sec) but when I go to take a picture how can I select that value?  It's still showing the max is 15 sec.
What are you referring to when you say "It's stil showing the max is 15 sec." ?  If you mean the Canon OSD values,  be aware that the Canon firmware has no idea that CHDK is going to change the shutter speed - that value is only inserted by CHDK into the shooting process right before the actual exposure is made.

Ignore the Canon OSD and examine the final photograph to see if you made a 60 second exposure.  Or just time how long the camera stays locked up as it makes the exposure.
Ported :   A1200    SD940   G10    Powershot N    G16


Re: Override shutter speed - can't get it to work
« Reply #8 on: 19 / November / 2013, 09:06:36 »
Doh!
Thanks for the explanation.  Now I get it.  I tested it out and it was about a minute.
Many thanks for your help!


 

Related Topics