supplierdeeply

Canon SX10IS - problem swapping partitions

  • 1 Replies
  • 609 Views
*

Offline Al

  • *
  • 1
Canon SX10IS - problem swapping partitions
« on: 18 / November / 2013, 21:17:45 »
Advertisements
I just bought a used SX10IS and the first thing I did was put CHDK on it.  Kind of a drag using the two partitions, but did get everything worked out.  Took a picture and then went to view it on my Windows PC.  Nothing showed up on the 16GB SDHC card.  Put the card back into the camera and swapped partitions.  Put the card back in the PC and found the image file.

Now the problem.  I put the card back into the camera, and CHDK doesn't load.  I can't find a way to swap the partitions back so CHDK works again.

BTW, I am using the bootable card method of loading CHDK.

Any help you can provide would be greatly appreciated.

Thanks...
Al

Re: Canon SX10IS - problem swapping partitions
« Reply #1 on: 18 / November / 2013, 21:21:25 »
Kind of a drag using the two partitions, but did get everything worked out. 
For playing with CHDK on my older cameras,  I typically stick to 4G cards formatted as FAT16.  For just this reason.

Quote
Took a picture and then went to view it on my Windows PC.  Nothing showed up on the 16GB SDHC card.  Put the card back into the camera and swapped partitions.  Put the card back in the PC and found the image file.
Now the problem.  I put the card back into the camera, and CHDK doesn't load.  I can't find a way to swap the partitions back so CHDK works again.
You can use SDMinste  or  WASP to swap partitions on your PC prior to putting the card back in the camera. 

Or you can boot using the "firmware update" method (assuming you have the ps.fi2 file on both partitiions) and go into the CHDK menus to swap the partitions back correctly for SD card lock booting.
« Last Edit: 18 / November / 2013, 21:24:28 by waterwingz »
Ported :   A1200    SD940   G10    Powershot N    G16

 

Related Topics