SX510

  • 213 Replies
  • 16984 Views
Re: SX510
« Reply #60 on: 02 / April / 2014, 15:19:39 »
Advertisements
sorry my mistake .it like to problem with draw zebra.not histgram.i test it and im sure about it.and thanks for everything

*

Offline srsa_4c

  • ******
  • 3171
Re: SX510
« Reply #61 on: 09 / April / 2014, 18:59:58 »
@nafraf
The following mod enables permanent zebra display in play mode - would be interesting to know whether the corruption/crash is still there when zebra is used in play mode (this would make the investigation easier and also spare unnecessary lens actuations).
Code: [Select]
Index: core/gui_osd.c
===================================================================
--- core/gui_osd.c (revision 3416)
+++ core/gui_osd.c (working copy)
@@ -1291,7 +1291,7 @@
         return;
 
     if (conf.zebra_draw)
-        if (libzebra->gui_osd_draw_zebra(conf.zebra_draw && camera_info.state.is_shutter_half_press && camera_info.state.mode_photo))
+        if (libzebra->gui_osd_draw_zebra(conf.zebra_draw))
      return; // if zebra drawn, we're done
 
 #if !CAM_SHOW_OSD_IN_SHOOT_MENU

*

Offline nafraf

  • *****
  • 1271
Re: SX510
« Reply #62 on: 13 / April / 2014, 17:55:40 »
@srsa_4c
Test with patched version. Camera crashes occasionally when it starts in play mode.


*

Offline srsa_4c

  • ******
  • 3171
Re: SX510
« Reply #63 on: 13 / April / 2014, 18:43:33 »
Test with patched version. Camera crashes occasionally when it starts in play mode.
Thanks. Same crash reason, inside malloc().
So, you now have a camera with a reproducible memory corruption that always seems to affect the same memory area. But the corruption only happens occasionally.
I'm not exactly sure what the next step should be. Maybe the zebra code could be modified to not write anything to
a) the cam's bitmap overlay
or
b) its internally malloc'd memory
but make boundary checks instead.
Or, does anyone have a better idea?


Re: SX510
« Reply #64 on: 18 / April / 2014, 17:48:41 »
Hi All, I am new in CHDK and looking for a hint about the possibility (if any) to get live video output via USB or HDMI ports while shooting (and or not) recording the video. From all I have read so far, it seems that this is not possible(?!). My Camera is SX 510 HS, FW-101a.

Re: SX510
« Reply #65 on: 18 / April / 2014, 21:28:43 »
Hi All, I am new in CHDK and looking for a hint about the possibility (if any) to get live video output via USB or HDMI ports while shooting (and or not) recording the video. From all I have read so far, it seems that this is not possible(?!). My Camera is SX 510 HS, FW-101a.
Some older Canon Powershot camera would output live video while shooting.  That feature has been removed by Canon on more recent models.  There is nothing CHDK can do to fix that.  Sorry.

*

Offline reyalp

  • ******
  • 10069
Re: SX510
« Reply #66 on: 18 / April / 2014, 22:49:43 »
Hi All, I am new in CHDK and looking for a hint about the possibility (if any) to get live video output via USB or HDMI ports while shooting (and or not) recording the video. From all I have read so far, it seems that this is not possible(?!). My Camera is SX 510 HS, FW-101a.
Some older Canon Powershot camera would output live video while shooting.  That feature has been removed by Canon on more recent models.  There is nothing CHDK can do to fix that.  Sorry.
Not all recent models. The Canon manual should say if video out works in shooting mode. The SX510 manual says

"When the camera and TV are connected, you can also shoot while previewing shots on the larger screen of the TV..." (p130)

I think this will only work with the USB plug adapter (NTSC/PAL SD), not HDMI.

With CHDK, PTP live view might also be an alternative, depending on the application.
Don't forget what the H stands for.

Re: SX510
« Reply #67 on: 19 / April / 2014, 11:59:15 »
waterwingz;  reyalp;
Thank you for the quick response. I will explore the case in depth. If I get some satisfactory result, will share here.


Re: SX510
« Reply #68 on: 21 / April / 2014, 16:28:47 »
Hello everybody ;
I´am new here , i hope i'm asking in the right post  :( .
I have a sx510 hs and i want to know if the chdk for 1.00d  is valid for a 1.00c version
firmware .
Thank you. :D

*

Offline srsa_4c

  • ******
  • 3171
Re: SX510
« Reply #69 on: 21 / April / 2014, 17:12:54 »
Hello everybody ;
I´am new here , i hope i'm asking in the right post  :( .
I have a sx510 hs and i want to know if the chdk for 1.00d  is valid for a 1.00c version
firmware .
I think it should work - the main part of the firmware only differs in the version strings. Try it and report if it's working. Note that you should probably avoid using the zebra (and maybe the histogram) feature of CHDK, these may lead to crash on this cam.

 

Related Topics