supplierdeeply

A1400 porting thread

  • 130 Replies
  • 9446 Views
*

Offline nafraf

  • *****
  • 1269
A1400 porting thread
« on: 02 / December / 2013, 20:00:28 »
Advertisements
I'm porting CHDK for A1400 100b. Testers are welcome. :)

Re: A1400 porting thread
« Reply #1 on: 04 / December / 2013, 04:57:42 »
Hi Nafraf,

I tried your binary build from http://www.filedropper.com/a1400-100b-130-3260-full  (based upon http://subversion.assembla.com/svn/nafraf/chdk/platform/a1400/ source).

I confirmed the firmware version of my A1400 to be 1.00b using the ACID utility.

I tried to boot chdk on the camera:
* took a 4 Gb SD card
* formatted it as fat32 using gparted
* put in the magic "BOOTDISK" string at 0X1E0 using hexedit
* copied the contents of the firmware zip file
* locked the sd card
* put it into the camera

When I boot the camera, I get no information whatsoever on screen about CHDK. It seems to boot to its generic Canon firmware.

I also had a quick look at connecting to it using the old ptpcam binary with chdk modifications that I had installed.

ptpcam --list-devices
Listing devices...
bus/dev   vendorID/prodID   device model
002/006   0x04A9/0x3264   Canon PowerShot A1400

ptpcam --chdk
unexpected return code 0x2005
error: cannot get camera CHDK PTP version; either it has an unsupported version or no CHDK PTP support at all


Is there anything that I can do to troubleshoot this?


Kind regards,

Mark
« Last Edit: 04 / December / 2013, 05:14:25 by markvandenborre »

*

Offline nafraf

  • *****
  • 1269
Re: A1400 porting thread
« Reply #2 on: 04 / December / 2013, 06:16:48 »
Thanks, I sent you a new version.

Re: A1400 porting thread
« Reply #3 on: 04 / December / 2013, 23:23:38 »
[email protected]:~$ ptpcam --chdk
<conn> mode 1
script:1
Code: [Select]
<conn> luar get_buildinfo()
script:2
2:ret:'platform a1400
build_date Dec  4 2013
build_number 1.3.0
build_time 09:08:18
version CHDK
platsub 100b
build_revision 3260
platformid 12900
os dryos

It switches to mode 1 ok. Many other things seem to be a problem.
« Last Edit: 04 / December / 2013, 23:25:16 by markvandenborre »


*

Offline nafraf

  • *****
  • 1269
Re: A1400 porting thread
« Reply #4 on: 05 / December / 2013, 11:35:41 »
Some tests:
- llibtst.lua runs without problems (log in attachment)
- ubtest runs without problems
- Raw capture works
- remote capture works
- setmode.lua: Even using 2s delay, some modes fails, but using chdkptp all modes works without problems
- file counter is implemented as done in ixus140

*

Offline reyalp

  • ******
  • 10067
Re: A1400 porting thread
« Reply #5 on: 05 / December / 2013, 16:34:33 »
- file counter is implemented as done in ixus140
FWIW, I have found that this method does not seem 100% reliable, I've raw images occasionally overwritten using an intervalometer.

It may need PAUSE_FOR_FILE_COUNTER after all.
Don't forget what the H stands for.

Re: A1400 porting thread
« Reply #6 on: 22 / December / 2013, 07:40:21 »
i want to test chdk a1400

can any one send me  some files i want to contribute for a1400

*

Offline nafraf

  • *****
  • 1269
Re: A1400 porting thread
« Reply #7 on: 22 / December / 2013, 22:00:04 »
@binngo
I sent you a PM with the link to the file.  Please test it and report.


Re: A1400 porting thread
« Reply #8 on: 23 / December / 2013, 06:09:42 »
i have loaded that file through  Cardtrick    camera turns on shows canon  on screen and then turns off 

i tried to turn it on through play button and  power button same  thing happened

Re: A1400 porting thread
« Reply #9 on: 23 / December / 2013, 06:23:34 »
after few Attamps  camera booted with CHDK icon but as i pressed alt key it turned off again and now agian it goes to canon logo and turn off

 

Related Topics