A1400 porting thread - page 3 - DryOS Development - CHDK Forum supplierdeeply

A1400 porting thread

  • 130 Replies
  • 32022 Views
Re: A1400 porting thread
« Reply #20 on: 25 / December / 2013, 10:14:29 »
Advertisements
The A1400 does not have an adjutable aperture so Av override is not an option.   Any variation in reported f-stop setting that you see in your images is a result of changing zoom position or the camera inserting a neutral density filter

Update :  the issue with the focus window interference with the menus in shooting mode happens on most cameras and is currently a limitation of CHDK and not just for your camera.  You will not see that effect if you do most of your setup work in playback mode.   Also,  turning off focus tracking helps.
« Last Edit: 25 / December / 2013, 10:25:58 by waterwingz »
Ported :   A1200    SD940   G10    Powershot N    G16

*

Offline nafraf

  • *****
  • 1308
Re: A1400 porting thread
« Reply #21 on: 25 / December / 2013, 11:17:36 »
2 histogram in color mode is not positioned rite i can only see two colors third one is some where below the screen hiding  :-X
CHDK Menu -> CHDK Settings -> OSD Layout Editor.
More information in the manual: http://chdk.wikia.com/wiki/CHDK_1.2.0_User_Manual

Re: A1400 porting thread
« Reply #22 on: 25 / December / 2013, 12:15:37 »
2 histogram in color mode is not positioned rite i can only see two colors third one is some where below the screen hiding  :-X
CHDK Menu -> CHDK Settings -> OSD Layout Editor.
More information in the manual: http://chdk.wikia.com/wiki/CHDK_1.2.0_User_Manual
http://chdk.wikia.com/wiki/CHDK_1.2.0_User_Manual#OSD_Layout_Editor
Ported :   A1200    SD940   G10    Powershot N    G16

Re: A1400 porting thread
« Reply #23 on: 29 / December / 2013, 03:36:32 »
okay i have tried every thing   only video options are not tested not a video person but can test if you ill tell me what to test

 every thing else seems to be working fine  on RAW camera get really slow but i think its cause of camera hardware or memory card issue

and also camera freezes  other then that every thing that i tested worked

still auto focus window is showing off making menu hard to read some times

Nafraf  this test version will expire in 5 days any chance i can get a permanent one


Re: A1400 porting thread
« Reply #24 on: 07 / January / 2014, 19:34:11 »
Would like to test this port out on my A1400 please.

Cheers
Andy

*

Offline ksz

  • *
  • 1
Re: A1400 porting thread
« Reply #25 on: 08 / January / 2014, 07:33:54 »
Hi!

I'm also interested in testing CHDK in my A1400.

ksz

*

Offline timgor

  • ***
  • 150
Re: A1400 porting thread
« Reply #26 on: 09 / January / 2014, 16:24:22 »
Can I have the a1400 version too for tests?
what should I do to compile it, just add
http://subversion.assembla.com/svn/nafraf/chdk/loader/a1400/
http://subversion.assembla.com/svn/nafraf/chdk/platform/a1400/
to my project and compile it?

*

Offline nafraf

  • *****
  • 1308
Re: A1400 porting thread
« Reply #27 on: 09 / January / 2014, 16:55:21 »
Yes, add those directories to chdk source tree, then "make PLATFORM=a1400 PLATFORMSUB=100b"
http://chdk.wikia.com/wiki/Compiling_CHDK_under_Linux



*

Offline c10ud

  • ***
  • 245
Re: A1400 porting thread
« Reply #28 on: 16 / January / 2014, 13:24:49 »
hello,

a friend got the a1400 and I had a brief chance to play with it (weird camera!)
You may want to _remove_ these defines otherwise it crashes while set_zoom()--ing..probably a leftover from older ports? (First and atm only issue I found...I'll see if I can keep the camera for a few days and test more though...even if my time to play with chdk is near to zero :()

Code: [Select]
diff --git a/platform/a1400/platform_camera.h b/platform/a1400/platform_camera.h
index 7fa915d..b92602e 100644
--- a/platform/a1400/platform_camera.h
+++ b/platform/a1400/platform_camera.h
@@ -103,10 +103,10 @@
     #define CAM_FILEWRITETASK_SEEKS           1
 
     #define CAM_HAS_ZOOM_LEVER                1    // Camera has dedicated zoom buttons
-    #define CAM_NEED_SET_ZOOM_DELAY           300  // Define to add a delay after setting the zoom position
-    #define CAM_USE_OPTICAL_MAX_ZOOM_STATUS   1    // Use ZOOM_OPTICAL_MAX to reset zoom_status when switching from digital to optical zoom
-    #define CAM_USE_ALT_SET_ZOOM_POINT        1    // Define to use the alternate code in lens_set_zoom_point()
-    #define CAM_USE_ALT_PT_MoveOpticalZoomAt  1    // Define to use the PT_MoveOpticalZoomAt() function in lens_set_zoom_point()
+    //#define CAM_NEED_SET_ZOOM_DELAY           300  // Define to add a delay after setting the zoom position
+    //#define CAM_USE_OPTICAL_MAX_ZOOM_STATUS   1    // Use ZOOM_OPTICAL_MAX to reset zoom_status when switching from digital to optical zoom
+    //#define CAM_USE_ALT_SET_ZOOM_POINT        1    // Define to use the alternate code in lens_set_zoom_point()
+    //#define CAM_USE_ALT_PT_MoveOpticalZoomAt  1    // Define to use the PT_MoveOpticalZoomAt() function in lens_set_zoom_point()
 
     #define CAM_FILE_COUNTER_IS_VAR           1       // file counter is variable file_counter_var in stubs, not a param
 

*

Offline nafraf

  • *****
  • 1308
Re: A1400 porting thread
« Reply #29 on: 16 / January / 2014, 14:24:12 »
Hi c10ud, thanks for testing!!
Do you have a script to reproduce the error? I tested using chdkptp and I could not reproduce it.
Code: [Select]
___> list
-1:Canon PowerShot A1400 b=bus-0 d=\\.\libusb0-0003--0x04a9-0x3264 v=0x4a9 p=0x3
264 s=8690FC533114492AAB8D98237D3416FB
___> c
connected: Canon PowerShot A1400, max packet size 512
con> =return get_buildinfo()
1:return:table:{platform="a1400",build_date="Jan 15 2014",build_number="1.3.0",b
uild_time="12:46:02",version="CHDK",platsub="100b",build_revision="3312",platfor
mid=12900,os="dryos",}
con 1> rec
con 2> =set_zoom(25)
con 3> =return get_zoom()
4:return:25
con 4> =set_zoom(3)
con 5> =return get_zoom()
6:return:3
con 6>

 

Related Topics