supplierdeeply

SX500 IS Porting thread

  • 53 Replies
  • 9610 Views
Re: SX500 IS Porting thread
« Reply #50 on: 26 / August / 2013, 23:38:51 »
Advertisements
I actually tested the build, the scripts and haven't found a problem yet. Will continue testing.

Re: SX500 IS Porting thread
« Reply #51 on: 04 / October / 2013, 09:08:41 »
I just snagged an SX500IS with 1.00c FW...

STICK now recognizes it and downloads the appropriate firmware. :)  It booted up CHDK ok, although there seems to be a lot of fighting going on between the camera display and CHDK.  There are also some menu options missing that I think should be there, but aren't.  I'm not completely sure of that, as I haven't spent much time with it yet.  I'll see if I can burn some time this weekend and run through everything to see what does and doesn't work.

Regardless, thanks for work on this...  I'll be happy to troubleshoot whatever I can, but you may have to exercise some patience with me.   ???

Re: SX500 IS Porting thread
« Reply #52 on: 04 / October / 2013, 10:49:52 »
It booted up CHDK ok, although there seems to be a lot of fighting going on between the camera display and CHDK. 
That's unfortunately normal when the camera is in shooting mode.  It tends to be more stable in playback mode.

Quote
There are also some menu options missing that I think should be there, but aren't.  I'm not completely sure of that, as I haven't spent much time with it yet.  I'll see if I can burn some time this weekend and run through everything to see what does and doesn't work.
The CHDK Manual pretty much documents everything that should be there :
http://chdk.wikia.com/wiki/CHDK_1.2.0_User_Manual
Ported : A1200  SD940  G10  Powershot N  G16*

*

Offline reyalp

  • ******
  • 10944
Re: SX500 IS Porting thread
« Reply #53 on: 15 / February / 2015, 17:14:51 »
It looks like this camera has the same incorrect front dial code as sx160, sx170 and sx510: http://chdk.setepontos.com/index.php?topic=11164.220

I've checked the fix into the 1.4 trunk, autobuild 4009 and later. If anyone can confirm it still works correctly, that would be appreciated.
Don't forget what the H stands for.


 

Related Topics