Setting focus from scripts or menus - page 23 - General Discussion and Assistance - CHDK Forum

Setting focus from scripts or menus

  • 556 Replies
  • 133361 Views
Advertisements
Sorry I am not very fluent in Canon camera operation and mastering the HTML code in my replies
Thank you for running this test - your camera was configured correctly.  But I looked at your log file (a2200.csv) and it appears that you missed two of the tests?

I can see where the first test ( set_focus() ) causes a crash.  However,  when you disabled that test it appears that you also disabled the set_aflock() and PressSw1AndMF tests as well?

Would you mind rerunning the test with  set_focus()  disabled   and   set_aflock()  & PressSw1AndMF enabled please?
Ported :   A1200    SD940   G10    Powershot N    G16

*

Offline poussin

  • *
  • 36
  • A2200
   

test 1 passed
test 2 launched then crash
disabling
set_focus
set_aflock
presssw1
allows the test to run





Would you mind rerunning the test with  set_focus()  disabled   and   set_aflock()  & PressSw1AndMF enabled please?
Sorry for the tense wording of my test report
I meant :
Until I successively disabled
set_focus
then
set_aflock
then
presssw1
the camera crashes

summary
set_focus;enabled;disabled;disabled;disabled
set_aflock;enabled;enabled;disabled;disabled
presssw1;enabled;enabled;enabled;disabled
result;crash;crash;crash;ok

Am I supposed to test all the combinations ?

Not sure how the crashes are reported in the .csv file.


Not sure how the crashes are reported in the .csv file.
Each time the script starts,  it writes the current camera configuration to the .csv file.  Then at each step,  the script writes a line to the .csv file giving camera status and test results at that point.  So by looking at the file, you can see where the script has crashed by finding the last entry prior to the next script start header.

In your case,  I can see four identical script starts that crash when attempting to set_focus() only.  The next and final script start after that has :
  • set_focus() only :  disabled
  • set_aflock() :  disabled
  • PressSW1AndMF : disabled

There are no entries to indicate the script has been run with :
  • set_focus() only :  disabled
  • set_aflock() :  enabled
  • PressSW1AndMF : enabled
or
  • set_focus() only :  disabled
  • set_aflock() :  disabled
  • PressSW1AndMF : enabled

That's why I asked you to rerun the script twice more with those configurations.
Ported :   A1200    SD940   G10    Powershot N    G16

Re: please run this script and report back (S100.CSV)
« Reply #223 on: 26 / January / 2014, 06:25:24 »
Updated the script to v2.12.  Now checks for CHDK 1.3.0 and version 3303 or later.
Thank you for the information. I've successfully run the script on my S100 (with s100-101a-1.3.0-3340-full_BETA), see attachment.
I ran it twice because the first time it was very dark. I'm not sure whether this could affect the test results.


*

Offline poussin

  • *
  • 36
  • A2200
    Not sure how the crashes are reported in the .csv file.


    There are no entries to indicate the script has been run with :
    • set_focus() only :  disabled
    • set_aflock() :  enabled
    • PressSW1AndMF : enabled

    Whatever the log file could list or not  , I ran this test and it crashes.

    Unless and until I disabled the 3 first  tests , it crashes.

    Please have a look at http://chdk.setepontos.com/index.php?topic=6231.msg109584#msg109584 .
    [/list]

    *

    Offline poussin

    • *
    • 36
    • A2200
    Further test shows that :
    Sun Jan 26 14:24:07 2014,MF Test 2.12 Log
    a2200,100d,CHDK,1.3.0-3337
    Mode:P,Continuous_AF:0,Servo_AF:0
    tests : set_focus:0, set_aflock:1, levents:0, event_procs:1, bypass:1
    test,set,actual,result,prop.FOCUS_STATE,prop.AF_LOCK,prop.FOCUS_MODE,prop.REAL_FOCUS_MODE
    1) Testing initial conditions
    ...interlock bypass function available
    ...start, , , ,0,0,0,0
    ...shot1,1020,595,failed,16,0,0,0
    2) Testing set_focus() only
       ..disabled
    3) Testing set_aflock()
    ...start, , , ,16,0,0,0
    ...set_aflock(1), , , ,8,0,0,0
    set_prop.AF_LOCK(1)
    ...start, , , ,8,1,0,0
    ...shot1,400,403,passed,8,1,0,0
    ...shot2,800,797,passed,8,1,0,0
    ...set_prop.AF_LOCK(0), , , ,8,0,0,0
    ...set_aflock(0), , , ,8,0,0,0
    4) Testing levent PressSw1AndMF
       ..disabled
    5) Testing SS.Create
    ...start, , , ,8,0,0,0
    ...SS.Create success
    ...>testing SS.MFOn
    ...SS.MFOn failed
    ...>testing PT_MFOn
    ...PT_MFOn success
    ...start, , , ,0,0,1,0
    ...shot1,600,595,passed,0,0,1,0
    ...shot2,1000,1020,passed,0,0,1,0
    ...disable_PT.MFOn, , , ,0,0,0,0
    6) Testing RegisterShootSeqEvent
    ...RegisterShootSeqEvent failed
    7) Done

     tests set_focus() and   levent PressSw1AndMF fails  ,  although  set_aflock() passes

    which explains the weird previous results

    Further test shows that :
    Sun Jan 26 14:24:07 2014,MF Test 2.12 Log
    Thanks for that.  Can you please attach the actual final csv file so that I can add it to the master file?
    « Last Edit: 26 / January / 2014, 10:26:14 by waterwingz »
    Ported :   A1200    SD940   G10    Powershot N    G16

    *

    Offline nafraf

    • *****
    • 1308
    Results for A2500


    *

    Offline poussin

    • *
    • 36
    • A2200
    Further test shows that :
    Sun Jan 26 14:24:07 2014,MF Test 2.12 Log
    Thanks for that.  Can you please attach the actual final csv file so that I can add it to the master file?

    Results for A2200  1.00d

    Beware some tests have not be logged.

    *

    Offline msl

    • *****
    • 1276
    • A720 IS, SX220 HS 1.01a
      • CHDK-DE links
    Re: Setting focus from scripts or menus : please run this script and report back
    « Reply #229 on: 05 / February / 2014, 08:12:53 »
    ixus80 / sd1100 is still needed.

    Now available: http://forum.chdk-treff.de/download/file.php?id=2669
    CHDK-DE:  CHDK-DE links

     

    Related Topics