proposal - script shooting hooks - page 17 - General Discussion and Assistance - CHDK Forum

proposal - script shooting hooks

  • 290 Replies
  • 79974 Views
*

Offline reyalp

  • ******
  • 13506
Re: proposal - script shooting hooks
« Reply #160 on: 24 / May / 2015, 15:40:11 »
Advertisements
I made a run with G1X. There is still a jump around sv96=603 (In the video around second 22). The rest of the run looks very good. This is the first run, where I see correct ISO values in the EXIF data. The run was made with r4153. Should this change still have an effect in continues mode?
Philmoz change should apply no matter what mode the camera is in. How the camera would behave was unknown, but it looks like it does something similar but not exactly the same  :blink:

AFAIK, Lapser had good results with the G1x in continuous mode using his custom code, so perhaps there are some clues there.
Don't forget what the H stands for.

*

Offline c_joerg

  • *****
  • 1159
Re: proposal - script shooting hooks
« Reply #161 on: 24 / May / 2015, 16:08:41 »
So I will try it next time with r4138 again....
M100 100a, M3 101a, G9x II (1.00c), 2*G1x (101a,100e), S110 (103a), SX50 (100c), SX230 (101a), S45,
Flickr https://www.flickr.com/photos/136329431@N06/albums
YouTube https://www.youtube.com/channel/UCrTH0tHy9OYTVDzWIvXEMlw/videos?shelf_id=0&view=0&sort=dd

*

Offline reyalp

  • ******
  • 13506
Re: proposal - script shooting hooks
« Reply #162 on: 25 / May / 2015, 21:05:25 »
@c_joerg

A long while back you reported the drtest.lua script failed on G1x. I think this should be fixed in the script included with autobuild 4158, so if you can try again, that would be appreciated.

I'm still thinking about how to make the C code and the script properly deal with varying black level.
Don't forget what the H stands for.

*

Offline c_joerg

  • *****
  • 1159
Re: proposal - script shooting hooks
« Reply #163 on: 27 / May / 2015, 01:57:43 »
Quote
you reported the drtest.lua script failed on G1x. I think this should be fixed in the script included with autobuild 4158, so if you can try again, that would be appreciated.

I’m really busy this week. But I will definitely try it on the weekend or beginning next week.

Quote
I'm still thinking about how to make the C code and the script properly deal with varying black level.

Let’s see, what the run with G1X with r4138 in continuous mode shows (I’ll try as soon as possible). If this works fine, I will be happy with this solution.
 

M100 100a, M3 101a, G9x II (1.00c), 2*G1x (101a,100e), S110 (103a), SX50 (100c), SX230 (101a), S45,
Flickr https://www.flickr.com/photos/136329431@N06/albums
YouTube https://www.youtube.com/channel/UCrTH0tHy9OYTVDzWIvXEMlw/videos?shelf_id=0&view=0&sort=dd


*

Offline reyalp

  • ******
  • 13506
Re: proposal - script shooting hooks
« Reply #164 on: 27 / May / 2015, 21:38:24 »
I’m really busy this week. But I will definitely try it on the weekend or beginning next week.
Thanks, no rush.

Quote
Let’s see, what the run with G1X with r4138 in continuous mode shows (I’ll try as soon as possible). If this works fine, I will be happy with this solution.
If the jump at sv96=603 happens in continuous mode, that won't depend on the CHDK version. Philmoz change just attempts to detect if the jump happened and adjust the black level used by CHDK code accordingly. It doesn't affect the actual data, or Canon jpeg processing.
Don't forget what the H stands for.

*

Offline c_joerg

  • *****
  • 1159
Re: proposal - script shooting hooks
« Reply #165 on: 28 / May / 2015, 02:56:32 »
There are differences, which I don’t understand.

Quote
If the jump at sv96=603 happens in continuous mode

The jump is not on sv96=603. The jump (peak) is on the first sv96 value, which is >= 603. So on the last run on sv96=605. When I run isoinc before, the jump was exactly on sv96=603. 605 were on isoinc OK.
Does it help, to implement the continuous mode in isoinc? Then we could compare the runs under same conditions.

Why I see only a peek on your log data, but the level of all jpg pictures are higher after sv96 >= 603.


What is different, when lapser use continuous mode?
http://chdk.setepontos.com/index.php?topic=7934.msg105252#msg105252


About drtest:
Would it be interesting to run drtest under different light condition?
May be one run with Tv < 1s and one run where Tv goes >2s?

M100 100a, M3 101a, G9x II (1.00c), 2*G1x (101a,100e), S110 (103a), SX50 (100c), SX230 (101a), S45,
Flickr https://www.flickr.com/photos/136329431@N06/albums
YouTube https://www.youtube.com/channel/UCrTH0tHy9OYTVDzWIvXEMlw/videos?shelf_id=0&view=0&sort=dd

*

Offline c_joerg

  • *****
  • 1159
Re: proposal - script shooting hooks
« Reply #166 on: 28 / May / 2015, 11:44:26 »
I just run drtest.lua from r4158. I got a printf error, when I start it. Then I run isobase.lua and after drtest.lua again. Then it looks like, that it works. I think, I have seen it also on the old version.
M100 100a, M3 101a, G9x II (1.00c), 2*G1x (101a,100e), S110 (103a), SX50 (100c), SX230 (101a), S45,
Flickr https://www.flickr.com/photos/136329431@N06/albums
YouTube https://www.youtube.com/channel/UCrTH0tHy9OYTVDzWIvXEMlw/videos?shelf_id=0&view=0&sort=dd

*

Offline reyalp

  • ******
  • 13506
Re: proposal - script shooting hooks
« Reply #167 on: 28 / May / 2015, 16:05:58 »
I just run drtest.lua from r4158. I got a printf error, when I start it. Then I run isobase.lua and after drtest.lua again. Then it looks like, that it works. I think, I have seen it also on the old version.
Oops. This happens if the camera is not in record and P mode when you start the script. Fixed in svn 4159.

edit:
The CSV you attached is OK, but the results are a bit strange.

Was the subject a neutral, uniform scene? The neutral shot (row seven, exposure #6) seems to be as expected, but the others are unexpected. There should be ~96 difference between each shot in the m96 column, and the wl% and bl% should only be significant in the first and last shots.

Quote
The jump is not on sv96=603. The jump (peak) is on the first sv96 value, which is >= 603. So on the last run on sv96=605. When I run isoinc before, the jump was exactly on sv96=603. 605 were on isoinc OK.
What I was trying to say is that whatever crazy thing happens is camera firmware behavior, and philmoz change has no impact on that.

In addition to unknown factors within the Canon code, timing of the overrides in CHDK may have some influence.
Quote
Does it help, to implement the continuous mode in isoinc? Then we could compare the runs under same conditions.
That's a good idea, I'll do that when I have some time. (edit: done http://chdk.setepontos.com/index.php?topic=12165.msg122547#msg122547)

I don't think there is a need to run drtest under different conditions, at least not yet.

Quote
What is different, when lapser use continuous mode?
http://chdk.setepontos.com/index.php?topic=7934.msg105252#msg105252
I don't know, lapser used his own custom code.
« Last Edit: 29 / May / 2015, 00:06:31 by reyalp »
Don't forget what the H stands for.


*

Offline c_joerg

  • *****
  • 1159
Re: proposal - script shooting hooks
« Reply #168 on: 29 / May / 2015, 05:28:05 »
Quote
Was the subject a neutral, uniform scene?

No, sorry…. On the first run yes, but then I got the error and I changed the scene. I thought, the scene has something to do with the error …

But today I had a discussion with some colleges, what a neutral, uniform scene is. We think, a gray card would be the best solution or? I’ll run it again…

Quote
I'll do that when I have some time.

This was fast … is there any reason in isoinc, why I can’t set append=true?

The next drtest run...
« Last Edit: 29 / May / 2015, 11:04:31 by c_joerg »
M100 100a, M3 101a, G9x II (1.00c), 2*G1x (101a,100e), S110 (103a), SX50 (100c), SX230 (101a), S45,
Flickr https://www.flickr.com/photos/136329431@N06/albums
YouTube https://www.youtube.com/channel/UCrTH0tHy9OYTVDzWIvXEMlw/videos?shelf_id=0&view=0&sort=dd

*

Offline reyalp

  • ******
  • 13506
Re: proposal - script shooting hooks
« Reply #169 on: 29 / May / 2015, 15:56:20 »
But today I had a discussion with some colleges, what a neutral, uniform scene is. We think, a gray card would be the best solution or? I’ll run it again…
The main point is just to have a similar amount of light across the scene, and have all the color channels at a similar level. A gray card would be fine, I mostly use an LCD monitor with white image on it. If you do use a monitor, make sure sure it's out of focus (e.g. focus at infinity and put the camera a few cm from the screen) so it doesn't pick up individual sub-pixels.

Quote
This was fast … is there any reason in isoinc, why I can’t set append=true?
My laziness is the only reason there isn't an option, if that's what you mean ;)

edit:
The drtest results look good, so it seems the meter code works fine with the 14 bit sensor (aside from the ISO issues)
1) The "neutral" shot m96 value is exactly 0.
2) The remaining m96 values go in steps very close to 96, except for the +3 and +4 exposures which are clipped
3) w% is only > 0 for +3 and +4 ev
4) bl% is only > 0 for -6
« Last Edit: 29 / May / 2015, 16:09:22 by reyalp »
Don't forget what the H stands for.

 

Related Topics