supplierdeeply

cannot open modelist.lua causing issue? (PTPCAM)

  • 23 Replies
  • 2676 Views
cannot open modelist.lua causing issue? (PTPCAM)
« on: 14 / January / 2014, 14:15:24 »
Advertisements
Hi All,

I have installed CHDK on my IXUS 230HS using STICK, with a view to using PTPCAM for remote capture. My problem is, PTPCAM functions don't work (except 'Camera Off'). If I switch to photo mode and click the red camera button, nothing happens, and I get this in the console indefinitely:

Code: [Select]
>> luar get_mode() << script:33
33:ret:false (Length: 23)
>> luar get_mode() << script:34
34:ret:false (Length: 23)
>> luar get_mode() << script:35

I do get "cannont open modelist.lua" error message on my camera and in PTPCAM when switching on the camera / opening the program, and I'm wondering if this is causing my issue?:

Code: [Select]
** init() start ...
>> version << ptpcam: 2.0
camera: 2.5 (Length: 24)
>> script-support << script-support:0x1 lua=yes (Length: 26)
>> luar not(os.stat("A/CHDK/LUALIB/lptpgui.lua")==nil) << script:1
1:ret:true (Length: 20)
>> luar require("lptpgui").version << script:2
2:ret:137 (89) (Length: 24)
>> luar get_buildinfo() << script:3
3:ret:'platform ixus230_elph310hs
build_date Jan 13 2014
build_number 1.2.0
build_time 22:32:49
version CHDK
platsub 100b
build_revision 3313
platformid 12855
os dryos
' (Length: 188)
>> luar get_config_value(67) << script:4
4:ret:1 (1) (Length: 21)
>> luar require("lptpgui").getcammode() << script:5
5:runtime error: error loading module 'GEN/modelist' from file 'A/CHDK/LUALIB/GEN/modelist.lua':
cannot fopen A/CHDK/LUALIB/GEN/modelist.lua (Length: 152)
>> luar get_raw() << script:6
6:ret:0 (0) (Length: 21)
>> luar get_video_button() << script:7
7:ret:1 (1) (Length: 21)
* enable keys for GUI control: >> lua post_levent_to_ui(4484) << script:8 (Length: 8)
>> script-status << script-status:0x0 run=no msg=no (Length: 31)
** init() successful
>> luar require("lptpgui").getcaminfo() << script:9
9:ret:'3592|4057|3280|2002112' (Length: 40)

The file doesn't exist on my SD card, and I'm not sure whether I should be obtaining it from somewhere?

Any help you can provide would be appreciated.

Nick
« Last Edit: 14 / January / 2014, 14:18:50 by elsmore »

*

Offline msl

  • *****
  • 1235
  • A720 IS, SX220 HS 1.01a
    • CHDK inside
Re: cannot open modelist.lua causing issue? (PTPCAM)
« Reply #1 on: 14 / January / 2014, 14:38:39 »
Hello and welcome.

You talk about ptpCamGui, right?

modelist.lua is included in the complete download package for your camera. Download the zip file and copy all folders & files from the zip file to the sd card.

msl

German CHDK pages:  CHDK forum | CHDK inside | CHDK Twitter News by msl | Download CHDK-DE (Autobuild)
Note: SDM violates the GPL rules!

Re: cannot open modelist.lua causing issue? (PTPCAM)
« Reply #2 on: 14 / January / 2014, 15:32:46 »
Hello and welcome.

You talk about ptpCamGui, right?

modelist.lua is included in the complete download package for your camera. Download the zip file and copy all folders & files from the zip file to the sd card.

msl

Hi, and thanks for your reply.

Yes, sorry, ptpCamGui.

I downloaded the complete package as you suggested, and now I have the modelist.lua file on the SD card (CHDK/LUALIB/GEN/modelist.lua). However, I'm still getting the same error! I even prepared (made bootable) the card again by using CHDK just to be sure it was installed properly.

Nick

*

Offline msl

  • *****
  • 1235
  • A720 IS, SX220 HS 1.01a
    • CHDK inside
Re: cannot open modelist.lua causing issue? (PTPCAM)
« Reply #3 on: 14 / January / 2014, 15:59:12 »
You can try another ptp client: chdkptp

If you have the same problems with this client, maybe there is a issue with chdk port for your camera.

msl
German CHDK pages:  CHDK forum | CHDK inside | CHDK Twitter News by msl | Download CHDK-DE (Autobuild)
Note: SDM violates the GPL rules!


Re: cannot open modelist.lua causing issue? (PTPCAM)
« Reply #4 on: 14 / January / 2014, 16:33:54 »
Thanks, I get a similar error with that client:

Code: [Select]
starting gui...
no match error loading module 'propcase' from file 'A/CHDK/LUALIB/propcase.lua':

        cannot fopen A/CHDK/LUALIB/propcase.lua

I guess I'll have to play around with it some more.

Re: cannot open modelist.lua causing issue? (PTPCAM)
« Reply #5 on: 14 / January / 2014, 17:04:32 »
Thanks, I get a similar error with that client:

Code: [Select]
starting gui...
no match error loading module 'propcase' from file 'A/CHDK/LUALIB/propcase.lua':

        cannot fopen A/CHDK/LUALIB/propcase.lua

I guess I'll have to play around with it some more.
Is A/CHDK/LUALIB/propcase.lua on your SD card?
Ported :   A1200    SD940   G10    Powershot N    G16

Re: cannot open modelist.lua causing issue? (PTPCAM)
« Reply #6 on: 14 / January / 2014, 17:11:00 »

Is A/CHDK/LUALIB/propcase.lua on your SD card?

It is.

Nick

*

Offline reyalp

  • ******
  • 11335
Re: cannot open modelist.lua causing issue? (PTPCAM)
« Reply #7 on: 16 / January / 2014, 23:05:11 »
If you are using multiple partitions, you need to make sure the scripts are on the "large" partition. However, the IXUS230 shouldn't require multiple partitions.

using chdkptp, try

Code: [Select]
ls CHDK/LUALIB

If the camera has very low free memory, that could also cause problems. You can get the free memory using

Code: [Select]
=return get_meminfo()
Don't forget what the H stands for.


Re: cannot open modelist.lua causing issue? (PTPCAM)
« Reply #8 on: 19 / January / 2014, 12:07:18 »
Hi reyalp, thank you for your reply. Perhaps I have not installed something properly, because I get the following when running the 'ls' and '=return' commands:

Code: [Select]
D:\chdkptp>chdkptp -i
___> ls CHDK/LUALIB
ERROR: D:\chdkptp\lua\chdku.lua:118: attempt to index field 'apiver' (a nil valu
e)
stack traceback:
        D:\chdkptp\lua\chdku.lua:118: in function 'is_ver_compatible'
        D:\chdkptp\lua\chdku.lua:627: in function <D:\chdkptp\lua\chdku.lua:609>

        (tail call): ?
        D:\chdkptp\lua\chdku.lua:144: in function 'listdir'
        D:\chdkptp\lua\cli.lua:1237: in function <D:\chdkptp\lua\cli.lua:1227>
        (tail call): ?
        (tail call): ?
        [C]: in function 'xpcall'
        D:\chdkptp\lua\cli.lua:239: in function 'execute'
        D:\chdkptp\lua\cli.lua:323: in function <D:\chdkptp\lua\cli.lua:320>
        (tail call): ?
        D:\chdkptp\lua\main.lua:227: in main chunk
        [C]: in function 'require'
        [string "require('main')"]:1: in main chunk
___>

I also ran the chdkptp check command shown in the README.TXT:
Code: [Select]
chdkptp -e"exec require'tests':runall()"
...and it looked ok:

Code: [Select]
D:\chdkptp>chdkptp -e"exec require'tests':runall()"
dirname:start
dirname:ok
extend_table:start
extend_table:ok
argparser:start
argparser:ok
lbufutil:start
lbufutil:ok
fsmisc:start
fsmisc:ok
basename:start
basename:ok
splitjoin_cam:start
splitjoin_cam:ok
lbuff:start
lbuff:ok
dirname_cam:start
dirname_cam:ok
joinpath:start
joinpath:ok
basename_cam:start
basename_cam:ok
lbufi:start
lbufi:ok
compare:start
compare:ok
lbuf:start
lbuf:ok
bit_util:start
bit_util:ok
round:start
round:ok
ustime:start
ustime:ok
serialize:start
serialize:ok

D:\chdkptp>

*

Offline reyalp

  • ******
  • 11335
Re: cannot open modelist.lua causing issue? (PTPCAM)
« Reply #9 on: 19 / January / 2014, 17:41:13 »
Hi reyalp, thank you for your reply. Perhaps I have not installed something properly, because I get the following when running the 'ls' and '=return' commands:
You need to connect first, e.g.  chdkptp -c -i

The confusing error has been fixed in svn, but I haven't uploaded a new build yet.
Don't forget what the H stands for.

 

Related Topics